Nao Usami
Posts: 1
Joined: Tue Nov 20, 2018 9:45 am

GUIが起動しません

Tue Nov 20, 2018 10:39 am

Raspberry Pi 3 B+を使用しています。
OSはRaspbianで、2018年6月頃ダウンロードしたものです。

使い始めて5ヶ月くらいになりますが、最近まで正常に起動していました。
カメラモジュールで写真や動画の撮影をする用途で使用していましたが、
ある日、バッファが足りないというエラーが出てしまい、撮影ができなくなり、電源を落としました。
そして再度電源をつけたところ、GUIが起動しなくなりました。

電源をつけ、ラズベリーのマークが表示され、Welcome to RaspberryPiの画面は出るのですが、
そのあと黒い画面になり、左上にカーソルが点滅しているだけで、デスクトップ画面が起動しません。

Ctrl+Alt+F1でCUIを起動できますが、rebootしても同じ結果になります。

PowerのランプもActもどちらも点灯しているのでRaspberryPi本体ではなくSDカードが原因だと思います。
試しに、別のRaspberryPiで起動してみても同じ結果でした。

SDカードをフォーマットし直さなければいけないのでしょうか?


SDカードに入っている写真や動画のデータが消えていないか心配です… :? :?

宜しくお願いします……

User avatar
masafumi_ohta
Forum Moderator
Forum Moderator
Posts: 407
Joined: Sun Sep 09, 2012 12:07 am
Location: Tokyo
Contact: Website

Re: GUIが起動しません

Wed Nov 21, 2018 12:35 am

うさみさんすいません。
Nao Usami wrote:
Tue Nov 20, 2018 10:39 am
Raspberry Pi 3 B+を使用しています。
OSはRaspbianで、2018年6月頃ダウンロードしたものです。

使い始めて5ヶ月くらいになりますが、最近まで正常に起動していました。
カメラモジュールで写真や動画の撮影をする用途で使用していましたが、
ある日、バッファが足りないというエラーが出てしまい、撮影ができなくなり、電源を落としました。
まずこのエラーの具体的メッセージ内容を教えてください。
Nao Usami wrote:
Tue Nov 20, 2018 10:39 am
そして再度電源をつけたところ、GUIが起動しなくなりました。

電源をつけ、ラズベリーのマークが表示され、Welcome to RaspberryPiの画面は出るのですが、
そのあと黒い画面になり、左上にカーソルが点滅しているだけで、デスクトップ画面が起動しません。

Ctrl+Alt+F1でCUIを起動できますが、rebootしても同じ結果になります。

PowerのランプもActもどちらも点灯しているのでRaspberryPi本体ではなくSDカードが原因だと思います。
試しに、別のRaspberryPiで起動してみても同じ結果でした。

SDカードをフォーマットし直さなければいけないのでしょうか?
いいえ、まずはログを確認していただけませんか?

/var/log/Xorg.0.log

また、
startx
あるいは
xinit
などXを立ち上げるコマンドは動きますか?エラーがでたら、すいません、そのメッセージの仔細をいただけませんか?

また、ホームディレクトリのX関係のファイルが壊れたかもなので、を一旦

ls -a
で、.Xauthorityなど関係ファイルをみて、一旦退避させて、再度startxあるいはxinitを立ち上げてみてください。

最後に、raspi-configでDesktopの項目で、
3 Enable Boot to Desktop/Scratch Choose whether to boot into a des...
を選択いただき、
Desktop Log in as user 'pi' at the graphical desktop
を選んで試してみてください。
Nao Usami wrote:
Tue Nov 20, 2018 10:39 am

SDカードに入っている写真や動画のデータが消えていないか心配です… :? :?

宜しくお願いします……
申し訳ないです、情報が不足していて壊れたかどうかはわかりません。
---
Masafumi Ohta
https://groups.google.com/d/forum/japanese-raspberry-pi-users-group

Return to “日本語”