giordan
Posts: 1
Joined: Thu Jul 18, 2019 10:24 pm

Avvio da scheda sd

Thu Jul 18, 2019 10:44 pm

Ciao Raga
mi chiamo giovanni e sto provando un raspberry p3+ da usare per un cloud con nextcloud
sistema raspbian 10 installato su disco sata esterno della wd

ho un problema e mi serve una mano, ho spostato il sistema su un disco sata esterno autoalimentato della WD, il sistema parte e funziona, il problema è il reboot, con riavvio, spegnimento o se va via la corrente non riparte più, per farlo ripartire devo spegnere il disco sata, spegnere il raspberry, accendere il disco e aspettare 5/10 secondi che si avvia e poi accendere il rasberry.

Dato che lo devo usare per un cloud, ogni volta che va via la corrente o si spegne per altri motivi (tipo un reboot) devo andare ad accenderlo a mano.
mi serve una soluzione, oppure lasciare il sistema sul disco sata e spostare il boot sulla scheda sd (attualmente la scheda non è inserita).

mi date qualche dritta

willy_pinguino
Posts: 696
Joined: Sun Jan 22, 2017 9:11 pm

Re: Avvio da scheda sd

Mon Jul 29, 2019 2:49 pm

i problemi a cui ti trovi di fronte sono di 2 tipi, il fatto che l'hd meccanico non è un fulmine in avvio e il fatto che il raspberry se non ha subito presente la periferica di boot non è in grado di leggerla e quindi si blocca non sapendo cosa fare.

la soluzione più veloce e sicura per tutto il sistema sarebbe di mettere un gruppo di continuità "allways on" che alimenti il tutto, così da prevenire anche i brevi salti di corrente (allways-on vuol dire che ciò che è attaccato al gruppo di continuità, è alimentato sempre dalla batteria e la batteria viene costantemente alimentata se c'è corrente, quindi se manca la corrente, non si ha mai un'interruzione della corrente, nemmeno per un attimo).

la seconda strada può essere il cambiare l'hd meccanico con un ssd (che appena alimentato è disponibile molto più velocemente di un hd meccanico) e comunque provare a cambiare un opzione nel file config.txt aggiungendo questa linea di comando:

Code: Select all

boot_delay = 5
che rimanda il boot di 5 secondi rispetto all'accensione del raspberry. Ovviamente puoi testare tempi diversi, per aspettare che il tuo hd sia disponibile al sistema operativo cambiando il valore di delay.
Comunque avere il sistema operativo su hd meccanico ti espone a parecchi problemi, hai valutato l'opzione di tenere su hd solo la cartella home dell'utente?

Return to “Italiano”