zioken
Posts: 4
Joined: Mon Mar 19, 2018 12:25 pm

Problema audio/crackling Rpi3

Mon Mar 19, 2018 9:40 pm

Ciao a tutti!
Poiché non ho trovato nessuna soluzione da nessuna parte in internet, descrivo qui il mio problema audio.

Il mio RPI3 è collegato a una TV al plasma Panasonic con un cavo Hdmi.
Ho installato l'ultima versione di Raspbian con Berryboot o l'ho aggiornata con update e dist upgrade

Tutto funziona bene, solo l' audio nei video che guardo ha un fastidioso scricchiolio (crackling/popping noise)Simile ai vecchi giradischi quando si trova tanta polvere sul disco.in più si sente una leggera distorsione o un blocco totale del audio.

I video e i film di YouTube in streaming hanno tutti questo problema in Chromium e Firefox.
Anche i video che faccio partire da youtube su VLC hanno questo rumore,pero si sente un leggero miglioramento.

Un force hdmi in config non ha apportato alcun miglioramento.

Su un altro televisore di Sony, l'audio il problema addiritura peggiora.

Ora ho installato il browser Kweb, dove il problema sparisce.

Sfortunatamente, le popolari pagine stream non funzionano su kweb ovvero non si riesce a farli partire tramite omxplayer.

Ho provato due cavi hdmi e un altro televisore ma il problema persiste.
L'alimentatore ha 5v-2500ma percio dovrebbe bastare.

Non so piú cosa fare.
Penso che si tratta piú di un problema software che hardware... siccome su VLC migliora e su Kweb sparisce.

Sono un principiante assoluto di Linux quindi le soluzioni devono essere descritte passo dopo passo siccome sono poco pratico in terminal e editori vari..

Saluti e grazie in anticipo.

nicolap8
Posts: 336
Joined: Mon Mar 13, 2017 9:45 pm

Re: Problema audio/crackling Rpi3

Mon Mar 19, 2018 11:38 pm

Ciao,
probabilmente il problema non è dalla parte dello HDMI ma della CPU!
Ovvero i browser (ormai sono diventati due affaroni mastodontici) consumano troppo tempo della CPU e questa non riesce a "tenere il ritmo" dell'audio.
N

zioken
Posts: 4
Joined: Mon Mar 19, 2018 12:25 pm

Re: Problema audio/crackling Rpi3

Tue Mar 20, 2018 12:33 am

Potrebbe essere, ma allora tutti dovrebbero avere questo problema usando raspbian e chromium!?

Ho provato anche video in 144p ma non cambia niente.


Domani farò dei test con una chiavetta usb con musica e video.

Grazie per la prima risposta!

davidequack
Posts: 232
Joined: Thu Feb 05, 2015 8:39 am

Re: Problema audio/crackling Rpi3

Wed Mar 21, 2018 10:16 am

zioken wrote:
Tue Mar 20, 2018 12:33 am
Potrebbe essere, ma allora tutti dovrebbero avere questo problema usando raspbian e chromium!?
Purtroppo è così. Magari il problema è diverso da macchina a macchina, ma un desktop replacement non riesci a farlo nemmeno con il nuovo PI 3 B+. Ormai i browser sono dei pachidermi che devono fare mille cose. Hanno bisogno di CPU e GPU di categoria superiore.

zioken
Posts: 4
Joined: Mon Mar 19, 2018 12:25 pm

Re: Problema audio/crackling Rpi3

Wed Mar 21, 2018 11:20 am

ma un desktop replacement non riesci a farlo nemmeno con il nuovo PI 3 B+
Mi hai fatto risparmiare soldi,ero giá tentato di prendermi quello sperando di risolvere il problema =)

Forse questo spiega perché nel browser Kweb si sente abbastanza bene, siccome e stato progettato per essere "leggero"

Ma se installo un media center risolvo tutto ma devo rinunciare a un browser?

willy_pinguino
Posts: 696
Joined: Sun Jan 22, 2017 9:11 pm

Re: Problema audio/crackling Rpi3

Tue Mar 27, 2018 10:10 am

oltre che leggero kweb come dici giustamente usa omxplayer per mostrarti i video, e il problema sparisce, quindi il problema stà nel tipo di accellerazione hardware usa il browser/mediaplayer per riprodurre il video in oggetto.

VLC ed i browser fano tutto a carico della cpu, OMXplayer usa la gpu e la decodifica in hardware.

non so se nei browser si può migliorare questa cosa, in VLC sipuò provare a cambiare modalità di decodifica, ma devi controllare che versione hai di VLC e come va impostato il tutto perchè ci sono state in passato modalità diverse per versioni diverse, e non è nemmeno detto che si possa portare il tutto a buon fine

forse nei browsers puoi provare a cambiare l'applicazione predefinita per video e audio in omxplayer, ma non ci giurerei

per contro puoi anche provare a scaricare omxd https://github.com/subogero/omxd che è un piccolo demone che rende possibile lanciare i video in streaming da youtube direttamente da OMXplayer da riga di comando. è uno sbattimento in più ma dovrebbe poter ampliare un po' l'orizzonte del visualizzabile direttamente, anche perchè omxd permette anche di fare delle playlist miste tra youtube e brani che hai sul raspi o nella tua rete interna, e legato a quel progetto c'è anche un controllo remoto da usare da cell o tablet o altro computer (si basa su pagina web quindi è compatibile con più o meno tutto)

DVD77
Posts: 1
Joined: Sat May 05, 2018 6:47 pm

Re: Problema audio/crackling Rpi3

Sat May 05, 2018 6:54 pm

Ho risolto così:

Start-->internet, andare sull'icona di chromium, tasto destro "proprietà"
Scheda "elemento scrivania"
comando :chromium-browser --audio-buffer-size=4096 %U

Spero possa aiutarti.
Saluti

Return to “Italiano”