baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Problemi porta ethernet

Sat Mar 28, 2015 8:40 am

Ciao, è da circa un' anno che uso il raspberry modello b (collegato in ethernet) come media center (openelec) e mi sono trovato sempre bene con la condivisione SMB e caricando i contenuti (la maggior parte SD) dalla rete locale senza rallentamenti. Avevo notato fin dall' inizio una lentezza nell' accesso a contenuti online (tipo youtube o altro) ma non ci avevo dato molto peso. Ieri ho collegato per prova un adattatore usb wireless e ho notato con stupore come la connessione fosse molto veloce rispetto al cavo (contenuti online senza buffering). Ho una adsl normale ma con cavo arrivo al massimo a 80/90 Kb/s mentre con il wifi arrivo a 400/500 Kb/s che è il limite della mia linea. Ho fatto anche altre prove con un portatile collegato sulla stessa porta del router e non ho avuto problemi ( quindi escludo problemi di cavo e di collegamento)
Come si spiega questo funzionamento? Possibile che la porta ethernet sia guasta in questo modo anomalo? Come posso testare in modo preciso la velocità sulla rete locale per vedere se è limitata anche quella (possibile che in locale funzioni bene e in internet no)? Potrei richiedere la sostituzione della board; l'ho presa su amazon.
Potrei collegarmi tramite wifi e ignorare il problema ma mi rompe eliminare l' ethernet che dobrebbe essere la connessione più stabile.
Avete altri suggerimenti o prove che posso fare.

Grazie.

davidequack
Posts: 232
Joined: Thu Feb 05, 2015 8:39 am

Re: Problemi porta ethernet

Sat Mar 28, 2015 9:48 am

Il firmware lo tieni aggiornato?

User avatar
m3nhir
Posts: 117
Joined: Sat Mar 21, 2015 11:53 am

Re: Problemi porta ethernet

Sat Mar 28, 2015 1:07 pm

prova anche a cambiare la porta ethernet sul router e controllare le impostazioni dello stesso.

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Sat Mar 28, 2015 6:02 pm

Penso di si..... ho l'ultima versione di Openelec installata sulla sd card. Se vado su informazioni di Kodi il kernel è 3.17.8 e Openelec 5.0.6.

Grazie.

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Sat Mar 28, 2015 6:31 pm

La porta del router ho già provato a cambiarla e i settaggi gli ho controllati... C'è qualche parametro particolare del router? Perchè se connetto il portatile scarica bene.

Ciao.

davidequack
Posts: 232
Joined: Thu Feb 05, 2015 8:39 am

Re: Problemi porta ethernet

Sat Mar 28, 2015 6:44 pm

C'è qualche dispositivo connesso al router che ti fa collassare la rete a 10 mbit/sec?

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Mon Mar 30, 2015 6:24 pm

Non dovrebbbero esserci altri dispositivi..... anche perche gli altri pc sulla rete scaricano bene.
Boh... L'unica è comprarmi una chiavetta wifi.... Avete da consigliarmene una compatibile(e semplice da installare - autoriconoscimento) tra Edimax EW-7811Un o qualche altra (out-of-the-box ??).

Ciao.

troombatzia
Posts: 501
Joined: Fri Jun 29, 2012 4:27 pm

Re: Problemi porta ethernet

Mon Mar 30, 2015 6:35 pm

Scusa, il problema dello scaricamento con qualsiasi OS? Usi un VPN? E' riportato in rete che VPN rallenta il collegamento ethernet.
English isn’t my first language, so please excuse any mistakes.

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Tue Mar 31, 2015 10:32 am

Non mi sembra che siano configurati VPN..... ho provato OSMC, e Raspbmc come media system; ho anche una sd con su raspbian dove ho provato a fare una prova di download con il comando
wget -O /dev/null http://speedtest.wdc01.softlayer.com/do ... test10.zip e non supero mai i 100/130 Kb/s dove con il wireless arrivo a 400/500 Kb/s.

Grazie.

troombatzia
Posts: 501
Joined: Fri Jun 29, 2012 4:27 pm

Re: Problemi porta ethernet

Tue Mar 31, 2015 1:52 pm

baskabaska wrote:Non mi sembra che siano configurati VPN..... ho provato OSMC, e Raspbmc come media system; ho anche una sd con su raspbian dove ho provato a fare una prova di download con il comando
wget -O /dev/null http://speedtest.wdc01.softlayer.com/do ... test10.zip e non supero mai i 100/130 Kb/s dove con il wireless arrivo a 400/500 Kb/s.

Grazie.
Se hai provato pure Raspian e hai lo stesso problema sembra effettivamente che qualcosa non vada. Un ultimo test che potresti fare è provare, se ne hai a casa, uno di quegli adattatori USB -- > ethernet e vedere se con quello va meglio.
English isn’t my first language, so please excuse any mistakes.

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Tue Mar 31, 2015 6:08 pm

Non ho provato il download col wifi con raspbian perchè devo capire come configurarlo. Ma sicuramente il download con il cavo è lento.

Ciao.

baskabaska
Posts: 11
Joined: Fri Mar 27, 2015 2:57 pm

Re: Problemi porta ethernet

Thu Apr 09, 2015 9:47 pm

Ciao, riprendo questa discussione con alcuni snap shoot.
Configurazione ethernet e download con wget:
Image
Download/upload rete locale con ethernet:
Image
Configurazione wifi e download con wget:
Image
Download/upload rete locale con wifi:
Image
Come è possibile questa cosa? Puo essere un malfunzionamento del chip ethernet?

Grazie.

aiemstrong
Posts: 1
Joined: Sun Oct 09, 2016 8:51 am

Re: Problemi porta ethernet

Sun Oct 09, 2016 1:25 pm

Ciao,
Anche io con lo stesso problema.
Aggiungo che ho provato anche a disabilitare la scheda da codi, e con il cavo attaccato alla lan , mi rallenta anche il portatile connesso in wifi.
Per caso hai trovato qualche soluzione?

Grazie.

davidequack
Posts: 232
Joined: Thu Feb 05, 2015 8:39 am

Re: Problemi porta ethernet

Tue Oct 11, 2016 7:55 am

Mi sembra strano, ma potrebbe essere che l'autosense di uno switch, hub o router nella catena decida che il raspberry debba andare a 10 megabit/sec invece che a 100 megabit/sec.

La prova del nove sarebbe avere un buon hub e un secondo computer, isolarli da resto della rete, e provare a copiare dei file tra il raspberry e il computer.

Return to “Italiano”