Page 1 of 1

Calibrating axis joystick problem

Posted: Wed Jan 29, 2014 1:40 pm
by 50l3r
Image

I acquired this interface with buttons for 2 players (http://www.arcadeoutlet.es/es/interface ... sb-2p.html #)

I follow this steps to connect my joysticks with raspberry pi (http://angelverde.info/configuracion-av ... mic-koala/)

I have done all the steps to the calibration of dipositive. I recognized it as Bus 001 Device 009: ID 16c0: 05e1 VOTI CDC-ACM class devices (modems)

The fact is that to calibrate eg axis 0, my device only returns 1 when I move it to the right and 0 in the center and left. In the tutorial says it should return 0, 128 and 255. The axis 1 returns 1 when I move it down and 0 in all other cases.

This results in the mame me, I just work right, bottom and buttons. Left and above does not work.

In windows all joysticks and buttons works fine.

I have run jstest / dev/input/js0 me and detects all buttons and right / bottom of the two joysticks.

js call only detect 4 axis. But i have 2 joysticks:

Code: Select all

Joystick has 4 axes and 22 buttons.
Correction for axis 0 is broken line, precision is 0.
Coeficients are: 0, 0, 536870912, 536870912
Correction for axis 1 is broken line, precision is 0.
Coeficients are: 0, 0, 536870912, 536870912
Correction for axis 2 is broken line, precision is 0.
Coeficients are: 0, 0, 536870912, 536870912
Correction for axis 3 is broken line, precision is 0.
Coeficients are: 0, 0, 536870912, 536870912
Image

Re: Calibrating axis joystick problem

Posted: Thu Jan 30, 2014 11:19 pm
by StrawberryDorbs
I'm also having exactly the same problem as you. Right side works fine, left side doesn't at all. On windows it's calibrated fine, all sides working as they should.

When I run the jcal I get exactly the same message too. Very frustrating.

I read somewhere about someone having a similar problem and installing a i386.deb package. Whenever I try and put this on usb and find it on my pi, it doesn't show up on the usb stick?

Re: Calibrating axis joystick problem

Posted: Fri Jan 31, 2014 1:32 am
by 50l3r
i execute tail -f /var/log/syslog when i plug in/out the usb joystick

Code: Select all

Jan 31 01:10:54 raspberrypi kernel: [   48.458230] usb 1-1.3: USB disconnect, device number 5
Jan 31 01:10:57 raspberrypi kernel: [   51.253379] usb 1-1.3: new low-speed USB device number 6 using dwc_otg
Jan 31 01:10:57 raspberrypi kernel: [   51.360054] usb 1-1.3: New USB device found, idVendor=16c0, idProduct=05e1
Jan 31 01:10:57 raspberrypi kernel: [   51.360087] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan 31 01:10:57 raspberrypi kernel: [   51.360104] usb 1-1.3: Product: THT Arcade console 2P USB Player
Jan 31 01:10:57 raspberrypi kernel: [   51.360119] usb 1-1.3: Manufacturer: THT
Jan 31 01:10:57 raspberrypi kernel: [   51.378515] input: THT THT Arcade console 2P USB Player as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.0/input/input3
Jan 31 01:10:57 raspberrypi kernel: [   51.380388] hid-generic 0003:16C0:05E1.0004: input,hidraw2: USB HID v1.01 Joystick [THT THT Arcade console 2P USB Player] on usb-bcm2708_usb-1.3/input0

Re: Calibrating axis joystick problem

Posted: Fri Jan 31, 2014 1:54 am
by 50l3r
I found this possible solution http://www.raspberrypi.org/phpBB3/viewt ... 4&start=25

Need to recompile the kernel raspbian, if you are using this operating system. My knowledge not reach there :(