stu232
Posts: 14
Joined: Mon Dec 24, 2012 7:06 pm

Transfered Quake3 onto USB - now it won't boot.

Wed Dec 26, 2012 10:30 pm

With the help of a few tutorials I finally managed to build a working copy of Quake 3 :)

I copied the 'release-linux-arm' folder (and all sub folders) over onto a usb stick but when I try to run it I'm told that permission is denied!?

Total Linux n00b here, please be gentle. :)

efflandt
Posts: 359
Joined: Mon Dec 03, 2012 2:47 am
Location: Elgin, IL USA

Re: Transfered Quake3 onto USB - now it won't boot.

Thu Dec 27, 2012 6:12 pm

FAT32 (or what Linux calls vfat) has no concept of directory or file permissions. Linux simulates file permissions, but since accidentally executing a file could have undesirable consequences, so execute permission for files is typically disabled by default. But with a mount option you can give all files on the USB execute and write permissions (to also record levels or scores).

Initially (once) you need to create a mount point (you likely already did this):

Code: Select all

sudo mkdir /media/usbmem
Then mount the USB partition with fmask that basically gives all files 777 permissions:

Code: Select all

sudo mount -o fmask=000 -t vfat /dev/sda1 /media/usbmem
You can either symlink (ln -s) the path to something on that to your home directory, or create a script in your personal ~/bin that cd's to the necessary directory and does sudo ./ioquake3.arm

Alternately an /etc/fstab entry could be used to mount it easily, but I need to test to see what would work best for that, especially if that USB device is not always present.

Return to “Gaming”