Page 1 of 1

XASH-3D 2019

Posted: Thu Mar 21, 2019 3:25 pm
by bro55ther
How can I install xash3d in 2019 old tutorials dont work. Thanks!

Re: XASH-3D 2019

Posted: Sat Mar 23, 2019 12:03 am
by Gess1t

Re: XASH-3D 2019

Posted: Fri May 17, 2019 2:54 pm
by Moonmarch
There is no available .deb file you can install for RPI, you need to build the program yourself, you can find guides on how to compile xash3d on the RPI in the Raspberry Pi forums or Reddit. To run xash3d, you will need the "valve" folder from a installation of "half-life," which can only be installed on a x86/x64 computer.

Here is what I can tell you about compiling xash3d, you need to compile "half-life sdk" to receive the "hl.so" and "client.so" files, if these files are not compiled, then you can't run xash3d even after compiling the xash3d program, the xash3d program cannot read the "hl.so" file or the "client.so" file that is included in the valve folder.