Alkimistta
Posts: 21
Joined: Mon Sep 22, 2014 11:07 pm

Imposible hacer funcionar disco xt3 y Trasnsmission

Mon Oct 27, 2014 12:06 pm

Buenas, voy a ver si me explico bien y no os doy mucho la vara porque ayer domingo acabe con mucho dolor de cabeza y acostándome a la 1000.

Hace poco adquirí mi Raspberry, instale Raspbian y un disco externo de 1Tb en formato ntfs junto a Transmisión, me funcionaba todo perfectamente lo que pasaba que era un grandísimo incordio era que no era capaz de mantener la raspberry con una velocidad de descarga constante y un archivo tardaba 3 veces y 4 veces mas de tiempo en descargarse.

Como ya empecé con ciertos errores y demás, decidí rápidamente formatear el disco desde la Raspberry en formato ext4, después siguiendo los manuales que ya había utilizado cuando lo monté como nfts hice los directorios para el Transmission y lo monté, aparentemente estaba todo correcto, pero tras reiniciar la Raspberry y poner a descargar un par de torrents para ver que tal (he de decir que el problema de la velocidad ya se ha arreglado, ya baja a la máxima de mi línea perfectamente) zas! me da error de espacio en disco....problema: no me estaba descargando en el disco duro si no en la tarjeta microsd del sistema.

Volví a empezar y he probado todas las configuraciones posibles y no hay manera, primero que el automontado no me funciona, porque lo tengo que seguir montando dando la orden y segundo ahora los archivos torrents me dan 2 tipos de errores algunos me dicen que no hay directorio (creo) me ponen error: not a directory y otro error es que no hay disco y que me asegure que tengo el disco conectado. Salgo y miro desde la consola y aparentemente esta montado no entiendo que pasa.

Para automontar edito el fichero fstab y añado al final /dev/sda1 xt4 0 0, así es como lo hice con el nfts y funcionó a la primera, pero nada no hay manera si hago un df -h no aparece el disco tengo que montarlo a mano con el comando sudo mount /dev/sda1 /media/descargas, pero vamos que aunque se monte con este comando luego el Transmission empieza a darme esos errores y ya no se que hacer.

Será porque antes tenía el disco instalado en el sitema como nfts? Debería añadirlo a fstab mejor con su UUID?

Estoy con un dolor de cabeza.....espero me podáis echar una mano....lo he intentado varias veces y nada.

User avatar
actkk2000
Posts: 1309
Joined: Wed Apr 02, 2014 3:22 am

Re: Imposible hacer funcionar disco xt3 y Trasnsmission

Mon Oct 27, 2014 12:51 pm

Mejor deja que el SO se encargue de detectar el sistema de archivos del disco.
Para ello usa los parámetros "auto" y "defaults" en la línea de fstab:

Code: Select all

/dev/sda1  /media/descargas  auto  defaults,noatime  0  0
Mas información sobre fstab aquí:
https://wiki.archlinux.org/index.php/Fstab_(Español)

Slds!
Last edited by actkk2000 on Fri Nov 07, 2014 4:41 am, edited 1 time in total.
Robot +Camara +Sensores +Encoder +Servo +Matriz8x8 +Joystick:
https://www.raspberrypi.org/forums/viewtopic.php?f=76&t=130470

Alkimistta
Posts: 21
Joined: Mon Sep 22, 2014 11:07 pm

Re: Imposible hacer funcionar disco xt3 y Trasnsmission

Tue Oct 28, 2014 8:38 pm

actkk2000 wrote:Mejor deja que el SO se encargue de detectar el sistema de archivos del disco.
Para ello usa los parámetros "auto" y "defaults" en la línea de fstab:

Code: Select all

/dev/sda1  /media/descargas  auto  defaults,noatime  0  0
Mas información sobre fstab aquí:
https://wiki.archlinux.org/index.php/Fs ... a%C3%B1ol)

Slds!

Ahora si me lo monta gracias!! El problema que tengo es que no dirige bien las descargas del Transmission al disco y deja las incompletas en la sd, pero bueno eso lo mirare a ver...

User avatar
actkk2000
Posts: 1309
Joined: Wed Apr 02, 2014 3:22 am

Re: Imposible hacer funcionar disco xt3 y Trasnsmission

Wed Oct 29, 2014 12:36 am

Para configurar el directorio de Transmission puedes hacerlo de dos maneras:
1- Abrir la consola y editar el archivo de configuracion
sudo nano /etc/transmission-daemon/settings.json
- Buscar la línea "download-dir": y allí reemplazar por la ruta donde quieres descargar.
Ejemplo:

Code: Select all

       "download-dir": "/media/<nombre de dispositivo>/torrents"
2- Abrir la pagina web de transmission e ir a las opciones y allí editar la configuración (click para ampliar):
Image
Image

Debes tener en cuenta también los permisos del directorio, lo mejor es darle todos, a menos que estés dando acceso a gente externa:

Code: Select all

 sudo chmod 777 /media/<nombre de dispositivo>/torrents
Slds!
Robot +Camara +Sensores +Encoder +Servo +Matriz8x8 +Joystick:
https://www.raspberrypi.org/forums/viewtopic.php?f=76&t=130470

Alkimistta
Posts: 21
Joined: Mon Sep 22, 2014 11:07 pm

Re: Imposible hacer funcionar disco xt3 y Trasnsmission

Wed Oct 29, 2014 5:51 pm

actkk2000 wrote:Para configurar el directorio de Transmission puedes hacerlo de dos maneras:
1- Abrir la consola y editar el archivo de configuracion
sudo nano /etc/transmission-daemon/settings.json
- Buscar la línea "download-dir": y allí reemplazar por la ruta donde quieres descargar.
Ejemplo:

Code: Select all

       "download-dir": "/media/<nombre de dispositivo>/torrents"
2- Abrir la pagina web de transmission e ir a las opciones y allí editar la configuración (click para ampliar):
Image
Image

Debes tener en cuenta también los permisos del directorio, lo mejor es darle todos, a menos que estés dando acceso a gente externa:

Code: Select all

 sudo chmod 777 /media/<nombre de dispositivo>/torrents
Slds!
Al final un caos total, no había manera de arreglarlo. He cortado por lo sano, he formateado la microsd y he vuelto a empezar de 0 instalando sistema, disco, y demás.

Ya por fin todo ok, Raspbian+HDD EXT4+Transmission+no-ip funcionando a la perfección!

Gracias!


Return to “Español”