darkcrizt
Posts: 3
Joined: Sun Jun 24, 2018 9:23 pm
Location: Mexico
Contact: Website

Raspberry 3 B no detecta cable de red

Sun Jun 24, 2018 9:36 pm

Hola buen dia.
Hace poco adquiri este modelo de Rpi y he realizado la instalación de algunos sistemas en busca de alguno que me agrade y se acople a mis necesidades. Todo esto lo he hecho por Wifi con NOOBS.
Ahora que se dio la oportunidad de poder conectar mi dispositivo por cable de red, mi Raspberry Pi no lo detecta ya que ni siquiera encienden los led, he probado con varios cables y sin exito, todo ellos tambien los probe en mi laptop y si funcionan.
He pensado que el puerto esté dañado o algo asi. Pero me gustaría pensar que puede ser cosa del sistema o se me ha pasado realizar alguna configuración.

User avatar
lmarmisa
Posts: 1233
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Raspberry 3 B no detecta cable de red

Mon Jun 25, 2018 10:27 am

Bienvenido al foro.

Antes de entrar en la consulta que solicitas, te indico un par de recomendaciones:

1) Para comprobar si el puerto Ethernet funciona o no, usa un sistema operativo fiable. Mi recomendación es utilizar Raspbian:

https://www.raspberrypi.org/downloads/raspbian/

2) Recomiendo no utilizar NOOBS sino directamente la imagen de Raspbian Strech con Desktop. En el enlace anterior tienes acceso a la descarga de la imagen y a las intrucciones de instalación, que no son complejas.

Una vez que arranque el entorno gráfico de Raspbian conéctate a wifi, abre un terminal y teclea estos comandos:

Code: Select all

sudo apt-get update
suso apt-get install ethtool
Esos dos comandos son necesarios para instalar la herramienta de análisis de Ethernet ethtool que no viene activada por defecto.

Seguidamente teclea el comando ethtool eth0:

Code: Select all

pi@rpi:~ $ ethtool eth0
Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes
pi@rpi:~ $
Deberías obtener una respuesta similar a la que te he mostrado. Fíjate sobre todo en las líneas que informan de la velocidad y de la detección del enlace:

Code: Select all

Speed: 100Mb/s
Link detected: yes
Sería bueno que nos indicaras qué valores obtienes en tu caso.

Otro comando que proporciona también información útil es ifconfig eth0

Code: Select all

pi@rpi:~ $ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr b8:27:eb:47:88:84  
          inet addr:192.168.1.58  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1f11:f7ea:e8d4:2e2f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5958526 errors:0 dropped:46596 overruns:0 frame:0
          TX packets:5905503 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1177671567 (1.0 GiB)  TX bytes:1095305788 (1.0 GiB)

pi@rpi:~ $
La línea que empieza por inet addr, en caso de que exista, muestra la dirección de red IP asignada al puerto Ethernet (en este caso 192.168.1.58)

darkcrizt
Posts: 3
Joined: Sun Jun 24, 2018 9:23 pm
Location: Mexico
Contact: Website

Re: Raspberry 3 B no detecta cable de red

Mon Jun 25, 2018 9:31 pm

lmarmisa wrote:
Mon Jun 25, 2018 10:27 am
Bienvenido al foro.

Antes de entrar en la consulta que solicitas, te indico un par de recomendaciones ...
Hola agradezco tu respuesta, mira esto es lo que recibo al ejecutar ethool

Code: Select all

Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Speed: 10Mb/s
	Duplex: Half
	Port: MII
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: no
Al ejecutar ifconfig:

Code: Select all

ifconfig eth0
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:d2:61:50  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

User avatar
lmarmisa
Posts: 1233
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Raspberry 3 B no detecta cable de red

Tue Jun 26, 2018 6:41 am

¿Has modificado de algún modo la configuración de la red por ejemplo para definir una IP estática?.

Si no has cambiado la configuración, parece que hay algún componente defectuoso en tu RPi.

Es curioso. Hace pocos días vi en los foros un problema muy raro que podría ser similar al tuyo (había algún tipo de defecto en un chip que integra el hub USB y el controlador Ethernet internos a la RPi). Aunque el diagnóstico no fue claro, parece que el forero encontró un remedio para que funcionara:

viewtopic.php?f=28&t=216510

Sólo por probar, mira a ver qué pasa con estos dos comandos:

Code: Select all

sudo dhclient eth0
ifconfig
En cualquier caso, si usas un raspbian oficial y no has tocado nada que no debieras, tu problema no parece normal. Si la RPi está en garantía, intentaría cambiarla por una que no diera problemas.

Return to “Español”