Page 1 of 1

Problema acceso a NAS con Samba

Posted: Thu Jan 26, 2017 12:49 pm
by KausDiv
Hola de nuevo.
Intento crear 3 carpetas para 2 usuarios y una compartida siguienteo este tutorial:
http://sobrebits.com/montar-un-servidor ... i-y-samba/

La cuestión es que cuando accedo desde otro ordenador con usuarios distintos de pi me da acceso denegado.

Mi configuración:
Tengo conectado a las raspi un HD
El sistema lo monta así:
/media/pi/nas001 permisos (pi:pi) posteriormente (pi:casa)
el permiso de /media/pi lo he cambiado a (pi:casa)

dentro nas001 hay tres carptas:
/media/pi/nas001/kaus propiedad de (kaus:kaus)
/media/pi/nas001/marib propiedad de (marib:marib)
/media/pi/nas001/compartida propiedad de (pi:casa)

Los usuarios: kaus, marib y pi agregados al grupo casa
y agregados al grupo samba.
Y esta es la configuración de samba:
[Marib]
comment = Nas Privado marib
path = /media/pi/nas001/marib
guest ok = no
read only = no
browseable = yes
valid users = marib
write list = marib
create mask = 0660
directory mask = 0770

(en kaus igual pero cambia carpeta y usuario)

[Compartida]
comment = carpeta compartida
path = /media/pi/nas001/compartida
guest ok = no
read only = no
browseable = yes
valid users = @ casa
write list = @ casa
create mask = 0660
directory mask = 077


¿ Que estoy haciendo mal para que no funcione ?

Re: Problema acceso a NAS con Samba

Posted: Thu Jan 26, 2017 8:35 pm
by screspo
Creo que el problema esta en algun parametro del fichero de configuracion que no has publicado.

Echa un vistazo a mi tutorial en alteageek.homelinux.org sobre como instalar un servidor samba en una raspberry. Es mas simple pero detalla todo lo que hay que cambiar en el fichero de configuracion para que funcione.

(perdonad por la falta de acentos pero estoy usando un ordenador con teclado de UK).

salu2

Santi

Re: Problema acceso a NAS con Samba

Posted: Thu Jan 26, 2017 11:45 pm
by KausDiv
Muy interesante tu web !! y sobre todo que esté en un cluste de 4 raspis.

En la mia tengo apache+msql, etc para probar apps de Django que programa.

Volviendo al NAS. No ha funcionado, agregé dos opciones de tu tutorias en el archivo smb.conf pero nada.

Decirte que antes de separar en los dos usuarios todo iba con el usuario pi, y funcionaba perfectamente.
ha sido al crear los usuarios y asignar permisos a las carpetas cuando ya no va.

Pregunto: ¿ puede tener algo que ver que todo cuelgue de /media/pi/ ?
en tu tuorial cuelga directamente de /media/

a media/pi le he asignado el grupo "casa" para que todos tengamos acceso.

Re: Problema acceso a NAS con Samba

Posted: Sat Jan 28, 2017 6:12 pm
by screspo
Entonces parece quedar claro que es un tema de usuarios y permisos.

Prueba a instalar Webmin, es una aplicación gratuita de código abierto disponible para Rasperry y que te permite gestionar Samba desde un entorno gráfico desde el navegador de cualquier ordenador de tu red.

Es muy fácil de instalar, os copio como hacerlo.

sudo wget http://prdownloads.sourceforge.net/weba ... 40_all.deb

dpkg –install webmin_1.740_all.deb

Si se produce algún error haciendo referencia al alguna dependencia, ejecutad lo siguiente:

apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python

Una vez finalizada la instalación, la aplicación será accesible desde cualquier navegador informando:

https://ipdenuestraraspberry:10000

Y nos cuentas.

salu2

Santi

Re: Problema acceso a NAS con Samba

Posted: Tue Jan 31, 2017 9:37 am
by KausDiv
Gracias screspo.

He instaldo webmin, y va genial.

Pero lo del Nas sigue sin funcionar, solo con el usuario pi desde otros ordenadores.
En algunas carpetas que he puesto nombres de usuarios distintos no se puede acceder.

Todos los ordenadores clientes son con windows 7.

Estoy por poner esto en el foro de ubuntu por si a alguien le ha pasado y sabe como resolverlo.

Gracias por webmin.
Saludos