Black-Panther86
Posts: 12
Joined: Thu Dec 05, 2019 6:18 am

Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 6:30 am

Hallo zusammen.

Seit vorgestern kann ich ein Raspberry Pi 4 4 gb mein eigen nennen :-)
Er ist sehr flott, er läuft nun gut seit 1 Tag, und 4 stunden stabil, und die Temperatur ist auch in ordnung.
Diese liegt im Leerlauf bei 33 grad, und bei Server tätigkeit (Minecraft) um die 45 grad.

Nun habe ich aber 2 Probleme festgestellt, und diese betreffen das Interne W-LAN Modul.

1. Ich kann den Raspi aufstellen wo ich will, egal ob auf 40 cm zum Router, oder auf eine Distanz von 5 metern, das Wlan Signal (Internet Speed) ist grotten schlecht.
Die Fritzbox (7490) zeigt mir an, das eine Verbindung im Downstream FB -> GERÄT von 150 Mbit/s
und vom wlan Gerät zur Fritzbox von 200 mbit's laufen soll.

Ich habe " speedtest-cli " als Speedtest auf dem Pi installiert.

Als Hauptfritzbox (Cable) läuft eine 6490, dahinter per switch ist die 7490 und agiert als Wlan schnittstelle.

Die Fritzbox 6490 zeigt einen Sync von: 212 Mbit/s im Download und 53 Mbit/s im Upload an.

Wenn ich per WLAN am Raspi den Speedtest mache, dann hat der Raspi maximal 75 mbit/s im DL wärend der Upload auf auf knapp 51-52 mbits kommt.

Ich finde das eine sehr große Verlust leistung.
Der Raspi ist dabei mittels 5ghz an meinem Wlan angebunden.

Gibt es irgendwie eine möglichkeit, aus dem WLAN Bereich die leistung zu steigern ?

2. Aufgrund der Problematik, wegen der massiven Speedeinbuße im Download, habe ich den Raspi nun doch wieder an die "leine" genommen, und hier
kann der Raspi werte erreichen, zwischen 190 - 200 mbits bei Maximalem upload.

Hier ist mir aufgefallen, das der Raspi hier über 2 wege mit dem netz kommuniziert.
Denn das WLAN Modul ist im Hintergrund Aktiv, und er hat auch einen regen datenaustausch, was ich anhand der Android App " RaspControler " festgestellt habe.

Der Raspi läuft mit dem Aktuellem Raspbian buster... in der Lite version, da der Raspi als kleiner Server dienen soll, da benötige ich keine Grafische oberfläche.

Da es aber bestimmt einige gibt, die die selben probleme haben so wie ich, wollte ich hier mal fragen, ob es
eine möglichkeit gibt dem Raspi zu sagen...

" Schau ob du Internet hast, und schaue dazu auf eth0 - ist eth0 mit internet versorgt, dann schalte wlan0 aus "

und als 2. regel " Wenn auf eth0 kein internet verfügbar, dann schalte wlan0 ein, und prüfe in einem interval von x sekunden/minuten ob eth0 verfügbar, wenn ja, dann switchen, und wlan0 wieder abschalten "

Gibt es da eventuell eine abhilfe, oder muss ich nun wo auch wlan eingerichtet ist, mit dem " Problem " leben, dass das wlan modul immer eingeschaltet ist ?
Es würde dadurch meines erachtens etwas performance verloren gehen, da er etwas aufrecht erhalten müsste, was nicht gebraucht wird.

lbog
Posts: 203
Joined: Sun Mar 06, 2016 9:44 am

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 10:02 am

Black-Panther86 wrote:
Thu Dec 05, 2019 6:30 am
Hier ist mir aufgefallen, das der Raspi hier über 2 wege mit dem netz kommuniziert.
Denn das WLAN Modul ist im Hintergrund Aktiv, und er hat auch einen regen datenaustausch, was ich anhand der Android App " RaspControler " festgestellt habe.
Versuch mal mit:

Code: Select all

net.ipv4.conf.all.arp_filter = 1
net.ipv4.conf.default.arp_filter = 1
net.ipv4.conf.eth0.arp_filter = 1
net.ipv4.conf.wlan0.arp_filter = 1
Du solltest dich aber auch vergewissern ob diese Einstellungen/Konfiguration durch die service-unit für sysctl, beim booten aktiviert werden. Wenn das nicht der Fall ist, solltest Du die service-unit für sysctl, mit einer timer-unit ca. 45 Sekunden nach dem booten, restarten.

Für die Wahl der default route, via eth0- bzw. wlan0-Interface, könntest Du ein Script schreiben, das z. B. mit Hilfe einer timer-unit prüft und das Routing (oder nur die metric der default route) ändert.

EDIT:

BTW: Schau mal in der FritzBox nach, ob das wlan0-Interface evtl. über das eth0-Interface erreicht wird (... wenn keine WLAN-Verbindung vorhanden ist).

wolf.z
Posts: 131
Joined: Thu Dec 24, 2015 8:34 pm

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 10:38 am

Black-Panther86 wrote:
Thu Dec 05, 2019 6:30 am
...
Die Fritzbox (7490) zeigt mir an, das eine Verbindung im Downstream FB -> GERÄT von 150 Mbit/s
und vom wlan Gerät zur Fritzbox von 200 mbit's laufen soll.
...
Als Hauptfritzbox (Cable) läuft eine 6490, dahinter per switch ist die 7490 und agiert als Wlan schnittstelle.

Die Fritzbox 6490 zeigt einen Sync von: 212 Mbit/s im Download und 53 Mbit/s im Upload an.
Damit sind down- und upload schon mal auf 212 bzw 53 Mbit beschränkt.
Black-Panther86 wrote:
Thu Dec 05, 2019 6:30 am
Wenn ich per WLAN am Raspi den Speedtest mache, dann hat der Raspi maximal 75 mbit/s im DL wärend der Upload auf auf knapp 51-52 mbits kommt.

Ich finde das eine sehr große Verlust leistung.
Der Raspi ist dabei mittels 5ghz an meinem Wlan angebunden.

Gibt es irgendwie eine möglichkeit, aus dem WLAN Bereich die leistung zu steigern ?
Beim Upload sicher nicht, weil der Upload vom Internet Anschluss - siehe Werte der 6490 - begrenzt wird. Im Download könnte ggfs. mehr gehen. Funkstrecke (drastisch) verkleinern. Wenn der Download schneller wird, funken andere Funker im gleichen Kanal, und dann muss sich das Gesatmsetup die Bandbreite teilen. Deine Funkstrecke funkt dann zwar mit 200Mbit brutto, aber der Kanal wird zeitlich aufgeteilt. Netto bleibt für jeden Funker weniger Bandbreite übrig.
Black-Panther86 wrote:
Thu Dec 05, 2019 6:30 am
2. ...

" Schau ob du Internet hast, und schaue dazu auf eth0 - ist eth0 mit internet versorgt, dann schalte wlan0 aus "

und als 2. regel " Wenn auf eth0 kein internet verfügbar, dann schalte wlan0 ein, und prüfe in einem interval von x sekunden/minuten ob eth0 verfügbar, wenn ja, dann switchen, und wlan0 wieder abschalten "

Gibt es da eventuell eine abhilfe,...
Versuch's mal mit metric in /etc/dhcpcd.conf, siehe https://www.raspberrypi.org/forums/view ... p?t=189582

lbog
Posts: 203
Joined: Sun Mar 06, 2016 9:44 am

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 11:20 am

Black-Panther86 wrote:
Thu Dec 05, 2019 6:30 am
..., und die Temperatur ist auch in ordnung.
Diese liegt im Leerlauf bei 33 grad, und bei Server tätigkeit (Minecraft) um die 45 grad.
BTW: Hast Du eine aktive Kühlung an deinem PI4 oder benutzt Du diesen z. Zt. ohne Gehäuse, evtl. im Freien oder in einem nicht geheizten Raum?

Black-Panther86
Posts: 12
Joined: Thu Dec 05, 2019 6:18 am

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 3:44 pm

Hallo zusammen.
Schonmal vielen lieben dank, für die Antworten, ich werde im einzelnen Versuchen was sich davon umsetzen lässt.

@wolf.z: du hast meinen Beitrag scheinbar nicht richtig durchgelesen.

Willst du mir sagen, das ein Abstand von 40 cm zwischen Fritzbox und dem Raspi nicht ausreichend sind ?
Auf die Idee, die äbstände noch kleiner zu setzen, bin ich schon gekommen.
Es macht keinen unterschied, ob auf der Fritzbox - Kontakt weniger als 7 mm -
Oder 1 Meter.. 5 meter.. 10 meter..
Das spielt im DL keine Rolle, der ist und bleibt bei den genanten 75 Mbits, von maximal 212 mbits die laut Hauptbox möglich wären.
Die maximale leistung kann nur erreicht werden, indem der Raspi mittels LAN-Kabel am Netzwerk teil nimmt.

Was das 5 ghz Wlan angeht, seh ich im Fritzbox Spektrum, das maximal 2 geräte auf dem Funkkanal eingestellt sind.
Ich musste von den Standard kanälen wechseln, weil ich ständig mit Radar Störungen zu kämpfen habe, und beide Fritzboxen das 5 ghz WLAN abschalten.

Mein Handy ist 5 ghz fähig, und hat eine weit aus höhrere Connection zur Fritzbox.
Wenn ich mit dem Smartphone einen Speedtest mache, dann erreiche ich mit dem Handy sowohl im DL als auch im UP die Maximalen werte, die der Sync der FB6490 sehr nahe kommen, + - 1 - 2 mbits. - Dies ist aber verschmerzbar.

Ich hab dazu mal einen Screenshot erstellt, aus dem was die Fritzbox sagt, wegen der Übertragsgungskapazitäten.
Screenshot 2019-12-05 16.25.53.png
Screenshot 2019-12-05 16.25.53.png (35.68 KiB) Viewed 710 times
--

@lbog: Der Raspi ist im unten verlinkten Case.
4 Passive Kühlrippen, und der Lüfter. - Diesen habe ich so verbaut, das er luft in das Gehäuse pusten soll.

https://www.amazon.de/Miuzei-Raspberry- ... ers&sr=1-1

Also ich habe es ausprobiert, das wenn an eth0 kein kabel ist, dann kann ich die IP ansprechen soviel ich möchte, die FB kann die IP nicht vermitteln, und geht ins leere.
Umgekehrt kann ich das im moment nicht testen, da ich nicht weiss wie ich das wlan abschalten soll, da ich nur Textbasiert via Putty mit dem Raspi interagiere, und keine Grafische oberfläche habe, wo es mit 2-3 klicks nun aus wäre.

lbog
Posts: 203
Joined: Sun Mar 06, 2016 9:44 am

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Thu Dec 05, 2019 4:01 pm

Black-Panther86 wrote:
Thu Dec 05, 2019 3:44 pm
Also ich habe es ausprobiert, das wenn an eth0 kein kabel ist, dann kann ich die IP ansprechen soviel ich möchte, die FB kann die IP nicht vermitteln, und geht ins leere.
Ich verstehe nicht was Du mir damit sagen willst.
Black-Panther86 wrote:
Thu Dec 05, 2019 3:44 pm
Umgekehrt kann ich das im moment nicht testen, da ich nicht weiss wie ich das wlan abschalten soll, da ich nur Textbasiert via Putty mit dem Raspi interagiere, und keine Grafische oberfläche habe, wo es mit 2-3 klicks nun aus wäre.
Naja, gerade textbasiert funktioniert das Abschalten des wlan sehr gut und einfach. Z. B. kannst Du das in der /boot/config.txt machen:

Code: Select all

dtoverlay=disable-bt
dtoverlay=disable-wifi
und/oder den WLAN-Treiber brcmfmac blacklisten und/oder wenn gerade aktiv, in der Kommandozeile den wpa_supplicant killen bzw. das wlan0-Interface mit "down" deaktivieren (... This flag causes the driver for this interface to be shut down.) bzw. mit modprobe den Treiber entladen:
sudo modprobe -rv brcmfmac
BTW: Man kann das WLAN des PI sehr gut optimieren, in dem man z. B. ein auf den PI optimiertes wpa_supplicant binary aus dem source code kompiliert, die zusätzlichen Konfigurationsmöglichkeiten des Treibers brcmfmac nutzt und die zusätzlichen Konfigurationsmöglichkeiten für den kompilierten wpa_supplicant nutzt.

wolf.z
Posts: 131
Joined: Thu Dec 24, 2015 8:34 pm

Re: Rasperry Pi 4 - Wlan Modul ist aktiv trotz Lan verbindung

Fri Dec 06, 2019 9:59 am

Black-Panther86 wrote:
Thu Dec 05, 2019 3:44 pm
Hallo zusammen.
Schonmal vielen lieben dank, für die Antworten, ich werde im einzelnen Versuchen was sich davon umsetzen lässt.

@wolf.z: du hast meinen Beitrag scheinbar nicht richtig durchgelesen.

Willst du mir sagen, das ein Abstand von 40 cm zwischen Fritzbox und dem Raspi nicht ausreichend sind ?
Auf die Idee, die äbstände noch kleiner zu setzen, bin ich schon gekommen.
Das war nur ein Hinweis, den vermuteten Fehler einzugrenzen, mehr nicht
Black-Panther86 wrote:
Thu Dec 05, 2019 3:44 pm
...Was das 5 ghz Wlan angeht, seh ich im Fritzbox Spektrum, das maximal 2 geräte auf dem Funkkanal eingestellt sind.
Ich musste von den Standard kanälen wechseln, weil ich ständig mit Radar Störungen zu kämpfen habe, und beide Fritzboxen das 5 ghz WLAN abschalten.
Das sind eher keine Radarstörungen, aber eine Diskussion dessen ist nicht zielführend. Viel wichtiger ist die Information, die aus Deinem Screenshot hevorgeht.
Black-Panther86 wrote:
Thu Dec 05, 2019 3:44 pm

Mein Handy ist 5 ghz fähig, und hat eine weit aus höhrere Connection zur Fritzbox.
Wenn ich mit dem Smartphone einen Speedtest mache, dann erreiche ich mit dem Handy sowohl im DL als auch im UP die Maximalen werte, die der Sync der FB6490 sehr nahe kommen, + - 1 - 2 mbits. - Dies ist aber verschmerzbar.
Im Screenshot siehst Du die entscheidende Information:
Handy: ac 80MHz WPA2 2x2
Raspi: n 40MHz WPA2 1x1
Das Handy ist fähig, eine Verbindung nach IEEE802.11ac aufzubauen. Handy und FB funken auf 4 20MHz Kanälen gleichzeitig, und das auch noch im 2x2 MIMO. Das sind auf beiden Seiten 2 Antennen, mit denen die Wahrscheinlichkeit erhöht wird, dass wenigstens eine von zwei Antennen gut empfangen kann. Das erhöht die Zuverlässigkeit der Funkstrecke. Handy und FB können also Brutto die stolze Datenrate von 780 bzw. 866 MBit/s. Wenn in der gesamten Verbindung die Internetanbindung wesentlich langsamer ist, reicht die viel größere Bruttokapazität des Folge-(funk-)kanals aus.
Der Raspi kann nur eine Verbindung nach IEEE802.11 n auf 2 Kanälen gleichzeitig? Das sind brutto nun mal nur 150/200 MBit. Davon erreichst Du Netto meist nur die Hälfte. Falls Du weiteren Experimentierbedarf hast, stelle mal die Fritzbox auf IEEE802.11g im 2,4GHz Band. Das sind 54MBit brutto und schau, was netto noch durchkommt.
Hier geht es um Funkstandards. Wenn Hard/Software schnellere Standards nicht unterstützt, kannst Du nichts machen.

Was mich allerdings wundert ist, dass der Raspi mit 802.11ac spezifiziert ist. Weshalb die Verbindung nur mit 802.11n zustande kommt, weiß ich auch nicht. (Ich hab keinen Raspi4)

Return to “Deutsch”