chientech
Posts: 2
Joined: Wed Dec 26, 2018 6:51 pm

PI ZERO Structure needs cleaning

Wed Dec 26, 2018 7:20 pm

Hallo.
Ich versuche gerade einen PI ZERO mit stretch zum Laufen zu bringen.

-SD formatiert
-Stretch mit Etcher aufgespielt
-ssh + wpa_supplicant.conf dazu kopiert

mit putty verbunden und egal was ich mache nach reboot geht nix mehr :evil:
Hab das ganze mehrfach versucht.
Wann immer ich etwas ändere z.B. Passwort oder Hostname sowie expand partition, bootet der PI nicht mehr.
außerdem ergibt -ls:

Code: Select all

pi@raspberrypi:~ $ ls
ls: cannot access 'Downloads': Structure needs cleaning
ls: cannot access 'Videos': Structure needs cleaning
ls: cannot access 'Documents': Structure needs cleaning
ls: cannot access 'Public': Structure needs cleaning
ls: cannot access 'Music': Structure needs cleaning
ls: cannot access 'Pictures': Structure needs cleaning
ls: cannot access 'Desktop': Structure needs cleaning
ls: cannot access 'Templates': Structure needs cleaning
Hat jemand eine Lösung für das Problem, bzw. was mach ich falsch?

fbe
Posts: 496
Joined: Thu Aug 17, 2017 9:08 pm

Re: PI ZERO Structure needs cleaning

Wed Dec 26, 2018 9:34 pm

Also wenn Du Etcher benutzt, dann brauchst Du die SD Karte vorher normalerweise nicht zu formatieren. Das ist aber nicht die Ursache Deines Problems.

Eigentlich wird die root-Partition beim ersten Booten mit einem originalen Raspbian Image automatisch vergrößert. Also was machst Du da?

Hast Du das Ganze auch mal mit einer zweiten SD Karte probiert?

smartifahrer
Posts: 870
Joined: Sat Feb 13, 2016 8:10 am

Re: PI ZERO Structure needs cleaning

Thu Dec 27, 2018 5:45 pm

Ich habe einen Pi Zero W, da hat die Installation mehrfach geklappt. Ich habe ihn aber auch nicht Remote installiert sondern mit Monitor und Tastatur dran. Fals du entsprechende Mini-Adapter hast würde ich zumindest mal ein Monitor anschliesen um zu sehen was passiert.
PHP-Entwickler, Elektroniker, Technik-Bastler. 5 Raspis mit Rasbian, Retropi und Libreelec.

chientech
Posts: 2
Joined: Wed Dec 26, 2018 6:51 pm

Re: PI ZERO Structure needs cleaning

Sun Jan 27, 2019 8:23 pm

Hallo
Danke für die Rückmeldungen.
Die Lösung war eine neue SD Karte, ich muss mir die zwei alten mit denen ich das ausprobiert hab irgendwie zerschossen haben.

Mit neuer SD Karte ging alles wie in einer der zahlreichen Anleitungen!

Return to “Deutsch”