Page 1 of 1

LineageOS

Posted: Sat Nov 24, 2018 9:03 pm
by awesomelydeluxe
Hi. I've been trying to install LineageOS (Android Oreo 8.1) from the KonstaKang website (https://androidfilehost.com/?fid=5862345805528041370). I successfully installed it on my 16 GB SD card. As soon as I insert it into my Pi 3 and plug it in, the graphics test rainbow image appears, so I'm assuming that it's working.But then after that it just goes immediately to a black screen. Is this supposed to happen or am I doing something wrong? Please help!

Re: LineageOS

Posted: Sat Nov 24, 2018 9:22 pm
by DarkPlatinum
Have you installed the correct linageOS version for your pi? Also if there is something wrong with image, don't expect to receive an update. The Dev has shut it down since there are some people who have used his open source android and sold it.

Re: LineageOS

Posted: Sat Nov 24, 2018 9:44 pm
by awesomelydeluxe
IDK check the website. It looks right to me. All I did was follow YouTube tutorials.

Re: LineageOS

Posted: Sat Nov 24, 2018 9:52 pm
by DarkPlatinum
awesomelydeluxe wrote:
Sat Nov 24, 2018 9:03 pm
Hi. I've been trying to install LineageOS (Android Oreo 8.1) from the KonstaKang website (https://androidfilehost.com/?fid=5862345805528041370). I successfully installed it on my 16 GB SD card. As soon as I insert it into my Pi 3 and plug it in, the graphics test rainbow image appears, so I'm assuming that it's working.But then after that it just goes immediately to a black screen. Is this supposed to happen or am I doing something wrong? Please help!
you need this one: https://konstakang.com/devices/rpi3/CM14.1/

Re: LineageOS

Posted: Sat Nov 24, 2018 10:12 pm
by awesomelydeluxe
DarkPlatinum wrote:
Sat Nov 24, 2018 9:52 pm
awesomelydeluxe wrote:
Sat Nov 24, 2018 9:03 pm
Hi. I've been trying to install LineageOS (Android Oreo 8.1) from the KonstaKang website (https://androidfilehost.com/?fid=5862345805528041370). I successfully installed it on my 16 GB SD card. As soon as I insert it into my Pi 3 and plug it in, the graphics test rainbow image appears, so I'm assuming that it's working.But then after that it just goes immediately to a black screen. Is this supposed to happen or am I doing something wrong? Please help!
you need this one: https://konstakang.com/devices/rpi3/CM14.1/
What will Nougat do vs Oreo? Just curious.

Re: LineageOS

Posted: Sat Nov 24, 2018 10:18 pm
by DarkPlatinum
awesomelydeluxe wrote:
Sat Nov 24, 2018 10:12 pm
DarkPlatinum wrote:
Sat Nov 24, 2018 9:52 pm
awesomelydeluxe wrote:
Sat Nov 24, 2018 9:03 pm
Hi. I've been trying to install LineageOS (Android Oreo 8.1) from the KonstaKang website (https://androidfilehost.com/?fid=5862345805528041370). I successfully installed it on my 16 GB SD card. As soon as I insert it into my Pi 3 and plug it in, the graphics test rainbow image appears, so I'm assuming that it's working.But then after that it just goes immediately to a black screen. Is this supposed to happen or am I doing something wrong? Please help!
you need this one: https://konstakang.com/devices/rpi3/CM14.1/
What will Nougat do vs Oreo? Just curious.
Yeh am afraid I can't answer that. Your probably going to have to look around online for differences.

Re: LineageOS

Posted: Sun Nov 25, 2018 5:52 am
by awesomelydeluxe
I tried that version and it still won't work. How long is the boot time supposed to be?

Re: LineageOS

Posted: Sun Nov 25, 2018 6:07 am
by HawaiianPi
awesomelydeluxe wrote:
Sun Nov 25, 2018 5:52 am
I tried that version and it still won't work. How long is the boot time supposed to be?
Probably best to ask on the Lineage OS support forum. Raspbian is the official OS of the Raspberry Pi, so that's what's typically supported here.

Official RPF stance on Android support.
viewtopic.php?f=73&t=71658

Lineage OS sub-forum.
viewtopic.php?f=73&t=220601

Just guessing, but if you have the newer Pi 3B+ model, Lineage OS probably wasn't updated to the newer kernel and firmware the 3B+ needs. If you have the older 3B and it's not working, then... ¯\_(ツ)_/¯

Re: LineageOS

Posted: Sun Nov 25, 2018 7:00 am
by fruitoftheloom
awesomelydeluxe wrote:
Sun Nov 25, 2018 5:52 am
I tried that version and it still won't work. How long is the boot time supposed to be?

viewtopic.php?f=73&t=220613

This states 3B+ support but for "advanced users only"

So you are on your own to get it working, maybe try ?

https://groups.google.com/forum/?nomobi ... ndroid-rpi

Re: LineageOS

Posted: Sun Nov 25, 2018 7:45 am
by r3d4
awesomelydeluxe wrote:
Sat Nov 24, 2018 9:03 pm
As soon as I insert it into my Pi 3 and plug it in, the graphics test rainbow image appears, so I'm assuming that it's working.But then after that it just goes immediately to a black screen. Is this supposed to happen or am I doing something wrong? Please help!
viewtopic.php?f=73&t=220613#p1383763
Konsta wrote:You need to use a display that supports 720p resolution (it's the maximum resolution this build supports). Maybe try with a different display or modifying config.txt (https://www.raspberrypi.org/documentati ... t/video.md) for your current one?
...
It's also difficult to get logs from the boot unless you have a serial console adapter.
so if *you* want to pursue a fix and dont have any luck with different display / settings
get ye a serial console adapter...

Re: LineageOS

Posted: Tue Nov 27, 2018 4:38 am
by awesomelydeluxe
So from what I'm seeing, it's a display problem? And BTW I do have Raspbian. I like to use different OS's.

Re: LineageOS

Posted: Tue Nov 27, 2018 2:27 pm
by HawaiianPi
r3d4 wrote:
Sun Nov 25, 2018 7:45 am
...so if *you* want to pursue a fix and dont have any luck with different display / settings
get ye a serial console adapter...
If you know the Pi is booting you could login using SSH to troubleshoot.

Although I like console cables myself for debugging. I use CP2102 USB-TTL adapters I get from ebay for less than $2. Of course the least expensive ones ship slow boat from China, but they're still under ten bucks closer to home ($6-$8).

You can even power a Pi Zero from a CP2102 USB-TTL adapter.

Re: LineageOS

Posted: Tue Nov 27, 2018 3:13 pm
by fruitoftheloom
HawaiianPi wrote:
Tue Nov 27, 2018 2:27 pm
r3d4 wrote:
Sun Nov 25, 2018 7:45 am
...so if *you* want to pursue a fix and dont have any luck with different display / settings
get ye a serial console adapter...
If you know the Pi is booting you could login using SSH to troubleshoot.

Although I like console cables myself for debugging. I use CP2102 USB-TTL adapters I get from ebay for less than $2. Of course the least expensive ones ship slow boat from China, but they're still under ten bucks closer to home ($6-$8).

You can even power a Pi Zero from a CP2102 USB-TTL adapter.

There is no "working" Android for the ARMv6 Zero & RPi 1 !

Re: LineageOS

Posted: Tue Nov 27, 2018 3:31 pm
by hippy
awesomelydeluxe wrote:
Tue Nov 27, 2018 4:38 am
So from what I'm seeing, it's a display problem?
Could be. I installed Konsta's LineageOS 14.1 (Android 7.1.2) and 15.1 (Android 8.1.0) unofficial builds on my Pi 3B (non-plus) and both worked fine a month or so ago using a standard HDMI 1080p TV.

14.1 was responsive enough for me but 15.1 was a poor experience on the 3B, and a worse version of Android anyway IMO.

Re: LineageOS

Posted: Wed Nov 28, 2018 4:34 am
by awesomelydeluxe
hippy wrote:
Tue Nov 27, 2018 3:31 pm
awesomelydeluxe wrote:
Tue Nov 27, 2018 4:38 am
So from what I'm seeing, it's a display problem?
Could be. I installed Konsta's LineageOS 14.1 (Android 7.1.2) and 15.1 (Android 8.1.0) unofficial builds on my Pi 3B (non-plus) and both worked fine a month or so ago using a standard HDMI 1080p TV.

14.1 was responsive enough for me but 15.1 was a poor experience on the 3B, and a worse version of Android anyway IMO.
Huh. So how did it even work for you?

Re: LineageOS

Posted: Wed Nov 28, 2018 11:19 am
by Konsta
Please post your questions/problems in respective LineageOS thread instead (viewtopic.php?f=73&t=220601 & viewtopic.php?f=73&t=220613).

You need to have a display that supports 720p resolution. Most normal 1080p/4K TVs/displays also support various other display modes and smaller resolutions. 720p is the maximum supported resolution with LineageOS 15.1 build. LineageOS 14.1 uses 720p by default but you can try 1080p or other resolutions by modifying config.txt (https://www.raspberrypi.org/documentati ... t/video.md) and /system/build.prop (https://github.com/lineage-rpi/android_ ... em.prop#L6). Using a bigger resolution has some impact in graphics performance, though.

Re: LineageOS_GPIO

Posted: Thu Jun 27, 2019 8:01 am
by iit
Whether Lineage OS support GPIO control throgh android command prompt??

Re: LineageOS_GPIO

Posted: Thu Jun 27, 2019 11:13 am
by Konsta
iit wrote:
Thu Jun 27, 2019 8:01 am
Whether Lineage OS support GPIO control throgh android command prompt??
Yes, all my LineageOS builds (14.1, 15.1 & 16.0) support this. See this post (https://www.raspberrypi.org/forums/view ... 3#p1404555) for examples. I've only tested this as far as blinking a LED, though. There's also support I2C and SPI devices.