vsiles
Posts: 41
Joined: Wed Feb 04, 2015 10:04 am

u-boot and ethernet on Raspberry 2

Fri Feb 27, 2015 4:57 pm

Hi,

anyone tried to use tftp or any other u-boot functions that uses Ethernet with Rpi 2 ?

Upon startup I get:

Code: Select all

DRAM:  944 MiB
WARNING: Caches not enabled
RPI 2 Model B
MMC:   bcm2835_sdhci: 0
reading uboot.env

** Unable to read "uboot.env" from mmc0:1 **
Using default environment

In:    serial
Out:   lcd
Err:   lcd
Net:   Net Initialization Skipped
No ethernet found.
Hit any key to stop autoboot:  0 
U-Boot> usb start
starting USB...
USB0:   Core Release: 2.80a
scanning bus 0 for devices... unable to get descriptor, error 0
usb_new_device: Cannot read configuration, skipping device 0424:9514
1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found
U-Boot> dhcp
No ethernet found.
Any suggestions ?

Best,
Vincent

sigjuice
Posts: 4
Joined: Thu Sep 04, 2014 7:09 am
Contact: Website

Re: u-boot and ethernet on Raspberry 2

Sat Feb 28, 2015 3:17 am

What is the version of u-boot that you are using and where is it available from?

vsiles
Posts: 41
Joined: Wed Feb 04, 2015 10:04 am

Re: u-boot and ethernet on Raspberry 2

Mon Mar 02, 2015 8:29 am

I am using the latest git source of the master branch (at http://www.denx.de/wiki/U-Boot/SourceCode)

vsiles
Posts: 41
Joined: Wed Feb 04, 2015 10:04 am

Re: u-boot and ethernet on Raspberry 2

Wed Apr 08, 2015 10:14 am

Any one got news about ethernet support for rpi 2 in u-boot ?

ghent360
Posts: 7
Joined: Thu Apr 09, 2015 8:26 am

Re: u-boot and ethernet on Raspberry 2

Thu Apr 09, 2015 8:31 am

There are some patches available. I got it working at some point. Check http://elinux.org/RPi_U-Boot for instructions.

vsiles
Posts: 41
Joined: Wed Feb 04, 2015 10:04 am

Re: u-boot and ethernet on Raspberry 2

Mon Apr 13, 2015 3:35 pm

A collegue of mine managed to clone Stephen's github in a state where usb/ethernet is actually working ! But the current head of the repository seems to fail for another (new) reason. I'll wait until Stephen has finished his work.
Thanks for the reminder !

V.

Return to “Bare metal, Assembly language”