bust
Posts: 76
Joined: Mon Mar 17, 2014 12:31 am

Problem with kernel 4.4

Wed May 18, 2016 12:10 am

Hi
I compile kernel 4.4.10+ (rpi-1) but he seem no boot
in the step (make modules_install) he give error too many files
after change on /etc/security/limits.conf with increase ulimit (make modules_install)
work now correctly but this kernel is unable to boot.
I don't know if required also some change of parameter with sysctl or some change on config.txt ?

root@raspberrypi_0:/mnt# cd linux-rpi-4.4.y
root@raspberrypi_0:/mnt/linux-rpi-4.4.y# make
CHK include/config/kernel.release
CHK include/generated/uapi/linux/version.h
CHK include/generated/utsrelease.h
make[1]: « include/generated/mach-types.h » est à jour.
CHK include/generated/bounds.h
CHK include/generated/timeconst.h
CHK include/generated/asm-offsets.h
CALL scripts/checksyscalls.sh
CHK include/generated/compile.h
CHK kernel/config_data.h
Kernel: arch/arm/boot/Image is ready
Kernel: arch/arm/boot/Image is ready
Kernel: arch/arm/boot/zImage is ready
Building modules, stage 2.
MODPOST 1504 modules
I wash the old module folder before (rm -r /lib/modules/4.4.10+)
make modules_install
....
....
....

INSTALL sound/usb/misc/snd-ua101.ko
INSTALL sound/usb/snd-usb-audio.ko
INSTALL sound/usb/snd-usbmidi-lib.ko
DEPMOD 4.4.10+
root@raspberrypi_0:/mnt/linux-rpi-4.4.y#

cp -v arch/arm/boot/zImage /boot/kernel.img

I don't see where is the problem
I use make bcmrpi_defconfig default without any changes
kernel 4.0.8+ that I build long time now , work perfectly


Regards

bust
Posts: 76
Joined: Mon Mar 17, 2014 12:31 am

Re: Problem with kernel 4.4

Mon Jun 13, 2016 11:54 pm

Hi
Resolved,It's just some parameters in default config def supposed aligned to rpi-1 are false for (armv6zk).
Regards

Return to “Linux Kernel”