rudy01
Posts: 38
Joined: Tue Feb 19, 2013 3:16 am

OpenMAX color format problem

Thu Feb 28, 2013 7:09 am

Hi everyone,
I read this post, which was extremely helpful:
http://www.raspberrypi.org/phpBB3/viewt ... 33&t=15463

In the specified post above, it talks about how you can set the color format, and here is the official example:
https://github.com/xbmc/xbmc-rbp/blob/m ... XImage.cpp

I also found this page, that lists all the available color formats:
http://www.khronos.org/registry/omxil/s ... cation.pdf

But, unfortunately, I cannot set it to an RGB color space.
I tried to change the OMX_COLOR_Format32bitABGR8888 to both OMX_COLOR_Format24bitBGR888 and
OMX_COLOR_Format32bitRGB888,
and no luck.
When I tried to set the parameter, m_omx_encoder.SetParameter(OMX_IndexParamPortDefinition, &port_def) it just crashes.

Is this a bug in OpenMAX? Because I don't see any reason why I cannot set the color space to 24-bit RGB instead of 32-bit RGBA !!!
Apparently, the SetParameter() function doesn't like to set the color space to RGB !!!

Has anyone had any success in setting the color space to RGB? Does anyone see what I am doing wrong?
I would really appreciate some help.

And, just a side question, does anyone know of any software to quickly encode an RGBA image?

Thanks,
--Rudy

MattOwnby
Posts: 58
Joined: Thu Aug 16, 2012 7:22 pm

Re: OpenMAX color format problem

Thu Feb 28, 2013 7:32 pm

I replied to the other thread, but just for completeness, I believe that the Pi's OpenMAX implementation does not support RGB, only RGBA. That is probably why it is giving the error.

rudy01
Posts: 38
Joined: Tue Feb 19, 2013 3:16 am

Re: OpenMAX color format problem

Thu Feb 28, 2013 8:44 pm

Thanks,
I saw your reply on the other post:
http://www.raspberrypi.org/phpBB3/viewt ... 3&p=298768

Since, this is about the same question, I would continue on your previous post and not be adding to this post.

Thanks,
--Rudy

Return to “OpenMAX”