chewy74
Posts: 14
Joined: Thu Dec 18, 2014 9:20 pm

[HELP] PEP440Warning

Thu Dec 18, 2014 9:30 pm

Noob here...I started receiving this warning 2 days ago and I am unsure how to fix this. Google is not giving me anything i can understand, or use...

can anyone help me out? I'm thinking it's pygames version now incompatible with python...if this is the case, would removing it resolve this?

Thanks

Code: Select all

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Dec 18 10:12:37 2014
pi@raspberrypi ~ $ flexget -V
/usr/local/lib/python2.7/dist-packages/pkg_resources.py:2443: PEP440Warning: 'pygame (1.9.1release)' is being parsed as a legacy, non PEP 440, version. You may find odd behavior and sort order. In particular it will be sorted as less than 0.0. It is recommend to migrate to PEP 440 compatible versions.
PEP440Warning,
1.2.237
You are on the latest release.
.

chewy74
Posts: 14
Joined: Thu Dec 18, 2014 9:20 pm

Re: [HELP] PEP440Warning

Fri Dec 19, 2014 4:01 pm

Anybody? :cry:

User avatar
Paeryn
Posts: 2561
Joined: Wed Nov 23, 2011 1:10 am
Location: Sheffield, England

Re: [HELP] PEP440Warning

Fri Dec 19, 2014 9:37 pm

I've never used flexget or pygame but from a quick google this is what I came up with :-

PEP 440 is to do with version identification. It looks like flexget can't figure out pygame's version, it looks like it's version is 1.9.1release, which doesn't seem to comply with PEP 440 which says that the version id should in the form of [N!]N(.N)*[{a|b|rc}N][.postN][.devN] i.e. the word release at the end is confusing it. flexget appears to be telling you that since it cannot determine the version, it will assume that the version is < 0.0

Nothing looks to be wrong, it's just warning you that it can't determine the correct version number.
She who travels light — forgot something.

chewy74
Posts: 14
Joined: Thu Dec 18, 2014 9:20 pm

Re: [HELP] PEP440Warning

Sat Dec 20, 2014 3:13 pm

Thanks. Everything does still to be working... Thanks again for the help

Return to “Raspbian”