User avatar
Paul Webster
Posts: 815
Joined: Sat Jul 30, 2011 4:49 am
Location: London, UK
Contact: Twitter

Experimenting with new lib6c on Raspbian Stretch

Fri Dec 06, 2019 9:24 am

I have a system running on Raspbian Stretch that, since an update to it, is running into an issue that 1 or 2 others have, in the past, said is related to the version of lib6c.

So - I'm tempted to try to install (or maybe build and install) a more recent version of lib6c.

I know that installing a newer version of such a commonly used library could cause problems elsewhere ... so am trying to be as careful as possible.

On my Stretch install it is:

Code: Select all

$ apt-cache policy libc6
libc6:
  Installed: 2.24-11+deb9u4
  Candidate: 2.24-11+deb9u4
  Version table:
 *** 2.24-11+deb9u4 500
        500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
        100 /var/lib/dpkg/status
on a local Raspbian Buster it is:

Code: Select all

$ apt-cache policy libc6
libc6:
  Installed: 2.28-10+rpi1
  Candidate: 2.28-10+rpi1
  Version table:
 *** 2.28-10+rpi1 500
        500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
        100 /var/lib/dpkg/status
I can get a .deb from Debian for armhf of 2.28-10 but ... the Raspbian Buster version has "+rpi1" ... so how can I find out what makes it a rpi1 version?

Moving the system to Buster is a possibility - but since upgrade from Stretch to Buster is not recommended then I am trying to do the minimum necessary.

If all else fails I will make a new Buster installation and re-install / configure everything that I had done before ... but I would rather not have to go through all of that.

Return to “Raspbian”