Page 4 of 8

Re: [Guide] Kodi on Raspbian Buster

Posted: Tue Sep 24, 2019 10:11 pm
by bjtheone
bjtheone wrote:
Tue Sep 24, 2019 11:34 am
Thanks for the speedy response. Will test tonight and report back.

Pretty sure the my non-pi user is in the required groups. However I definitely have sudo prompting for a password. Will add the sudoers.d option and see if that resolves it. I do not have the problem if I just launch Kodi and muck about with the settings. It only hangs when I actually play a movie, so it is likely the X cleanup on exit. Sorry I missed the sudoers.d suggestion that was already in the comments.
/etc/sudoers.d/020_kodi suggestion seems to resolve my problem.

xserver-xorg-video-fbdev package was already installed.

Result of "groups $USER" for bob was

Code: Select all

bob : bob adm tty dialout cdrom sudo audio video plugdev games users input netdev spi i2c gpio lpadmin

Re: [Guide] Kodi on Raspbian Buster

Posted: Tue Sep 24, 2019 10:24 pm
by Rascas
bjtheone wrote:
Tue Sep 24, 2019 10:11 pm
bjtheone wrote:
Tue Sep 24, 2019 11:34 am
Thanks for the speedy response. Will test tonight and report back.

Pretty sure the my non-pi user is in the required groups. However I definitely have sudo prompting for a password. Will add the sudoers.d option and see if that resolves it. I do not have the problem if I just launch Kodi and muck about with the settings. It only hangs when I actually play a movie, so it is likely the X cleanup on exit. Sorry I missed the sudoers.d suggestion that was already in the comments.
/etc/sudoers.d/020_kodi suggestion seems to resolve my problem.

xserver-xorg-video-fbdev package was already installed.

Result of "groups $USER" for bob was

Code: Select all

bob : bob adm tty dialout cdrom sudo audio video plugdev games users input netdev spi i2c gpio lpadmin
Nice! Your groups in user bob seems good, most likely it was the sudo password. I will upload a new Kodi packages that will do that automatically in a few minutes.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 12:23 am
by Rascas
Packages updated to 18.4-5
Changes:

-Add some system configuration files to faciliate/automate configuration. That should fix most of permissions problems. More info here: https://github.com/PIPplware/xbmc/commi ... _backports

Just update and upgrade the packages has you normally do.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 7:41 pm
by chewy74
Hi @Rascas so I installed this on my Pi4 4g model and I'm having some trouble with it. The first issue is that I have no audio at all. The second issue is whenever I launch kodi, and when it loads, it will switch off/on my video input and my TV will switch to the next active input. When I switch the video input back to the Pi4 everything looks fine. This is also happening whenever I try to play a video. When I play the video my TV input will change to next available active input. I change it back to the Pi4 and I can play the video OK, but still without audio.

Aside from the gui lag and occasional stutters everything else is OK.

Here is an debug log.
https://www.dropbox.com/s/cjpxro55fhryx49/kodi.log?dl=0

Thanks for all your hard work on this

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 8:05 pm
by Rascas
chewy74 wrote:
Wed Sep 25, 2019 7:41 pm
Hi @Rascas so I installed this on my Pi4 4g model and I'm having some trouble with it. The first issue is that I have no audio at all. The second issue is whenever I launch kodi, and when it loads, it will switch off/on my video input and my TV will switch to the next active input. When I switch the video input back to the Pi4 everything looks fine. This is also happening whenever I try to play a video. When I play the video my TV input will change to next available active input. I change it back to the Pi4 and I can play the video OK, but still without audio.

Aside from the gui lag and occasional stutters everything else is OK.

Here is an debug log.
https://www.dropbox.com/s/cjpxro55fhryx49/kodi.log?dl=0

Thanks for all your hard work on this
Your /boot/config.txt settings doesn't look right. Did you disabled the OpenGL FKMS driver ? That won't work (or work bad) in Kodi. Please post your /boot/config.txt

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 8:51 pm
by TomoeMikage
Rascas wrote:
Tue Sep 24, 2019 8:50 pm
TomoeMikage wrote:
Tue Sep 24, 2019 8:17 pm
Rascas wrote:
Tue Sep 24, 2019 10:20 am


Please post a Kodi debug log after playing one of those files: https://kodi.wiki/view/Log_file
Does it work if play one of the same files from the sdcard?
Hello, thank you for your reply.
I tried to copy video into SD card and external USB flash drive. I have the same green artifacts. If it can help you, VLC player has this issue as well.

Also, please, take a look at the attached log file.
kodi.zip
Well, I do see alot of audio sync errors, but that can be caused by alot of things. Do you have PI:HDMI selected in Kodi audio settings ? What you are getting does not seem normal, the codec is h264, nothing special for the Pi, it is hardware decoded, it looks like the PI cannot read the file fast enough. And the log you posted is just a normal log, not a debug log wihich provides more info. Please post a debug log, check first post.
Sorry, I forgot to enable DEBUG in logs. I saw the update of the package, so I've updated. But I still have those glitches.
Please, see the attached file.
kodi_log_with_debug.zip
(67.61 KiB) Downloaded 14 times

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 8:56 pm
by chewy74
I don't think I changed anything on the OpenGL FKMS driver. Here is my config

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=40
#overscan_right=0
#overscan_top=0
#overscan_bottom=40
overscan_scale=1

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1920
#framebuffer_height=1080

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=95

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=1

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=11	

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all] 
dtoverlay=vc4-fkms-v3d 
hdmi_enable_4kp60=1 
gpu_mem=320 


Rascas wrote:
Wed Sep 25, 2019 8:05 pm
chewy74 wrote:
Wed Sep 25, 2019 7:41 pm
Hi @Rascas so I installed this on my Pi4 4g model and I'm having some trouble with it. The first issue is that I have no audio at all. The second issue is whenever I launch kodi, and when it loads, it will switch off/on my video input and my TV will switch to the next active input. When I switch the video input back to the Pi4 everything looks fine. This is also happening whenever I try to play a video. When I play the video my TV input will change to next available active input. I change it back to the Pi4 and I can play the video OK, but still without audio.

Aside from the gui lag and occasional stutters everything else is OK.

Here is an debug log.
https://www.dropbox.com/s/cjpxro55fhryx49/kodi.log?dl=0

Thanks for all your hard work on this
Your /boot/config.txt settings doesn't look right. Did you disabled the OpenGL FKMS driver ? That won't work (or work bad) in Kodi. Please post your /boot/config.txt

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 9:08 pm
by Rascas
chewy74 wrote:
Wed Sep 25, 2019 8:56 pm
I don't think I changed anything on the OpenGL FKMS driver. Here is my config

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=40
#overscan_right=0
#overscan_top=0
#overscan_bottom=40
overscan_scale=1

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1920
#framebuffer_height=1080

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=95

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=1

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=11	

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all] 
dtoverlay=vc4-fkms-v3d 
hdmi_enable_4kp60=1 
gpu_mem=320 


Rascas wrote:
Wed Sep 25, 2019 8:05 pm
chewy74 wrote:
Wed Sep 25, 2019 7:41 pm
Hi @Rascas so I installed this on my Pi4 4g model and I'm having some trouble with it. The first issue is that I have no audio at all. The second issue is whenever I launch kodi, and when it loads, it will switch off/on my video input and my TV will switch to the next active input. When I switch the video input back to the Pi4 everything looks fine. This is also happening whenever I try to play a video. When I play the video my TV input will change to next available active input. I change it back to the Pi4 and I can play the video OK, but still without audio.

Aside from the gui lag and occasional stutters everything else is OK.

Here is an debug log.
https://www.dropbox.com/s/cjpxro55fhryx49/kodi.log?dl=0

Thanks for all your hard work on this
Your /boot/config.txt settings doesn't look right. Did you disabled the OpenGL FKMS driver ? That won't work (or work bad) in Kodi. Please post your /boot/config.txt
Try commenting/removing the following settings, those are not default:
overscan_scale=1
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=95
hdmi_drive=1
config_hdmi_boost=11

I don't see any video/audio errors, but I think your problem is with some of that settings. And make sure you have the HDMI connected to HDMI0 (the connector closer to the USB-C connector), there is a currently a kernel/firmware bug that there is no sound on HDMI1.
Also if you have enabled "Sync playback to display" and "Adjust display frame rate", try with those disabled.

About the lag in the interface, you are using a 3840x2160 @ 30 Hz resolution to render the interface, and as explained in the first post, that will make things slower. Select 1080p resolution in Kodi video settings.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 9:57 pm
by Rascas
TomoeMikage wrote:
Wed Sep 25, 2019 8:51 pm
Rascas wrote:
Tue Sep 24, 2019 8:50 pm
TomoeMikage wrote:
Tue Sep 24, 2019 8:17 pm


Hello, thank you for your reply.
I tried to copy video into SD card and external USB flash drive. I have the same green artifacts. If it can help you, VLC player has this issue as well.

Also, please, take a look at the attached log file.
kodi.zip
Well, I do see alot of audio sync errors, but that can be caused by alot of things. Do you have PI:HDMI selected in Kodi audio settings ? What you are getting does not seem normal, the codec is h264, nothing special for the Pi, it is hardware decoded, it looks like the PI cannot read the file fast enough. And the log you posted is just a normal log, not a debug log wihich provides more info. Please post a debug log, check first post.
Sorry, I forgot to enable DEBUG in logs. I saw the update of the package, so I've updated. But I still have those glitches.
Please, see the attached file.
kodi_log_with_debug.zip
I am sorry but I have no idea why that happens. Maybe something to do with analogue audio output ?
If the same happens in VLC I suggest that you open a topic about your problem. VLC is supported by the Raspberry Pi devs, they know better.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 10:16 pm
by chewy74
Setting the boot config back to default causes the command line screen txt to be very oversized and spill over the left side and bottom of the screen. I made sure the hdmi is connected to the closest to the USB-C port, and both sync playback to monitor and adjust frame rate are both off. Still don't have sound, and the other issues still remains.

Also forgot to mention in my original post that CEC is also not working for me
Rascas wrote:
Wed Sep 25, 2019 9:08 pm
chewy74 wrote:
Wed Sep 25, 2019 8:56 pm
I don't think I changed anything on the OpenGL FKMS driver. Here is my config

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=40
#overscan_right=0
#overscan_top=0
#overscan_bottom=40
overscan_scale=1

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1920
#framebuffer_height=1080

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=95

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=1

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=11	

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all] 
dtoverlay=vc4-fkms-v3d 
hdmi_enable_4kp60=1 
gpu_mem=320 


Rascas wrote:
Wed Sep 25, 2019 8:05 pm


Your /boot/config.txt settings doesn't look right. Did you disabled the OpenGL FKMS driver ? That won't work (or work bad) in Kodi. Please post your /boot/config.txt
Try commenting/removing the following settings, those are not default:
overscan_scale=1
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=95
hdmi_drive=1
config_hdmi_boost=11

I don't see any video/audio errors, but I think your problem is with some of that settings. And make sure you have the HDMI connected to HDMI0 (the connector closer to the USB-C connector), there is a currently a kernel/firmware bug that there is no sound on HDMI1.
Also if you have enabled "Sync playback to display" and "Adjust display frame rate", try with those disabled.

About the lag in the interface, you are using a 3840x2160 @ 30 Hz resolution to render the interface, and as explained in the first post, that will make things slower. Select 1080p resolution in Kodi video settings.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 10:22 pm
by Rascas
chewy74 wrote:
Wed Sep 25, 2019 10:16 pm
Setting the boot config back to default causes the command line screen txt to be very oversized and spill over the left side and bottom of the screen. I made sure the hdmi is connected to the closest to the USB-C port, and both sync playback to monitor and adjust frame rate are both off. Still don't have sound, and the other issues still remains.

Also forgot to mention in my original post that CEC is also not working for me
Rascas wrote:
Wed Sep 25, 2019 9:08 pm
chewy74 wrote:
Wed Sep 25, 2019 8:56 pm
I don't think I changed anything on the OpenGL FKMS driver. Here is my config

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=40
#overscan_right=0
#overscan_top=0
#overscan_bottom=40
overscan_scale=1

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1920
#framebuffer_height=1080

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=95

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=1

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=11	

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all] 
dtoverlay=vc4-fkms-v3d 
hdmi_enable_4kp60=1 
gpu_mem=320 



Try commenting/removing the following settings, those are not default:
overscan_scale=1
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=95
hdmi_drive=1
config_hdmi_boost=11

I don't see any video/audio errors, but I think your problem is with some of that settings. And make sure you have the HDMI connected to HDMI0 (the connector closer to the USB-C connector), there is a currently a kernel/firmware bug that there is no sound on HDMI1.
Also if you have enabled "Sync playback to display" and "Adjust display frame rate", try with those disabled.

About the lag in the interface, you are using a 3840x2160 @ 30 Hz resolution to render the interface, and as explained in the first post, that will make things slower. Select 1080p resolution in Kodi video settings.
First, I would make sure that the problem (no audio and no CEC) also happens with everything at default settings, even if the image does not fit the screen. To make sure the problem is not caused by some extra setting.
And of course audio and CEC are confirmed working, in your case it may indicate some problem with your HDMI cable, so I would test with another one. Make sure it is a HDMI 2.0 cable like the oficial one.

PS: Don't forget about Kodi resolution.

Re: [Guide] Kodi on Raspbian Buster

Posted: Wed Sep 25, 2019 10:50 pm
by chewy74
Yes, I reverted the boot config back to its original values and still had the same issues. Along with setting the kodi resolution down. No luck with either

The hdmi cable I'm using is hdmi 2.0
https://www.amazon.com/gp/aw/d/B009W9V2 ... asin_title

I will have to get another cable to test if it's a cable issue

Thanks
Rascas wrote:
Wed Sep 25, 2019 10:22 pm
chewy74 wrote:
Wed Sep 25, 2019 10:16 pm
Setting the boot config back to default causes the command line screen txt to be very oversized and spill over the left side and bottom of the screen. I made sure the hdmi is connected to the closest to the USB-C port, and both sync playback to monitor and adjust frame rate are both off. Still don't have sound, and the other issues still remains.

Also forgot to mention in my original post that CEC is also not working for me
Rascas wrote:
Wed Sep 25, 2019 9:08 pm


Try commenting/removing the following settings, those are not default:
overscan_scale=1
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=95
hdmi_drive=1
config_hdmi_boost=11

I don't see any video/audio errors, but I think your problem is with some of that settings. And make sure you have the HDMI connected to HDMI0 (the connector closer to the USB-C connector), there is a currently a kernel/firmware bug that there is no sound on HDMI1.
Also if you have enabled "Sync playback to display" and "Adjust display frame rate", try with those disabled.

About the lag in the interface, you are using a 3840x2160 @ 30 Hz resolution to render the interface, and as explained in the first post, that will make things slower. Select 1080p resolution in Kodi video settings.
First, I would make sure that the problem (no audio and no CEC) also happens with everything at default settings, even if the image does not fit the screen. To make sure the problem is not caused by some extra setting.
And of course audio and CEC are confirmed working, in your case it may indicate some problem with your HDMI cable, so I would test with another one. Make sure it is a HDMI 2.0 cable like the oficial one.

PS: Don't forget about Kodi resolution.

Re: [Guide] Kodi on Raspbian Buster

Posted: Thu Sep 26, 2019 10:47 pm
by chewy74
OK, so my hdmi cable is OK. I got the audio working by forcing hdmi instead of dvi with

Code: Select all

hdmi_drive=2


Unfortunately the videos signal loss is still there... I'm thinking it might be my power supply. I'm using a pixel 3 xl ome charger which is 5v 3a so I figured it would do the job, but I'm still seeing low voltage warnings. Would low voltage cause the kodi video input to lose the signal and causing my TV to switch inputs thinking there's no signal?

chewy74 wrote:
Wed Sep 25, 2019 10:50 pm
Yes, I reverted the boot config back to its original values and still had the same issues. Along with setting the kodi resolution down. No luck with either

The hdmi cable I'm using is hdmi 2.0
https://www.amazon.com/gp/aw/d/B009W9V2 ... asin_title

I will have to get another cable to test if it's a cable issue

Thanks
Rascas wrote:
Wed Sep 25, 2019 10:22 pm
chewy74 wrote:
Wed Sep 25, 2019 10:16 pm
Setting the boot config back to default causes the command line screen txt to be very oversized and spill over the left side and bottom of the screen. I made sure the hdmi is connected to the closest to the USB-C port, and both sync playback to monitor and adjust frame rate are both off. Still don't have sound, and the other issues still remains.

Also forgot to mention in my original post that CEC is also not working for me

First, I would make sure that the problem (no audio and no CEC) also happens with everything at default settings, even if the image does not fit the screen. To make sure the problem is not caused by some extra setting.
And of course audio and CEC are confirmed working, in your case it may indicate some problem with your HDMI cable, so I would test with another one. Make sure it is a HDMI 2.0 cable like the oficial one.

PS: Don't forget about Kodi resolution.

Re: [Guide] Kodi on Raspbian Buster

Posted: Fri Sep 27, 2019 5:30 pm
by bjtheone
chewy74 wrote:
Thu Sep 26, 2019 10:47 pm
Unfortunately the videos signal loss is still there... I'm thinking it might be my power supply. I'm using a pixel 3 xl ome charger which is 5v 3a so I figured it would do the job, but I'm still seeing low voltage warnings. Would low voltage cause the kodi video input to lose the signal and causing my TV to switch inputs thinking there's no signal?
Low voltage warning "should not" be a large enough event to cause the Pi to drop video output for long enough for your Tv to decide to switch inputs. However, they are an indication of a power issue and you might as well address it to rule it out as a cause since power issues are know to cause odd things to happen. Even if the charger is not the cause of your video issues, you are very likely to encounter other strange things.

[climbs on soapbox]

As has been stated a bunch of times, phone charges are not the same as power supplies and some chargers do not supply claimed voltage at maximum rated current. The Pi very much does not like brownouts (when the voltage sags or drops as you get close to the max current). Plus some chargers out and out lie, and cannot deliver the claimed current.

You certainly can use any power supply that can deliver the required current at the required voltage, with the required regulation. The easiest way to ensure this is to get an official Pi 4 power supply, as these will just work. The $12-15 dollars they cost is money very well spent in terms of the hassles and issues they eliminate.

[climbs off soapbox]

Re: [Guide] Kodi on Raspbian Buster

Posted: Fri Sep 27, 2019 5:47 pm
by chewy74
Kodi crash log

https://pastebin.com/U7E8KPwY
bjtheone wrote:
Fri Sep 27, 2019 5:30 pm
chewy74 wrote:
Thu Sep 26, 2019 10:47 pm
Unfortunately the videos signal loss is still there... I'm thinking it might be my power supply. I'm using a pixel 3 xl ome charger which is 5v 3a so I figured it would do the job, but I'm still seeing low voltage warnings. Would low voltage cause the kodi video input to lose the signal and causing my TV to switch inputs thinking there's no signal?
Low voltage warning "should not" be a large enough event to cause the Pi to drop video output for long enough for your Tv to decide to switch inputs. However, they are an indication of a power issue and you might as well address it to rule it out as a cause since power issues are know to cause odd things to happen. Even if the charger is not the cause of your video issues, you are very likely to encounter other strange things.

[climbs on soapbox]

As has been stated a bunch of times, phone charges are not the same as power supplies and some chargers do not supply claimed voltage at maximum rated current. The Pi very much does not like brownouts (when the voltage sags or drops as you get close to the max current). Plus some chargers out and out lie, and cannot deliver the claimed current.

You certainly can use any power supply that can deliver the required current at the required voltage, with the required regulation. The easiest way to ensure this is to get an official Pi 4 power supply, as these will just work. The $12-15 dollars they cost is money very well spent in terms of the hassles and issues they eliminate.

[climbs off soapbox]

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 2:10 pm
by Rascas
chewy74 wrote:
Fri Sep 27, 2019 5:47 pm
Kodi crash log

https://pastebin.com/U7E8KPwY
bjtheone wrote:
Fri Sep 27, 2019 5:30 pm
chewy74 wrote:
Thu Sep 26, 2019 10:47 pm
Unfortunately the videos signal loss is still there... I'm thinking it might be my power supply. I'm using a pixel 3 xl ome charger which is 5v 3a so I figured it would do the job, but I'm still seeing low voltage warnings. Would low voltage cause the kodi video input to lose the signal and causing my TV to switch inputs thinking there's no signal?
Low voltage warning "should not" be a large enough event to cause the Pi to drop video output for long enough for your Tv to decide to switch inputs. However, they are an indication of a power issue and you might as well address it to rule it out as a cause since power issues are know to cause odd things to happen. Even if the charger is not the cause of your video issues, you are very likely to encounter other strange things.

[climbs on soapbox]

As has been stated a bunch of times, phone charges are not the same as power supplies and some chargers do not supply claimed voltage at maximum rated current. The Pi very much does not like brownouts (when the voltage sags or drops as you get close to the max current). Plus some chargers out and out lie, and cannot deliver the claimed current.

You certainly can use any power supply that can deliver the required current at the required voltage, with the required regulation. The easiest way to ensure this is to get an official Pi 4 power supply, as these will just work. The $12-15 dollars they cost is money very well spent in terms of the hassles and issues they eliminate.

[climbs off soapbox]
That crash was CEC related. Most likely because you are using an unsuitable power supply and hdmi cable 5 meter long.

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 3:22 pm
by bat0nas
Has anybody experienced this?

Start kodi
Watch movie
Exit to desktop
Start kodi
And kodi doesn't start. Just the black screen

Didn't yet notice any pattern.

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 8:16 pm
by cocodude
I have an interesting issue whereby audio goes down different HDMI ports on the RPi 4 depending on whether I'm allowing passthrough or not.

My situation is that I have a Raspberry Pi 4 with a 4k monitor on HDMI 0, and my audio receiver connected to HDMI 1. The reason for this is that the audio receiver can't process 4k video, so I'm sending sound directly to it so it can handle DTS etc. which my TV can't. The setup is:

[*] HDMI 0 -> TV
[*] HDMI 1 -> Audio receiver

In the Raspbian GUI, I have configured audio to go to HDMI 1 (right click on the speaker icon), which presumably changes the ALSA default to HDMI 1. In Kodi, I have configured the default sound output to be the ALSA default. Decoded/PCM audio in Kodi correctly goes to HDMI 1.

However, when I enable audio passthrough, the encoded (Dolby Digital in my case) audio only goes to HDMI 0.

I may be wrong, but I believe this is because Kodi only sends audio to direct digital audio outputs (e.g. not ALSA) and Kodi directly only lists one HDMI port for video output. This is, of course, HDMI 0.

Is there any reason why Kodi only lists the one HDMI port (plus ALSA etc.) in the list of sound output devices?

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 8:28 pm
by Rascas
cocodude wrote:
Sat Sep 28, 2019 8:16 pm
I have an interesting issue whereby audio goes down different HDMI ports on the RPi 4 depending on whether I'm allowing passthrough or not.

My situation is that I have a Raspberry Pi 4 with a 4k monitor on HDMI 0, and my audio receiver connected to HDMI 1. The reason for this is that the audio receiver can't process 4k video, so I'm sending sound directly to it so it can handle DTS etc. which my TV can't. The setup is:

[*] HDMI 0 -> TV
[*] HDMI 1 -> Audio receiver

In the Raspbian GUI, I have configured audio to go to HDMI 1 (right click on the speaker icon), which presumably changes the ALSA default to HDMI 1. In Kodi, I have configured the default sound output to be the ALSA default. Decoded/PCM audio in Kodi correctly goes to HDMI 1.

However, when I enable audio passthrough, the encoded (Dolby Digital in my case) audio only goes to HDMI 0.

I may be wrong, but I believe this is because Kodi only sends audio to direct digital audio outputs (e.g. not ALSA) and Kodi directly only lists one HDMI port for video output. This is, of course, HDMI 0.

Is there any reason why Kodi only lists the one HDMI port (plus ALSA etc.) in the list of sound output devices?
The HDMI ports on the PI are handled directly through a PISink code block in Kodi, not ALSA. And yes, it only supports HDMI0 for now. If you want support for both ports you should raise this in the Kodi forum: https://forum.kodi.tv/

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 8:47 pm
by cocodude
Rascas wrote:
Sat Sep 28, 2019 8:28 pm
The HDMI ports on the PI are handled directly through a PISink code block in Kodi, not ALSA. And yes, it only supports HDMI0 for now. If you want support for both ports you should raise this in the Kodi forum: https://forum.kodi.tv/
Thanks so much; that makes sense. I've created a new thread at https://forum.kodi.tv/showthread.php?tid=347621

Re: [Guide] Kodi on Raspbian Buster

Posted: Sat Sep 28, 2019 11:51 pm
by chewy74
Yea, I'm going to get a new power supply for it, but unfortunately I can't put my Pi closer to the TV. It's why I'm using such a long hdmi cord. Hop the new power supply will fix it.

Thanks
Rascas wrote:
Sat Sep 28, 2019 2:10 pm
chewy74 wrote:
Fri Sep 27, 2019 5:47 pm
Kodi crash log

https://pastebin.com/U7E8KPwY
bjtheone wrote:
Fri Sep 27, 2019 5:30 pm

Low voltage warning "should not" be a large enough event to cause the Pi to drop video output for long enough for your Tv to decide to switch inputs. However, they are an indication of a power issue and you might as well address it to rule it out as a cause since power issues are know to cause odd things to happen. Even if the charger is not the cause of your video issues, you are very likely to encounter other strange things.

[climbs on soapbox]

As has been stated a bunch of times, phone charges are not the same as power supplies and some chargers do not supply claimed voltage at maximum rated current. The Pi very much does not like brownouts (when the voltage sags or drops as you get close to the max current). Plus some chargers out and out lie, and cannot deliver the claimed current.

You certainly can use any power supply that can deliver the required current at the required voltage, with the required regulation. The easiest way to ensure this is to get an official Pi 4 power supply, as these will just work. The $12-15 dollars they cost is money very well spent in terms of the hassles and issues they eliminate.

[climbs off soapbox]
That crash was CEC related. Most likely because you are using an unsuitable power supply and hdmi cable 5 meter long.

Re: [Guide] Kodi on Raspbian Buster

Posted: Sun Sep 29, 2019 11:58 am
by armyofme
Thanks for setting up this guide :) Unfortunately I'm stuck on the first set of installation instructions. When I try to install Kodi I get:

Code: Select all

Err:1 http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary  libshairplay0 0.9.0+git20180824.096b61a-1~stretch
  404  Not Found [IP: 176.221.32.193 80]
Unable to correct missing packages.
E: Failed to fetch http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary/./libshairplay0_0.9.0+git20180824.096b61a-1~stretch_armhf.deb  404  Not Found [IP: 176.221.32.193 80]
E: Aborting install.
I tried yesterday and then again today (just in case servers were down). Any ideas?

Re: [Guide] Kodi on Raspbian Buster

Posted: Sun Sep 29, 2019 5:42 pm
by Rascas
armyofme wrote:
Sun Sep 29, 2019 11:58 am
Thanks for setting up this guide :) Unfortunately I'm stuck on the first set of installation instructions. When I try to install Kodi I get:

Code: Select all

Err:1 http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary  libshairplay0 0.9.0+git20180824.096b61a-1~stretch
  404  Not Found [IP: 176.221.32.193 80]
Unable to correct missing packages.
E: Failed to fetch http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary/./libshairplay0_0.9.0+git20180824.096b61a-1~stretch_armhf.deb  404  Not Found [IP: 176.221.32.193 80]
E: Aborting install.
I tried yesterday and then again today (just in case servers were down). Any ideas?
The address is "buster" not "unstable".

Re: [Guide] Kodi on Raspbian Buster

Posted: Sun Sep 29, 2019 6:45 pm
by piplip
I'm trying this on a raspberry pi zero w (in fact I already had raspbian stretch+kodi from PiPplware installed, I just upgraded to buster with apt-get dist-upgrade).

I'm using the first systemd script. If I connect the pi to the tv with the hdmi cable it works no problem, but if I try to use the composite output (PAL, sdtv_mode=2) kodi hangs.
A 'systemctl stop kodi' does nothing, I have to 'kill -KILL' kodi-rbpi (well, actually "systemd stop" does kill it after a long while).

Previously (with stretch) kodi worked even with the composite output.

I put both logs (with hdmi/with composite video) on pastebin (I tried to attach them but both .log and .txt extensions aren't admitted here).
I removed the timestamps so it's easier to diff them.

with hdmi https://pastebin.com/EfRaY8NU
with composite video https://pastebin.com/RXM3HF6w

the only difference, apart from the available resolutions (only 720x576 with composite), is that the latter hangs at " NOTICE: Checking resolution 16"

Re: [Guide] Kodi on Raspbian Buster

Posted: Sun Sep 29, 2019 7:09 pm
by armyofme
But all I did was follow the instructions in the first post. I didn't type 'unstable' into the repo manually. I wonder what could have happened? I'll try and change it to buster.