joda_fr
Posts: 2
Joined: Fri Sep 13, 2019 9:26 am

RESOLVED : Buster + Headless + Teamviewer + no FrameBuffer = FAILURE

Fri Sep 13, 2019 9:41 am

Hi All

I'm running Raspbian Buster on a 2GB Pi4, in headless mode (no screen, no keyboard...)

I try to configure my Pi4 for a teamviewer control. The teamviewer's installation was OK, but when I try to connect on my Pi4 it does'nt work...

After investigation, I find that a FrameBuffer is required... something like "/dev/fb0" that I haven't got on my config


I've got a Pi3 (with previous Rapsbian) which have this Framebuffer configurated and it works fine !!

So is the framebuffer diseabled, uninstalled, unconfigured.... and how can I activate it ??

Thanks for your help

Regards
Last edited by joda_fr on Fri Sep 13, 2019 12:58 pm, edited 1 time in total.

User avatar
topguy
Posts: 5759
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: Buster + Headless + Teamviewer + no FrameBuffer = FAILURE

Fri Sep 13, 2019 11:28 am

The Pi4 ( and buster ) uses the GPU differently than earlier models so that is probably why there is no standard linux-framebuffer device present.

- So either you need an option to also create fbX devices on a Pi4, but I'm not sure that is an option.
- Or the Teamviewer people need to update their software to support Pi4. Do they mention Pi4 support on their pages ?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23632
Joined: Sat Jul 30, 2011 7:41 pm

Re: Buster + Headless + Teamviewer + no FrameBuffer = FAILURE

Fri Sep 13, 2019 11:41 am

As a stop gap, comment out the FKMS entry in config.txt. That should mean you get a legacy framebuffer. I'll discuss what to do about fkms with a colleague.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

klricks
Posts: 6586
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Buster + Headless + Teamviewer + no FrameBuffer = FAILURE

Fri Sep 13, 2019 12:22 pm

Use sudo raspi-config to set a forced screen resolution. (Choose anything other than monitor default).

The reason is that by default (RPi4), if no screen is connected at boot then a display device is not created. Without a display device the GUI desktop does not start so any program that requires GUI will not start. Other RPi models did not have that issue because they would fall back to composite mode if no HDMI was connected. The RPi4 has composite mode disabled by default so no display device is created.
Setting a resolution mode with raspi-config or the GUI config tool or manual edits to config.txt will force a display device on boot even without the HDMI connected as long as you don't choose the monitor default setting.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

joda_fr
Posts: 2
Joined: Fri Sep 13, 2019 9:26 am

Re: Buster + Headless + Teamviewer + no FrameBuffer = FAILURE

Fri Sep 13, 2019 12:58 pm

Hi All !!

And thanks for the time you gave me....

I try to force my screen resolution as @klricks told me.... and it works perfectly :D !!! THX

I now also understand the difference between RPi3 and RPi4 ;) !!

Regards

Return to “Raspbian”