User avatar
Gavinmc42
Posts: 3730
Joined: Wed Aug 28, 2013 3:31 am

Re: FreeCAD on PI4 and Raspbian Buster.

Sat Aug 24, 2019 12:41 am

I got OpenSCAD to work in Gentoo64.
Under Buster I had similar errors on compiling OpenSCAD as the FreeCAD errors.
Coin3D emerged ok on Gentoo64.

Just wondering if it might be a 32/64bit issue?
Not sure if FreeCAD runs on Gentoo x86 32bit?
Are there any 32bit Linux's around for x86?

No ebuild for Arm8 version, so it must be done the hard way :(
emerge: there are no ebuilds to satisfy "freecad".
Is there a way to test coin3d without FreeCAD?
Google time
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

User avatar
clicky
Posts: 387
Joined: Thu Oct 25, 2012 7:34 am

Re: FreeCAD on PI4 and Raspbian Buster.

Thu Aug 29, 2019 3:48 pm

Just to keep this thread alive - I've picked the latest from git and compiled it as on https://www.freecadweb.org/wiki/CompileOnUnix and without any errors. Of course it didn't do me any good as it fails in exactly the same way as pre-packaged version...

Any news on finding the winning combination?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5963
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: FreeCAD on PI4 and Raspbian Buster.

Thu Aug 29, 2019 3:50 pm

Not until this coin3d issue is fixed - https://freecadweb.org/tracker/view.php?id=4083

User avatar
Gavinmc42
Posts: 3730
Joined: Wed Aug 28, 2013 3:31 am

Re: FreeCAD on PI4 and Raspbian Buster.

Fri Aug 30, 2019 1:41 am

I have been getting a "segmentation fault" error on other apps when compiling and running on Gentoo64.
Linux Combat Simulator compiles, runs and then crashes with "seg fault".
What is common? OpenGL?
But there is massive libraries and dependencies in both.

What does "segmentation fault" mean?
google time
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

kkremitzki
Posts: 4
Joined: Wed Aug 07, 2019 9:45 pm
Location: Texas
Contact: Website Twitter

Re: FreeCAD on PI4 and Raspbian Buster.

Sat Oct 12, 2019 12:39 am

Hello all, I just wanted to give an update. I've finally got my Raspberry Pi 4—this thing is amazing! After some further troubleshooting, we've hit a dead end on fixing the segmentation fault problem. However, it looks like it isn't present when FreeCAD is built with the Python 2, Qt 4 configuration. So, my plan is to provide a diff of the debian (packaging) tarball to Raspbian maintainers which will change the build rules and possibly some of the install manifests, and once that is applied and a new package built and uploaded to the archive, then people will for sure be able to start running FreeCAD on RPi4's. Woohoo!

After I get that diff prepared I can continue troubleshooting the Python 3, Qt 5 build.

User avatar
Gavinmc42
Posts: 3730
Joined: Wed Aug 28, 2013 3:31 am

Re: FreeCAD on PI4 and Raspbian Buster.

Sat Oct 12, 2019 5:09 am

we've hit a dead end on fixing the segmentation fault problem.
I have run into seg faults during compiles etc when Pis runs out of memory.
Happens on Pi3's and smaller 4's.
Not sure if it is GPU/CPU memory clash, but that is my theory at the moment.
Need to make it repeatable before I can say that with more confidence.
Buster seems worse than Gentoo64 for seg faults too.

My current Pi4 stress test is Buildroot.

Don't think I have tried making FreeCAD on my new Pi4B4, the older 1 and 2GB ones did not work.
For big compiles the 4GB Pi4 is best or the 2GB one without desktop.
Some stuff will compile on the 1GB 3,4's it I have a 1GB swap file.
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

Return to “Raspbian”