Michael_O
Posts: 23
Joined: Sat Oct 20, 2012 12:28 pm

Problem with VNC on Pi Zero using Buster

Mon Jun 24, 2019 3:02 pm

I am trying Raspbian Buster on a Pi Zero which I normally access headless over VNC. I seem to connect normally except that I get a black screen with the message "Cannot currently show the desktop". I have made sure VNC is enabled and that I am using legacy graphics. I have done update/upgrade but no luck.
Any ideas - anyone?

spl23
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 378
Joined: Fri Dec 26, 2014 11:02 am

Re: Problem with VNC on Pi Zero using Buster

Mon Jun 24, 2019 5:47 pm

You need to make sure you set a display resolution in the "Set Resolution" option in Raspberry Pi Configuration.

VNC determines the size of the desktop it creates from an attached monitor. If no monitor is attached, it does not know how big to make the desktop unless you tell it - this button allows you to do that.

I've just tested this on a Zero running Buster here - without a value set, I get the same error message as you; if I set a resolution, I get a desktop.

Michael_O
Posts: 23
Joined: Sat Oct 20, 2012 12:28 pm

Re: Problem with VNC on Pi Zero using Buster

Mon Jun 24, 2019 7:05 pm

That did it thank you. With all previous versions VNC came up with a small default window and I just went in and set the resolution I wanted so I never bothered setting it in raspi-config.
I'll check out now whether I can see any differences in behaviour or performance from stretch.

tfv
Posts: 5
Joined: Wed May 06, 2015 2:54 pm

Re: Problem with VNC on Pi Zero using Buster

Wed Aug 07, 2019 7:38 pm

I was stuck at the same stage, but things started to resolve when I switched boot options in raspi-config to B3 or B4.

However, I still have not found the proper credentials to log in, I'll probably have to set an additional password somewhere.

Return to “Raspbian”