AJSG1969
Posts: 42
Joined: Tue Oct 24, 2017 3:24 pm

Manual Wifi setup DISABLED WPA_Supplicant

Mon Dec 18, 2017 10:59 am

I'm trying to connect a Pi3 to my local network but have had to disable WPA_Supplivant (apt-get remove) and disabled Avahi Daemon.

I have tried to make sure the bult in interface (wlan0) sees the SSID and it does using

Code: Select all

sudo iwlist wlan0 scan
Tried editing the old /etc/network/interfaces file to include:

Code: Select all

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
address 123.456.789.123
netmask 255.255.255.0
gateway 123.456.789.121
wpa-passphrase password
wpa-ssid myssid
Does anyone have any suggestions as to what might be going wrong?

Thanks.

User avatar
DougieLawson
Posts: 35784
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Manual Wifi setup DISABLED WPA_Supplicant

Thu Dec 21, 2017 5:42 am

Take all of that stuff out of /etc/network/interfaces.

Add the fixed IP stuff in /etc/dhcpcd.conf.

Add the WiFi credentials in a

Code: Select all

network={
 ssid="myssid"
 psk="password"
}
block at the bottom of /etc/wpa_supplicant/wpa_supplicant.conf

Reboot and it should connect.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

AJSG1969
Posts: 42
Joined: Tue Oct 24, 2017 3:24 pm

Re: Manual Wifi setup DISABLED WPA_Supplicant

Thu Dec 21, 2017 2:54 pm

I've tried that but it ends up enabling Wifi on the wrong adapter.

I have also tried re-enabling wpa_supplicant and making two separate config files:

wlan0_wpa_supplicant.conf
wlan1_wpa_supplicant.conf

With real SSID/pass in wlan0 and test/test for wlan1

Unfortunately it connects wlan1 to the SSID parameters of wlan0!!

I changed sudo nano /etc/network/interfaces to

Code: Select all

source-directory /etc/network/interfaces.d
auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wlan0_wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wlan1_wpa_supplicant.conf
Ideally I need to onbord wifi to connect and the USB adapter to remain disconnected

Thanks.

davesteele
Posts: 57
Joined: Wed Nov 30, 2016 4:16 pm

Re: Manual Wifi setup DISABLED WPA_Supplicant

Thu Dec 21, 2017 8:54 pm

Comitup would handle this the way you want.

https://davesteele.github.io/comitup/

Return to “Raspbian”