ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5854
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Fri Dec 01, 2017 1:57 pm


beta-tester
Posts: 1236
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Fri Dec 01, 2017 3:38 pm

i thought it is a Raspbian thing, not a general debian.
thank you for the reference url.
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B, RPi3B, RPi3B+, RPiZeroW, ...

User avatar
Chupo_cro
Posts: 33
Joined: Mon Dec 14, 2015 8:45 pm
Location: Hrvatska

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Sat Mar 17, 2018 1:16 am

Same here with the new 2018-03-13-raspbian-stretch.img. It happens only after reboot but not after log out + re-log in. If I wait at login prompt then the cursor jumps to the beginning of the line before I log in and if I log in immediatelly then the cursor jumps to the beginning of the line later - when I am already logged in, meaning it is really a time based issue.

I am surprised this bug has still not been resolved.

I am using ethernet cable connection and PSU is BTW 3.8 A mini power supply + DIY micro USB connector + thick wires.
Chupo_cro

User avatar
DougieLawson
Posts: 35776
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Sat Mar 17, 2018 8:25 am

Hit [ENTER] and the problem vanishes.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Chupo_cro
Posts: 33
Joined: Mon Dec 14, 2015 8:45 pm
Location: Hrvatska

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Sat Mar 17, 2018 6:18 pm

DougieLawson wrote:
Sat Mar 17, 2018 8:25 am
Hit [ENTER] and the problem vanishes.

Depending on what you consider a problem :-) If the problem is defined as: "The cursor jumps to the left when it mustn't", then hitting Enter wouldn't resolve a problem.

In fact, no need to hit Enter, you can just type over the displayed text and everything works as expected.
Chupo_cro

robmcc83
Posts: 4
Joined: Tue Nov 21, 2017 9:08 pm

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Wed Mar 21, 2018 3:45 pm

I have this exact same problem.
I've just been searching as this happens on both of my pi's which I have updated to the latest stretch image.
One is a pi 2 and the other is a pi 3 both do the same fault.
It happens approx 15 mins after login and if I've already logged in before it has happened then it happens half way through typing my first command.
It is kind of annoying, has there not been a fix yet or does anyone no how?.
Cheers

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5854
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Wed Mar 21, 2018 4:26 pm

It looks like that part of systemd has been removed:
https://lists.freedesktop.org/archives/ ... 30175.html
https://github.com/systemd/systemd/comm ... 76c4c253ec

However, it was added back for the Debian package. I haven't looked into whether it's removed or fixed in any of the upcoming versions of the package in Debian.

Jujan
Posts: 1
Joined: Sat Nov 17, 2018 9:18 pm

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Sat Nov 17, 2018 10:18 pm

I know this thread is old (over 1 year now), but I have finnaly found solution to this problem. There are several limitations (I explain later).
So the actual behavior as of 17. November 2018 is as follows: Raspbian Lite disconnected from network works as expected. User connects to Internet and about 15 seconds after systemd completes bootup and asks for login, cursor jumps at the beggining of the same line. This results in broken input text and if user is fast enough it intercepts password input. No matter what connection interface does user choose as it is proved it affects both onboard WLAN and/or Ethernet. *Tested on RPi Zero W.

The explanation (I am no linux developer or programmer, so I try to explain as good as I can.) : Very similiar behavior was observed on Ubuntu. As stated here: https://unix.stackexchange.com/question ... ring-login the problem comes from systemd module named systemd.fsckd. This module is responsible for launching fsck by statements made in /etc/fstab. As stated by ShiftPlusOne in mailing lists message - this module is actually a piece of trash and should not be in systemd as it not only causes erratic behavior, but is also a code bloat. As stated by ShiftPlusOne at https://github.com/systemd/systemd/comm ... 76c4c253ec this module was eventually removed from systemd, because reasons above. This would have fixed out problem, however Debian decided on keeping it here. The updated version sadly did not reach us and probably never will. In desperate search of fix, I have came around this https://unix.stackexchange.com/question ... ring-login thread and as stated by Jeff Schaller: "so I could see that the systemd-fsckd was somehow responsible. To prove it, I turned off file system checking in my fstab, and the problem went away." First I had to open /boot/cmdline.txt, removed parameter "fsck.repair=yes". Second I opened my /etc/fstab file and looked for sixth column (this one is used to specify fsck at boot time). I could see it contained "2" for boot mountpoint and "1" for root filesystem. So I changed these two to "0" did a reboot and voila! The problem went away.

!!! Limitations:
!EXTREMLY IMPORTANT!
I you apply my fix, you will lose ability to recover from sudden power loss. This is because this fix only disables daemon for fsck repair upon power up. By sudden power loss your RPi SD Card may become unbootable and in worst scerario the filesystem get corrupted. I AM NOT RESPONSIBLE FOR DATA LOSS.
If you experience power loss and able to successfully boot up, do not forget to run "fsck.ext4 -f /dev/mmcblk0p2" as superuser to fix errors on root partition.

Procedure:
Issue commands as superuser.
1. "nano /boot/cmdline.txt"
2. Search for "fsck.repair=yes" parameter and remove it. Exit and save file.
3. "nano /etc/fstab"
4. Search for expression "0 2" and "0 1". Change both of them to "0 0". Exit and save file.
5. Reboot and done.
6. The cursor should no longer jump on beggining of login line.

The reason Raspbian Lite Jessie was not affected were most likely due to less aggressive enforcement of fsck at boot time.

Feel free to correct or enhance my answer.

I even think of writing simple script to make it little more automated. I will reply back if I succeed.

silly05
Posts: 5
Joined: Mon Nov 19, 2018 6:45 pm

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Wed Nov 28, 2018 9:27 pm

I came here looking for a solution to this problem. It's been bothering us for a while now and we are planning to hand off our machines to another team so we are trying to make things perfect.

I did have a memory that this was not a problem in the more distant past and I think the change was between Jessie and Stretch. The worst part is that it jumps positions while you are in the middle of typing. Because of this hitting the enter key is not a total solution.

beta-tester
Posts: 1236
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Raspbian Stretch: login cursor jumps to pos0 of line.

Mon Jul 01, 2019 12:03 pm

the cursor is still "jumping" on Buster (2019-06-20-raspbian-buster-lite.zip) :? :roll: :x
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B, RPi3B, RPi3B+, RPiZeroW, ...

Return to “Raspbian”