Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Problems using PPTP VPN server on RPi from Windows

Mon Aug 07, 2017 9:08 am

I have installed a PPTP VPN server on an RPi in my home network.
That was done 2.5 years ago to allow access into my home network and to view certain sites that are geo-locked to Sweden while I am traveling.
The Pi runs Wheezy and is headless.
I have now connected to the RPi command line (via the PPTP VPN connection) and checked the version:

Code: Select all

$ dpkg --status pptpd
...
Version: 1.3.4-5.2
...
$ sudo apt-get -s -V install pptpd
...
pptpd is already the newest version.
...
PROBLEM:
I have noted that when I connect from Windows7 and use a FireFox browser some webpages never load.
Others work fine and I can access the home network as intended to.
Now I wonder:
1) Since there is no update available for pptpd as shown above, does that mean that pptpd has not been updated or does it mean that it is no longer updated for wheezy?
I don't want to upset my system unnecessarily by upgrading the operating system...

2) Is my problem known by others using the PPTP VPN solution via a server on an RPi?
Could it be that the webpages use some newer protocol that is unhandled by PPTP?

3) How can I check the version of a package that is not installed?
If this would be possible I could connect to a Raspbian Pixel Pi and check the latest available version...
Bo Berglund
Sweden

aymaliev
Posts: 1
Joined: Wed Aug 07, 2019 10:12 pm

Re: Problems using PPTP VPN server on RPi from Windows

Wed Aug 07, 2019 10:14 pm

Hi
Did you find a solution?
I am experiencing the same problem.

Bosse_B
Posts: 836
Joined: Thu Jan 30, 2014 9:53 am

Re: Problems using PPTP VPN server on RPi from Windows

Thu Aug 08, 2019 6:05 am

I stopped using PPTP VPN altogether since it is inherently unsafe.
Instead I have installed and used OpenVPN on multiple RPi units and my Linux systems too.
It works much better and is a lot safer too.
Bo Berglund
Sweden

Return to “Raspbian”