Page 1 of 1

Bluetooth working?

Posted: Sun Sep 09, 2012 2:22 pm
by Jim Ford
Has anyone actually got bluetooth working on Raspbian?

I've got a recommended Cambridge chip 'nano' dongle from Tescos. I've installed the bluetooth software. The chip flashes merrily and '/etc/init.d/bluetooth status' says that bluetooth is running. Output from dmesg and lsmod also suggests that it's working.

If I do 'hcitool scan' the Pi doesn't find anything, yet the bluetooth set up on my desktop finds a photoframe I have OK. My PC doesn't 'see' the Pi nor does the Pi 'see' the PC.

Ides anyone, please?

Jim

Re: Bluetooth working?

Posted: Sun Sep 09, 2012 8:04 pm
by Sander
In my experience and from what I read on this forum: bluetooth on Raspi is picky and buggy (possibly caused by USB problems).

I've trying to get Bluetooth working, and only USB BT module #3 was able to 'function' at all. However, after some hours of usage, it will stop functioning. Only remedy so far: reboot the Raspi.

Re: Bluetooth working?

Posted: Mon Sep 10, 2012 11:02 am
by Jim Ford
It's frustrating that the list of "RPi Verified Peripherals" gives a list of working Bluetooth adaptors, furthermore stating:

"Tesco own brand 'Technika' Nano Bluetooth Adaptor has the Cambridge Silicon Radio chipset and works fine"

This is the one that I have - yet it doesn't work fine. Also, from what I've found by googling, Bluetooth doesn't seem to work fine with any adaptor!

Jim

Re: Bluetooth working?

Posted: Mon Sep 10, 2012 12:52 pm
by rasbeer
There seem to be problems with Bluetooth support in Linux generally recently. I read that the Bluez developers haven't done a terribly good job documenting some of the changes they've been making.

Re: Bluetooth working?

Posted: Tue Sep 11, 2012 9:07 am
by Wendo
I've never used bluetooth in linux before but i can see my iphone when I do an

hcitool scan

So at least that much works

Re: Bluetooth working?

Posted: Tue Sep 11, 2012 9:43 am
by Sander
Wendo wrote:I've never used bluetooth in linux before but i can see my iphone when I do an

hcitool scan

So at least that much works
On your Raspi? So you have a BT-USB-dongle inserted in your Raspi?

Can you:
- post the name of the BT USB dongle, and do "lsusb -v", and post the BT stuff here?
- run 'hcitool scan' each 5 minutes (in crontab*) ... in my experience it stops working after a few hours.


* crontab explanation: Type "crontab -e" (e for edit), and type:

Code: Select all

*/5 * * * *         hcitool scan >> /home/pi/hcitool-scan.txt
The "*/5 * * * *" means: each 5 minutes, on each hour/day/etc.

Re: Bluetooth working?

Posted: Tue Sep 11, 2012 11:04 am
by MaxK1
Jim Ford wrote:It's frustrating that the list of "RPi Verified Peripherals" gives a list of working Bluetooth adaptors, furthermore stating:

"Tesco own brand 'Technika' Nano Bluetooth Adaptor has the Cambridge Silicon Radio chipset and works fine"

This is the one that I have - yet it doesn't work fine. Also, from what I've found by googling, Bluetooth doesn't seem to work fine with any adaptor!

Jim
One of the big problems with the list of "RPi verified peripherals" is that you just don't know the "quality" of either the test setup, the testers ability to fully test every feature/function of the device, the abilities of the tester(s) themselves or if there are "engineering" differences in the products that might be "in the wild", etc... Don't even get me started on devices that work individually, but not in combination...

Re: Bluetooth working?

Posted: Tue Sep 11, 2012 11:24 am
by MaxK1
I'll add to my previous post...

Some "device" may have worked at a given level of the OS but fails at another.

The list of "problem" devices also suffers from people who couldn't get the device to work.
"I couldn't get it to work" is not the same as "It doesn't work"