timjstone
Posts: 9
Joined: Wed Sep 19, 2012 10:35 am

Application Launch Bar Issue

Thu Oct 20, 2016 9:42 am

Since last nights update, i have been unable to add an application via the Application Launch Bar settings app. if i manually amend the file, i can change the icons/apps, but clicking the "Add" button in the settings application seems to do nothing. Clicking "Remove" does remove an existing app, so i seem to have read/write access to the file via the app.

spl23
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 378
Joined: Fri Dec 26, 2014 11:02 am

Re: Application Launch Bar Issue

Thu Oct 20, 2016 9:45 am

Hmm - you're right; this worked the other day, because I tested it! I'll see if I can find out what got broken in the last set of releases. Thanks for pointing it out!

timjstone
Posts: 9
Joined: Wed Sep 19, 2012 10:35 am

Re: Application Launch Bar Issue

Thu Oct 20, 2016 10:22 am

no problem, i thought i was going mad! the problem from my side is narrowing down the root cause.

Tim

spl23
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 378
Joined: Fri Dec 26, 2014 11:02 am

Re: Application Launch Bar Issue

Thu Oct 20, 2016 10:48 am

I've found the problem - in the last update, I added some code to check whether the target of a launchbar button actually existed when deciding whether or not to show it (so that launchbar buttons are hidden if the user removes the application to which they link). Unfortunately, it seems that the same code is also called when adding a button from the dialog, and at the point where the code is called, the target is not yet set so doesn't exist - hence the buttons are not added.

Just testing the fix now...

spl23
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 378
Joined: Fri Dec 26, 2014 11:02 am

Re: Application Launch Bar Issue

Thu Oct 20, 2016 3:19 pm

Fix is tested and being uploaded to the repo now - should be available in an hour or so. The usual "sudo apt-get update" followed by "sudo apt-get dist-upgrade" will apply it - please shout if the launchbar is still misbehaving afterwards!

Malman35
Posts: 425
Joined: Sun Nov 30, 2014 4:51 am

Re: Application Launch Bar Issue

Fri Oct 21, 2016 2:36 am

spl23 wrote:Fix is tested and being uploaded to the repo now - should be available in an hour or so. The usual "sudo apt-get update" followed by "sudo apt-get dist-upgrade" will apply it - please shout if the launchbar is still misbehaving afterwards!
I am having the same problem but when I ran dist-upgrade (I already ran apt-get update) it said there was no upgrade.

Code: Select all

pi@malman:~ $ sudo apt-get update
Hit http://archive.raspberrypi.org jessie InRelease                 
Hit http://mirrordirector.raspbian.org jessie InRelease                        
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages    
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB   
Ign http://archive.raspberrypi.org jessie/main Translation-en                  
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB                 
Ign http://archive.raspberrypi.org jessie/ui Translation-en                    
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB        
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en           
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB           
Ign http://mirrordirector.raspbian.org jessie/main Translation-en              
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB       
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en          
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB            
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en               
Reading package lists... Done                                                  
pi@malman:~ $ sudo apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Edit:My bad. I just logged out to the CLI and went back to the UI and it worked fine.

Return to “Raspbian”