pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

Jessie: Keyboard settings not saved

Wed Oct 07, 2015 1:49 am

Updated to jessie 2015-10-06

I am trying to set the keyboard to french canada but I lose it after re-boot.

I need to set the keyboard for each starup otherwise it stick french france. The keys are all messed up.

klricks
Posts: 6510
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Jessie: Keyboard settings not saved

Wed Oct 07, 2015 2:09 am

pcote_pi wrote:Updated to jessie 2015-10-06

I am trying to set the keyboard to french canada but I lose it after re-boot.

I need to set the keyboard for each starup otherwise it stick french france. The keys are all messed up.
Known issue.
You need to do keyboard setup the old way.

Code: Select all

sudo raspi-config
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

knute
Posts: 446
Joined: Thu Oct 23, 2014 12:14 am
Location: Texas
Contact: Website

Re: Jessie: Keyboard settings not saved

Wed Oct 07, 2015 9:55 pm

raspi-config isn't working on my Pi2B either. I've edited the /etc/default/keyboard file directly and that seems to work.

pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

Re: Jessie: Keyboard settings not saved

Thu Oct 08, 2015 2:09 am

I have tried raspi-config and that failed too.

klricks
Posts: 6510
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Jessie: Keyboard settings not saved

Thu Oct 08, 2015 2:48 am

pcote_pi wrote:I have tried raspi-config and that failed too.
Works for me.... I just changed from US to UK then back to US. I verified that the /etc/default/keyboard file was changed each time.
Did you forget to reboot after making the keyboard changes?
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

pcote_pi
Posts: 38
Joined: Mon Nov 03, 2014 12:29 am
Location: Montréal

Re: Jessie: Keyboard settings not saved

Thu Oct 08, 2015 6:46 pm

Yes, I tried several times with raspi-config followed by a re-boot. No luck.

raspi-config no longer has the French Canada option. Only French. The graphical tool does have the French Canada choice so they are not consistent.

User avatar
jojopi
Posts: 3078
Joined: Tue Oct 11, 2011 8:38 pm

Re: Jessie: Keyboard settings not saved

Thu Oct 08, 2015 8:22 pm

pcote_pi wrote:raspi-config no longer has the French Canada option. Only French.
It does. You have to select "French (Canada)" in the preceding question, not "French". Choose "Other" to go back.

It is not necessary to reboot after changing layout with raspi-config. (In previous images, if you enabled boot to desktop and rebooted before changing layout, then you would need to reboot again or hot plug the keyboard. That is fixed.)

After changing layout with lxkeymap, it is best never to reboot. It only configures the per-user GUI layout, not the system default, so there is always a risk you will exposed to the system layout in future.

Due to the number of factors affecting which layout takes precedence, if you have already run both tools it would be advisable to make sure they agree.

1775
Posts: 51
Joined: Sat Apr 18, 2015 4:16 am

Re: Jessie: Keyboard settings not saved

Fri Oct 09, 2015 5:17 am

I am glad that I stopped over here to see that I am not the only one that was having this problem. Using sudo raspi-config worked for me - reboot and all is well. I only wish that there was a setting for a Generic US Querty Keyboard. I have no idea which one to choose - picked US with alternative international and that seems to be right. I am not sure what the alternative international does or how it is accessed.

Anyway, thanks for sharing how to get the keyboard to set and stay set!

RobinGreig
Posts: 14
Joined: Sat Oct 27, 2012 2:40 am
Location: Calgary, Alberta, Canada

Re: Jessie: Keyboard settings not saved

Wed Dec 16, 2015 3:38 pm

What I find interesting is that I can change the keyboard layout to Canada > English and shift 3 show the # sign rather than the British Currency Pound sign.
Yet when I switch to my preferred command line (Ctrl-Alt-F1), the shift 3 still shows the British Pound sign.
I have success in running sudo raspi-config and changing it there.
Just thought it was interesting that the GUI would change, but not the command line....
Robin
www.robingreig.ca
Arduino + Raspi + Amateur Radio enthusiast since 2012
VE6RBN Canadian Amateur Radio Callsign

Stanwine
Posts: 1
Joined: Thu Mar 31, 2016 6:52 am

Re: Jessie: Keyboard settings not saved

Thu Mar 31, 2016 7:03 am

Hi
Just began (today) as a newbie. Using the GUI for configuration preferences as I needed to change most of the fields.

The changes (after re-booting) worked OK for Language[and Locale - but would not change Keyboard or Wi-fi Country.

Rgds
Stanwine

Return to “Raspbian”