n0rc
Posts: 3
Joined: Fri Jul 20, 2012 4:01 am

CPAN fails when I run install

Mon Jul 23, 2012 1:25 pm

When I try to install ANYTHING or run update I get:

Code: Select all

Going to read '/home/pi/.cpan/sources/modules/02packages.details.txt.gz'
Warning: Your /home/pi/.cpan/sources/modules/02packages.details.txt.gz does not contain a Line-Count header.
Please check the validity of the index file by comparing it to more
than one CPAN mirror. I'll continue but problems seem likely to
happen.
How do I fix this?

saif
Posts: 74
Joined: Sun Apr 15, 2012 8:15 pm
Contact: Website

Re: CPAN fails when I run install

Mon Jul 30, 2012 6:42 am

I struggled to install cpan modules myself
I eventually used cpanminimus

Steps 1) get cpanm

Code: Select all

sudo apt-get install curl
sudo curl -L http://cpanmin.us | perl - --sudo App::cpanminus
cpanm will often fail, because the gcc version installed is 4.6
Step 2) install gcc-4.7

Code: Select all

sudo apt-get install gcc-4.7
Step 3) Install the modules you want e.g.

Code: Select all

sudo cpanm XML::Parser

nemo096
Posts: 26
Joined: Wed Dec 26, 2012 10:54 am

Re: CPAN fails when I run install

Thu Jul 18, 2013 9:32 am

I tried to install cpanminus but I got an error saying "curl(6) couldnt resolve host "cpanmin.us"

Does anyone know what is wrong?

Thanks

User avatar
IgorGanapolsky
Posts: 33
Joined: Sun Apr 10, 2016 8:32 pm

Re: CPAN fails when I run install

Mon Jan 30, 2017 9:15 pm

I am receiving the following error when trying your command:
Can't locate strict.pm in @INC (you may need to install the strict module) (@INC contains: /etc/perl
Step 3) Install the modules you want e.g.

Code: Select all

sudo cpanm XML::Parser
[/quote]

Return to “Raspbian”