User avatar
DougieLawson
Posts: 35840
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Jessie Q&A

Fri Oct 23, 2015 3:09 pm

dom wrote:
dom wrote:
novacausekey wrote:Hi there, it's my first post here. I just installed Raspbian Jessie on my Pi2 & I'm really pleased with some changes, but I've got some problems with "Raspberry Pi Configuration" app. When I go to "Localisation > Set Keyboard", choose "Polska" (Polish) & click "ok", my keyboard layout change to polish. But Raspbian forgets about it when I restart - then it changes to "UK". How can I force it to save my choice?
I've just checked and this is a known problem. A patch is being tested and will hopefully be available through "apt-get upgrade" soon.
This should be present now. Please run:

Code: Select all

sudo apt-get update && sudo apt-get upgrade
test again, and report back if issue is fixed.
Thanks for making /etc/network/interfaces even simpler than it was with the first version of raspberrypi-net-mods. It should be easier to explain how to set static IP addresses (in dhcpcd.conf) now.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

Malman35
Posts: 425
Joined: Sun Nov 30, 2014 4:51 am

Re: Jessie Q&A

Sat Oct 24, 2015 1:30 am

fruitoftheloom wrote: IF you have the RPi2B ARMv7 you can install Chromium 45:

viewtopic.php?f=63&t=121195
WOW that is totally awesome! I got Chromium 45 on my rpi2 easily and it runs WAY better the the chromuim I used before! It is much faster, I can sync bookmarks, add extensions, and add themes! None of those worked on the old one

p.s. Writing this from chromium 45 on my rpi 2 :D

drencor
Posts: 27
Joined: Sun Feb 16, 2014 11:45 pm

Re: Jessie Q&A

Sat Oct 24, 2015 5:30 am

jamesh wrote:Please put any questions about the new Jessie release in this thread. We will endeavour to answer then as soon as possible.

Please keep it to Q&A, posts not answering that description may be deleted without warning, to keep things tidy.
My Raspberry Pi 2 Model B was working with Jesse fine with WiFi. I did a

sudo apt-get update
sudo apt-get upgrade

The interfaces file got changed and the following lines got removed:
auto eth0
allow-hotplug eth0

auto wlan0
allow-hotplug wlan0

auto wlan1
allow-hotplug wlan1

After this new interfaces file my WiFi stopped working. My question is what was the intent of this change as it seems to break WiFi?

I manually added these lines back in and now my WiFi is working again, but again this is probably something that may wish to be addressed as disabling working WiFi connections may cause larger scale issues for people that may not have direct access to their RPi's.

User avatar
novacausekey
Posts: 3
Joined: Fri Oct 23, 2015 10:55 am

Re: Jessie Q&A

Sat Oct 24, 2015 3:55 pm

drencor wrote:My Raspberry Pi 2 Model B was working with Jesse fine with WiFi. I did a

sudo apt-get update
sudo apt-get upgrade

The interfaces file got changed and the following lines got removed:
auto eth0
allow-hotplug eth0

auto wlan0
allow-hotplug wlan0

auto wlan1
allow-hotplug wlan1

After this new interfaces file my WiFi stopped working. My question is what was the intent of this change as it seems to break WiFi?

I manually added these lines back in and now my WiFi is working again, but again this is probably something that may wish to be addressed as disabling working WiFi connections may cause larger scale issues for people that may not have direct access to their RPi's.
When I did sudo apt-get update && sudo apt-get upgrade to fix Raspberry Pi Configuration app forgetting my polish keyboard layout, it fixed my keyboard but broke my WiFi. Where do I copy this lines to make it work again?

diederik
Posts: 391
Joined: Wed Mar 26, 2014 11:17 pm

Re: Jessie Q&A

Sat Oct 24, 2015 4:07 pm

novacausekey wrote:Where do I copy this lines to make it work again?
/etc/network/interfaces

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5318
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Jessie Q&A

Sat Oct 24, 2015 5:09 pm

novacausekey wrote:When I did sudo apt-get update && sudo apt-get upgrade to fix Raspberry Pi Configuration app forgetting my polish keyboard layout, it fixed my keyboard but broke my WiFi. Where do I copy this lines to make it work again?
Another apt-get upgrade should fix it. See: https://github.com/raspberrypi/linux/issues/1174

User avatar
novacausekey
Posts: 3
Joined: Fri Oct 23, 2015 10:55 am

Re: Jessie Q&A

Sat Oct 24, 2015 9:49 pm

dom wrote:Another apt-get upgrade should fix it. See: https://github.com/raspberrypi/linux/issues/1174
Thanks, apt-get upgrade fixed it.

Milliways
Posts: 436
Joined: Fri Apr 25, 2014 12:18 am
Location: Sydney, Australia

Re: Jessie Q&A

Mon Oct 26, 2015 10:03 am

drencor wrote: My Raspberry Pi 2 Model B was working with Jesse fine with WiFi. I did a

sudo apt-get update
sudo apt-get upgrade

The interfaces file got changed and the following lines got removed:
auto eth0
allow-hotplug eth0

auto wlan0
allow-hotplug wlan0

auto wlan1
allow-hotplug wlan1

After this new interfaces file my WiFi stopped working. My question is what was the intent of this change as it seems to break WiFi?

I manually added these lines back in and now my WiFi is working again, but again this is probably something that may wish to be addressed as disabling working WiFi connections may cause larger scale issues for people that may not have direct access to their RPi's.
If the Foundation had setup dhchcd as the author intended /etc/network/interfaces would not be needed. Find and install /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant and delete /etc/network/interfaces (although it won't hurt if you leave it).

fruitoftheloom
Posts: 20506
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Jessie Q&A

Mon Oct 26, 2015 10:10 am

dom wrote:
novacausekey wrote:When I did sudo apt-get update && sudo apt-get upgrade to fix Raspberry Pi Configuration app forgetting my polish keyboard layout, it fixed my keyboard but broke my WiFi. Where do I copy this lines to make it work again?
Another apt-get upgrade should fix it. See: https://github.com/raspberrypi/linux/issues/1174
Thank you, all tiddley-poo now after a dist-upgrade :D
Retired disgracefully.....

ve2tmq
Posts: 1
Joined: Wed Oct 28, 2015 3:13 pm

Re: Jessie Q&A

Wed Oct 28, 2015 3:18 pm

Hi Folks.

With Wheeze, it's easy to boot Raspbian on QEMU, but with Jessie, they are a lot of new things (Kernel 4, SystemD). There is not docs found on Google about it. Does some one successful boot Jessie Raspbian on QEMU and how did you get it?

Thanks.

wozza
Posts: 1
Joined: Thu Oct 29, 2015 10:58 pm

Re: Jessie Q&A

Thu Oct 29, 2015 11:21 pm

Hello,
I've used FLow(FTP and SFTP tfrs) with Pi, Pi 2 and Wheezy, no problems. Now using Jessie, for its touch screen capability, and Flow has tossed its toys..."Key Exchange Failed" ...no connection. I'm a bit new at this and have 'assumed' the problem is the ECDSA key fingerprint, mainly because I can log into Pi 2 running Jessie via Terminal successfully. Flow has been such a cool tool, but is now unsupported, I wonder whether some knowledgeable person can suggest a Jessie mod that will maintain my KISS method of SFTP to the Pi 2?
Wozza

User avatar
dliloch
Posts: 168
Joined: Wed Jun 27, 2012 6:28 pm
Location: cleveland, ohio usa

Re: Jessie Q&A

Fri Oct 30, 2015 10:52 am

hello,
I installed jessie using just .IMG file not noobs. It booted fine and went to desktop. I customized it to boot to just the cli. Then when I tried startx it comes up screen is black and it goes back to cli. If I use raspi-config and specify boot to desktop and auto login it is fine I have a graphical desktop again. So is booting to cli and then doing startx no longer a supported way of running?
I can't see anything like obvious error messages in Xorg.0.log. I can post the log if required. Here is my current level:
Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
thanks..

gkreidl
Posts: 6054
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Jessie Q&A

Fri Oct 30, 2015 11:24 am

For me startx is still working. But I upgraded from Wheezy to Jessie.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5054
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Jessie Q&A

Sat Oct 31, 2015 6:12 pm

gkreidl wrote:For me startx is still working...
+1
I'm using a "fresh" install** of the same "direct image" as @dliloch ie.

Code: Select all

pi@raspiJamesA8Gb ~ $ uname -a
Linux raspiJamesA8Gb 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
pi@raspiJamesA8Gb ~ $ df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/root        7460004 3437036   3660384  49% /
devtmpfs          469756       0    469756   0% /dev
tmpfs             474060       0    474060   0% /dev/shm
tmpfs             474060    6384    467676   2% /run
tmpfs               5120       4      5116   1% /run/lock
tmpfs             474060       0    474060   0% /sys/fs/cgroup
/dev/mmcblk0p1     57288   20232     37056  36% /boot
tmpfs              94812       0     94812   0% /run/user/1000
on a 8Gb uSDHC card but, because of known issues with the GUI version of raspi-config, that has been upgraded:

Code: Select all

pi@raspiJamesA8Gb ~ $ history
...
  109  sudo apt-get update
  110  uname -a
  111  sudo apt-get upgrade
...
Trev.
** a week or two ago.
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my 2xP3A+, P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Sun Nov 01, 2015 10:24 am

ShiftPlusOne wrote:Oh, interesting. Sounds like the solution might be to provide a working hwclock-equivalent unit that works. Thanks, jojopi.

Bump: any update @ShiftPlusOne?

Roger

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Jessie Q&A

Sun Nov 01, 2015 10:33 am

If you put RTC in the forum search (it's good enough for this) you will come up with a couple of recent posts in threads where I explain how I got it working under jessie

Edit: I could explain it all again here, but there are already many threads relating to RTC detailing successful, or otherwise, attempts under wheezy, some jessie posts too.

If there is some feedback that what I have done also works for others using raspbian jessie then it is probably worth adding an explanation here too

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Sun Nov 01, 2015 1:35 pm

fruit-uk wrote:If you put RTC in the forum search (it's good enough for this) you will come up with a couple of recent posts in threads where I explain how I got it working under jessie

Edit: I could explain it all again here, but there are already many threads relating to RTC detailing successful, or otherwise, attempts under wheezy, some jessie posts too.

If there is some feedback that what I have done also works for others using raspbian jessie then it is probably worth adding an explanation here too

thanks fruit-uk, I have got it working under wheezy, based on your suggestion and I will try under jessie and if I get it working, report back on the process here to confirm it works. The reason for the original 'bump' is that I am converting my main development pi to jessie and need the RTC working for it.

Roger

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Sun Nov 01, 2015 4:36 pm

fruit-uk wrote:
If there is some feedback that what I have done also works for others using raspbian jessie then it is probably worth adding an explanation here too
This was tested on the default Raspbian build 2015-09-24-raspbian-jessie.

I checked the instructions here viewtopic.php?t=85683 by itsmedoofer » 06 Nov 2014 16:07 together with reading http://afterthoughtsoftware.com/products/rasclock as suggested by fruit-uk, modifying for ds3231. This is on a Pi model 2b

The key for this is to add the line to /boot/config.txt as appropriate for your RTC, in my case for a model 2B)

Code: Select all

dtoverlay=i2c-rtc,ds3231
and to install i2c-tools

Code: Select all

# sudo apt-get install i2c-tools
if not already there. Then modify the hwclock.sh as in the links above and delete fake hwclock and other things depending on how far you want to go in disabling NTP or only using the RTC if the NTP service is not available.

It would be good to have it working by default in jessie as there are now many variants of the correct process depending on wheezy / jessie and the model of Pi being used. If you know what you are doing (in my case 'just') then you can make the appropriate changes for your own setup.

Roger

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Jessie Q&A

Sun Nov 01, 2015 4:51 pm

Why didn't you just purge fake-hwclock?

Is all working for your jessie install without modifying /lib/udev/hwclock-set as suggested in the link?

It was the last bit that got mine working correctly, otherwise some other rubbish was being written to RTC by something,

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Sun Nov 01, 2015 9:15 pm

fruit-uk wrote:Why didn't you just purge fake-hwclock?

Is all working for your jessie install without modifying /lib/udev/hwclock-set as suggested in the link?

It was the last bit that got mine working correctly, otherwise some other rubbish was being written to RTC by something,
no it was the mod to hwclock.sh that seemed to stop rubbish being written to the RTC, when I commented out as this

Code: Select all

            init_rtc_device
#
#          Raspberry Pi doesn't have udev detectable RTC
#
#           if [ -d /run/udev ] || [ -d /dev/.udev ]; then
#               return 0
#           fi
it all started working fine (having modified /boot/config.txt first)

Roger

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Jessie Q&A

Sun Nov 01, 2015 9:28 pm

Now I am getting confused!
I haven't touched hwclock.sh at all on jessie.

I'll have to look backwards and see if can find what changes you have made there and if likely to have a similar effect.
Good you have got it working though.

Edit:
My guess is that you have pretty much followed the changes for wheezy not those specifically suggested for jessie in http://afterthoughtsoftware.com/products/rasclock
It doesn't matter as long as it's working but means we don't have just the one way of doing things - and jessie RTC threads may get just as messy as wheezy :/

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Mon Nov 02, 2015 10:53 am

fruit-uk wrote:Now I am getting confused!
I haven't touched hwclock.sh at all on jessie.

Edit:
My guess is that you have pretty much followed the changes for wheezy not those specifically suggested for jessie in http://afterthoughtsoftware.com/products/rasclock
:/
I will make a fresh install of jessie release and see what happens with minimal changes and update here later

Roger

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Jessie Q&A

Mon Nov 02, 2015 11:16 am

That would be useful however now you have a working RTC seems overkill.

If you do, then enable i2c from raspi-config - easier that way :)
Add relevant dtoverlay for your RTC to config.txt.

It was mentioned elsewhere that you have to modprobe some modules to actually get the RTC/hwckock working.
I have i2c-dev, i2c-bcm2708. rtc-ds1307 in /etc/modules which should do the same once i2c is enabled

You mentioned having to install i2c-tools earlier. It is recommeneded to check the RTC is available using these tools after initially installing the hardware with

Code: Select all

sudo i2cdetect -y 1
(so generally assumed this is already installed)

After that purge fake-hwclock, install hwclock if not already, comment those referenced lines in /lib/udev/hwclock-set.sh

Set hwclock, reboot

With luck all should be working

All from memory so may be mistakes above - apart from the useual typos ;)

Edit;
Following a post in one of the other RTC threads I have re-read the referenced instructions and see that I completely missed the step that you performed re. commenting out the --systz lines... so you were correct, sorry :(

User avatar
g7ruh
Posts: 67
Joined: Mon Apr 23, 2012 9:49 am
Location: Blackfield UK

Re: Jessie Q&A

Mon Nov 02, 2015 9:18 pm

fruit-uk wrote:That would be useful however now you have a working RTC seems overkill.


You mentioned having to install i2c-tools earlier. It is recommeneded to check the RTC is available using these tools after initially installing the hardware with

Code: Select all

sudo i2cdetect -y 1
(so generally assumed this is already installed)




Edit;
Following a post in one of the other RTC threads I have re-read the referenced instructions and see that I completely missed the step that you performed re. commenting out the --systz lines... so you were correct, sorry :(
Fresh install of Raspian jessie:

Code: Select all

pi@raspberrypi ~ $ sudo i2cdetect -y 1
sudo: i2cdetect: command not found
pi@raspberrypi ~ $
which did confuse me too.. as I expected it to be there

re --systz lines... so you were correct, sorry .... no apology needed, this stuff is confusing enough :shock:


onwards and upwards....

still no changes from release

Code: Select all

pi@raspberrypi ~ $ sudo hwclock  -r
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
pi@raspberrypi ~ $
enable i2c from raspi-config in x
reboot pi

Code: Select all

pi@raspberrypi ~ $ sudo i2cdetect -y 1
sudo: i2cdetect: command not found
pi@raspberrypi ~ $
and

Code: Select all

pi@raspberrypi ~ $ sudo hwclock  -r
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
pi@raspberrypi ~ $
so no change after enable i2c in raspi-config via X

install i2c-tools

Code: Select all

# sudo apt-get update
# apt-get install i2c-tools


pi@raspberrypi ~ $  sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- 18 -- -- -- -- -- -- --
20: -- -- -- -- 24 -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- 39 -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- 48 -- -- -- -- -- -- --
50: -- 51 -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --
pi@raspberrypi ~ $

so that is as expected, 68 shows the rtc


modify /boot/config.txt
to add

Code: Select all

#
dtoverlay=i2c-rtc,ds3231
#
then

reboot

Code: Select all

pi@raspberrypi ~ $ sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- 18 -- -- -- -- -- -- --
20: -- -- -- -- 24 -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- 39 -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- 48 -- -- -- -- -- -- --
50: -- 51 -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --
pi@raspberrypi ~ $
looks promising, rtc in use (UU)
and

Code: Select all

pi@raspberrypi ~ $ cat /proc/driver/rtc
rtc_time        : 20:38:26
rtc_date        : 2015-11-02
alrm_time       : 00:00:00
alrm_date       : 1970-01-01
alarm_IRQ       : no
alrm_pending    : no
update IRQ enabled      : no
periodic IRQ enabled    : no
periodic IRQ frequency  : 1
max user IRQ frequency  : 64
24hr            : yes
pi@raspberrypi ~ $
the RTC is not corrupted :)

a power off and restart to check all is OK...

Code: Select all

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Nov  2 20:42:07 2015
pi@raspberrypi ~ $ sudo i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- 18 -- -- -- -- -- -- --
20: -- -- -- -- 24 -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- 39 -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- 48 -- -- -- -- -- -- --
50: -- 51 -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --
pi@raspberrypi ~ $ sudo hwclock -r
Mon 02 Nov 2015 20:42:39 UTC  -0.947193 seconds
pi@raspberrypi ~ $ cat /proc/driver/rtc
rtc_time        : 20:42:44
rtc_date        : 2015-11-02
alrm_time       : 00:00:00
alrm_date       : 1970-01-01
alarm_IRQ       : no
alrm_pending    : no
update IRQ enabled      : no
periodic IRQ enabled    : no
periodic IRQ frequency  : 1
max user IRQ frequency  : 64
24hr            : yes
pi@raspberrypi ~ $
so, rethinking what you did / wrote and what I have just done:

enable i2c in raspi-config using X
then add the line to /boot/config.txt for the RTC:

Code: Select all

#
##
dtoverlay=i2c-rtc,ds3231
#
note, my RTC is a chronodot 2 hence the ds3231

Code: Select all

pi@raspberrypi ~ $ i2ctools -y 1
-bash: i2ctools: command not found
pi@raspberrypi ~ $ sudo hwclock -r
Mon 02 Nov 2015 21:01:45 UTC  -0.550603 seconds
pi@raspberrypi ~ $
so i2c-tools are not installed by default
hwclock works fine after the 2 steps above as a summary:

1) enable i2c in raspi-config
2) add the entry to /boot/config.txt as my test pi is a model 2B

and 3)
install i2c-tools if you need to.

does that make sense? as fruit-uk suggested it should all work without much modification and it does. the other referenced posts tend to confuse the differences between wheezy and jessie.


fruit-uk quote "That would be useful however now you have a working RTC seems overkill." .... yes but not too much trouble to help get to the bottom of it all and it seems to be as simple as you suggested in your post. :D


Obviously extra steps are needed to disable the fake hwclock and disable / use RTC if NTP not available need to be added to this as required, as posted elsewhere.

Thanks fruit-uk for the pointers and other from the reference posts as well.

Roger

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Jessie Q&A

Mon Nov 02, 2015 9:37 pm

Mm... a lot of writing ;)
Useful though, thanks.

It seems from the few who have provided feedback that this method works under jessie.

I run ntp on all my machines, that may be why I have all working commenting out

Code: Select all

if [ -e /run/systemd/system ] ; then
    exit 0
fi
but not commenting out

Code: Select all

/sbin/hwclock --rtc=$dev --systz --badyear
and

Code: Select all

/sbin/hwclock --rtc=$dev --systz
lines in /lib/udev/hwclock-set - but I am not totally sure on that :/

Anyway, thanks must go to http://afterthoughtsoftware.com/products/rasclock for their instructions

Return to “Raspbian”