kevins7189
Posts: 3
Joined: Wed May 27, 2015 8:34 pm

Chromium Iceweasel won't play mp3

Wed May 27, 2015 8:45 pm

I'm having sound issues in Chromium and Iceweasel. I get sound in flash, but when I try to play an mp3 in chromium there is no sound. Mp3 works in epiphany.
I thought chromium was smart enough to play mp3 but I guess not? Googling led me to a chromium ffmpeg that does not exist in raspian.

Any ideas?

elatllat
Posts: 1337
Joined: Sat Dec 17, 2011 5:05 pm

Re: Chromium Iceweasel won't play mp3

Thu May 28, 2015 12:47 am

The raspberrypi foundation chose to optimize that other browser instead of chromium maybe due to the memory limitations of pre B2 boards. So a lot of chromium features are disabled on the armv6 build and it's a really old version.
SBC with 32GB RAM: https://hardkernel.com

FAQ : https://raspberrypi.stackexchange.com

Unanswered: https://www.raspberrypi.org/forums/search.php?search_id=unanswered

fruitoftheloom
Posts: 20916
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Chromium Iceweasel won't play mp3

Thu May 28, 2015 4:51 am

kevins7189 wrote:I'm having sound issues in Chromium and Iceweasel. I get sound in flash, but when I try to play an mp3 in chromium there is no sound. Mp3 works in epiphany.
I thought chromium was smart enough to play mp3 but I guess not? Googling led me to a chromium ffmpeg that does not exist in raspian.

Any ideas?
IF you have installed Raspbian forget Flash as it is not natively supported.

IF you have installed Raspbian then maybe use kweb for media viewtopic.php?f=66&t=40860
Retired disgracefully.....

kevins7189
Posts: 3
Joined: Wed May 27, 2015 8:34 pm

Re: Chromium Iceweasel won't play mp3

Thu May 28, 2015 4:02 pm

kweb doesn't play sound either. kweb gtk3 doesn't seem to even work with javascript.
Basically the web page is php/javascript playing an mp3.
Epiphahy works, but crashes alot.
I don't understand why chromium and iceweasel won't play sound, but will through pepperflash.

gkreidl
Posts: 6116
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Chromium Iceweasel won't play mp3

Thu May 28, 2015 4:13 pm

kevins7189 wrote:kweb doesn't play sound either. kweb gtk3 doesn't seem to even work with javascript.
Basically the web page is php/javascript playing an mp3.
Epiphahy works, but crashes alot.
I don't understand why chromium and iceweasel won't play sound, but will through pepperflash.
Of course kweb does play sound and even mp3 within the browser, if you disable omxplayer. And of course it will work with Javascript, if you enable it.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

kevins7189
Posts: 3
Joined: Wed May 27, 2015 8:34 pm

Re: Chromium Iceweasel won't play mp3

Sun May 31, 2015 1:53 pm

any idea why Linaro doesn't have any of these problems? Out-of-the-box Chromium on Linaro works perfectly and as expected.

gkreidl
Posts: 6116
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Chromium Iceweasel won't play mp3

Sun May 31, 2015 2:03 pm

kevins7189 wrote:any idea why Linaro doesn't have any of these problems? Out-of-the-box Chromium on Linaro works perfectly and as expected.
Linaro has newer program versions and Raspbian will get them in a few weeks when the transition to Jessie will be finished.

But mp3 was never part of any HTML specification and support is not required by any browser. In the past, plugins were responsible to support file formats which are not part of the HTML specification.

Webkit is compiled with support for gstreamer (0.1 or 1.0) and so browsers based on it support lots of media formats out of the box.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Return to “Raspbian”