Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Thu Jul 21, 2016 11:43 pm

b1990liam wrote:Hi I'm a total noob to pi & Linux.
I have bought a pi2 and have managed to install raspbian Jessie and got kodi 15.2, I have been reading many post regarding adding deb http://pipplware.... but from start to finish how exactly do you do this ?
Here:
viewtopic.php?f=66&t=109088&start=525#p961205

darkhunter_93
Posts: 2
Joined: Fri Apr 29, 2016 3:29 pm

Re: Kodi 15/16 Packages for Raspbian

Sat Jul 30, 2016 7:38 am

Hi guys, i'm having an issue with the addon on kodi 16.1 installed on pipplware repo. when open the office repository addon it said "Could not connect to the repository". My connection is fine, also with dns google.
Log might use full imo:
14:06:38 52.694000 T:1767674800 ERROR: CRepository: Failed to parse addons.xml. Malformated.
14:06:38 52.694202 T:1767674800 ERROR: CRepositoryUpdateJob[repository.xbmc.org] failed to read or parse directory 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz'
14:06:39 53.400410 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:39 53.400524 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:39 53.400570 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 3)
14:06:40 54.401020 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:40 54.401127 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:40 54.401169 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 4)
14:06:40 55.253330 T:1943908352 ERROR: GetDirectory - Error getting addons://repository.xbmc.org/
14:06:40 55.253551 T:1943908352 ERROR: CGUIMediaWindow::GetDirectory(addons://repository.xbmc.org/) failed
Anyone is facing with my problem, pls help. Thanks

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 01, 2016 2:43 pm

darkhunter_93 wrote:Hi guys, i'm having an issue with the addon on kodi 16.1 installed on pipplware repo. when open the office repository addon it said "Could not connect to the repository". My connection is fine, also with dns google.
Log might use full imo:
14:06:38 52.694000 T:1767674800 ERROR: CRepository: Failed to parse addons.xml. Malformated.
14:06:38 52.694202 T:1767674800 ERROR: CRepositoryUpdateJob[repository.xbmc.org] failed to read or parse directory 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz'
14:06:39 53.400410 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:39 53.400524 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:39 53.400570 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 3)
14:06:40 54.401020 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:40 54.401127 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:40 54.401169 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 4)
14:06:40 55.253330 T:1943908352 ERROR: GetDirectory - Error getting addons://repository.xbmc.org/
14:06:40 55.253551 T:1943908352 ERROR: CGUIMediaWindow::GetDirectory(addons://repository.xbmc.org/) failed
Anyone is facing with my problem, pls help. Thanks
Probably the repo server was offline then. It is online now.

darkhunter_93
Posts: 2
Joined: Fri Apr 29, 2016 3:29 pm

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 01, 2016 2:59 pm

Rascas wrote:
darkhunter_93 wrote:Hi guys, i'm having an issue with the addon on kodi 16.1 installed on pipplware repo. when open the office repository addon it said "Could not connect to the repository". My connection is fine, also with dns google.
Log might use full imo:
14:06:38 52.694000 T:1767674800 ERROR: CRepository: Failed to parse addons.xml. Malformated.
14:06:38 52.694202 T:1767674800 ERROR: CRepositoryUpdateJob[repository.xbmc.org] failed to read or parse directory 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz'
14:06:39 53.400410 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:39 53.400524 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:39 53.400570 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 3)
14:06:40 54.401020 T:1830810544 ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
14:06:40 54.401127 T:1830810544 ERROR: CecLogMessage - Open - vc_cec could not be initialised
14:06:40 54.401169 T:1830810544 ERROR: CecLogMessage - could not open a connection (try 4)
14:06:40 55.253330 T:1943908352 ERROR: GetDirectory - Error getting addons://repository.xbmc.org/
14:06:40 55.253551 T:1943908352 ERROR: CGUIMediaWindow::GetDirectory(addons://repository.xbmc.org/) failed
Anyone is facing with my problem, pls help. Thanks
Probably the repo server was offline then. It is online now.
Thanks, i just checked it again it's now working :mrgreen:

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Tue Aug 09, 2016 11:44 pm

got tvheadend server setup and run ok, than install kodi-pvr-hts and enable tvheadend client addon.
but, when TV --> enable it can not found any client addon then tvheadend addon been disabled, any idea?

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Wed Aug 10, 2016 1:53 am

cjan wrote:got tvheadend server setup and run ok, than install kodi-pvr-hts and enable tvheadend client addon.
but, when TV --> enable it can not found any client addon then tvheadend addon been disabled, any idea?
Please give more information. Make sure your server is compatible with the addon version, which is the current stable one for Kodi 16.1 (on the pipplware repo)

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Wed Aug 10, 2016 3:10 am

Rascas wrote:
cjan wrote:got tvheadend server setup and run ok, than install kodi-pvr-hts and enable tvheadend client addon.
but, when TV --> enable it can not found any client addon then tvheadend addon been disabled, any idea?
Please give more information. Make sure your server is compatible with the addon version, which is the current stable one for Kodi 16.1 (on the pipplware repo)
kodi & kodi-pvr-hts from pipplware repo and tvheadend_4.0.8~jessie_armhf.deb from apt repo.
does pipplware share tvheadend? or where can found compatible version?

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Wed Aug 10, 2016 9:37 am

cjan wrote:
Rascas wrote:
cjan wrote:got tvheadend server setup and run ok, than install kodi-pvr-hts and enable tvheadend client addon.
but, when TV --> enable it can not found any client addon then tvheadend addon been disabled, any idea?
Please give more information. Make sure your server is compatible with the addon version, which is the current stable one for Kodi 16.1 (on the pipplware repo)
kodi & kodi-pvr-hts from pipplware repo and tvheadend_4.0.8~jessie_armhf.deb from apt repo.
does pipplware share tvheadend? or where can found compatible version?
Yes, that's the version of tvheadend that I use with PiPplware Kodi's and the pvr hts (tvheadend). Please post your server log and kodi log's and I can try to see what's the problem although I am not an expert with this kind of servers/pvrs.

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Wed Aug 10, 2016 11:46 am

Rascas wrote:Yes, that's the version of tvheadend that I use with PiPplware Kodi's and the pvr hts (tvheadend). Please post your server log and kodi log's and I can try to see what's the problem although I am not an expert with this kind of servers/pvrs.
sorry, im not familiar with tvheaded too, where are those log?

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Wed Aug 10, 2016 12:55 pm

cjan wrote:
Rascas wrote:Yes, that's the version of tvheadend that I use with PiPplware Kodi's and the pvr hts (tvheadend). Please post your server log and kodi log's and I can try to see what's the problem although I am not an expert with this kind of servers/pvrs.
sorry, im not familiar with tvheaded too, where are those log?
ok, one of them

Code: Select all

tvheadend[6673]: mpegts: 593MHz in TV - scan complete
tvheadend[6673]: subscription: 018F: "scan" unsubscribing
tvheadend[6673]: mpegts: 569MHz in TV - tuning on Afatech AF9013 : DVB-T #0
tvheadend[6673]: subscription: 0191: "scan" subscribing to mux "569MHz", weight: 2, adapter: "Afatech AF9013 : DVB-T #0", network: "TV", service: "Raw PID Subscription"
tvheadend[6673]: tot: invalid checksum (len 8, errors 1)

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Sun Aug 14, 2016 10:46 pm

ok, upgrade to tvheadend-4.1.1492 & kodi-pvr-hts-2.2.4 sloved all problem.
Rio 2016 here i come ~~~~~~~~~~~~~~~~~~~~

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 15, 2016 1:41 am

cjan wrote:ok, upgrade to tvheadend-4.1.1492 & kodi-pvr-hts-2.2.4 sloved all problem.
Rio 2016 here i come ~~~~~~~~~~~~~~~~~~~~
just catch up Bolt win 100M in time, ha~~~~

speendo
Posts: 13
Joined: Fri Sep 18, 2015 9:19 am

Re: Kodi 15/16 Packages for Raspbian

Sat Aug 20, 2016 7:42 pm

Hi!

I really admire your work! Using Kodi 16 in Raspbian is exactly what I wanted!

However, I experience some problems lately. When I try to start Kodi, it asks me for the sudo password several times.

I tried to upgrade, but this brought me in even bigger problems. The installation of the package does somehow not work. This is what the console says:

Code: Select all

pi@mediacenter:~ $ cat /etc/apt/sources.list.d/pipplware.list            
deb http://dl.bintray.com/pipplware/dists/jessie/main/binary/ ./
deb http://dl.bintray.com/pipplware/dists/jessie/armv7/binary/ ./

pi@mediacenter:~ $ sudo dpkg -l kodi
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version       Architecture  Description
+++-================-=============-=============-======================================
iF  kodi             2:16.1-5~jess all           Kodi Media Center (arch-independent da

pi@mediacenter:~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up kodi (2:16.1-5~jessie) ...
adduser: The user `kodi' already exists. Exiting.
dpkg: error processing package kodi (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 kodi
E: Sub-process /usr/bin/dpkg returned an error code (1)
Can you please help me with that?

Thank you!

speendo
Posts: 13
Joined: Fri Sep 18, 2015 9:19 am

Re: Kodi 15/16 Packages for Raspbian

Sat Aug 20, 2016 11:50 pm

I think I could solve the update problem on my own.

I backuped the home folder of user kodi and then deleted the kodi user and it's home folder.

After that the update worked.

There might be a more elegant way, though...

speendo
Posts: 13
Joined: Fri Sep 18, 2015 9:19 am

Re: Kodi 15/16 Packages for Raspbian

Sat Aug 20, 2016 11:57 pm

... however, the other part of the problem remains:

when I start kodi from the command line, it asks me for a sudo password 6 times. When I just press enter, finally kodi starts. Still this seems not right...

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 9:17 am

speendo wrote:... however, the other part of the problem remains:

when I start kodi from the command line, it asks me for a sudo password 6 times. When I just press enter, finally kodi starts. Still this seems not right...
Are you using another user besides "pi" to start kodi ? If not, did you changed the user "pi" sudo permissions, like to ask password with the use of "sudo" in the sudoers config ?

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 10:15 am

cjan wrote:
cjan wrote:ok, upgrade to tvheadend-4.1.1492 & kodi-pvr-hts-2.2.4 sloved all problem.
Rio 2016 here i come ~~~~~~~~~~~~~~~~~~~~
just catch up Bolt win 100M in time, ha~~~~
Olympus is over, a question...
omxplayer --> HD-TV channels --> video & audio OK, SD-TV channels only audio
mmal --> HD & SD TV channels --> video & audio both OK
why is that?

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 10:22 am

cjan wrote:
cjan wrote:
cjan wrote:ok, upgrade to tvheadend-4.1.1492 & kodi-pvr-hts-2.2.4 sloved all problem.
Rio 2016 here i come ~~~~~~~~~~~~~~~~~~~~
just catch up Bolt win 100M in time, ha~~~~
Olympus is over, a question...
omxplayer --> HD-TV channels --> video & audio OK, SD-TV channels only audio
mmal --> HD & SD TV channels --> video & audio both OK
why is that?
Probably, you are watching something encoded in an unsupported codec and/or you don't have the licenses for mpeg-2 and vc-1. Check the codec of the video by pressing "o" key.

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 11:17 am

Rascas wrote:
cjan wrote:
cjan wrote:just catch up Bolt win 100M in time, ha~~~~
Olympus is over, a question...
omxplayer --> HD-TV channels --> video & audio OK, SD-TV channels only audio
mmal --> HD & SD TV channels --> video & audio both OK
why is that?
Probably, you are watching something encoded in an unsupported codec and/or you don't have the licenses for mpeg-2 and vc-1. Check the codec of the video by pressing "o" key.
no, all SD-TV channels can play under VLC sdl_vout.

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 11:32 am

cjan wrote: no, all SD-TV channels can play under VLC sdl_vout.
That doesn't confirm the video codec. VLC doesn't even use omxplayer, or any kind of hardware acceleration on the Pi.

Anyway, if you are using a RPi 2 or 3, mmal is the recommended (default), since it has more features, using only slightly more resources.

cjan
Posts: 708
Joined: Sun May 06, 2012 12:00 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 11:49 am

Rascas wrote:
cjan wrote: no, all SD-TV channels can play under VLC sdl_vout.
That doesn't confirm the video codec. VLC doesn't even use omxplayer, or any kind of hardware acceleration on the Pi.

Anyway, if you are using a RPi 2 or 3, mmal is the recommended (default), since it has more features, using only slightly more resources.
ok, off topic
does mmal is open source? why VLC mmal suck & Kodi mmal rock ?

speendo
Posts: 13
Joined: Fri Sep 18, 2015 9:19 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 12:45 pm

Rascas wrote:
speendo wrote:... however, the other part of the problem remains:

when I start kodi from the command line, it asks me for a sudo password 6 times. When I just press enter, finally kodi starts. Still this seems not right...
Are you using another user besides "pi" to start kodi ? If not, did you changed the user "pi" sudo permissions, like to ask password with the use of "sudo" in the sudoers config ?
Yes I use several users on this raspberry pi - some of them should have access to kodi, however, not all of them should be sudo users.

Is there a way to user kodi without sudo permissions?

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 1:20 pm

speendo wrote:
Rascas wrote:
speendo wrote:... however, the other part of the problem remains:

when I start kodi from the command line, it asks me for a sudo password 6 times. When I just press enter, finally kodi starts. Still this seems not right...
Are you using another user besides "pi" to start kodi ? If not, did you changed the user "pi" sudo permissions, like to ask password with the use of "sudo" in the sudoers config ?
Yes I use several users on this raspberry pi - some of them should have access to kodi, however, not all of them should be sudo users.

Is there a way to user kodi without sudo permissions?
If you use "pi" user with default configurations on Raspbian it should work just fine. If you are using another user, you can configures sudoers to no ask password for your user, or maybe better, edit /usr/bin/kodi and remove/comment the 2 lines which call "sudo". This 2 lines are to fix 2 bugs, but you may not get affected by them. In Kodi 17 I will try to change it to not depend and sudo. This was already talked earlier in this topic.

speendo
Posts: 13
Joined: Fri Sep 18, 2015 9:19 am

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 1:33 pm

Rascas wrote:If you use "pi" user with default configurations on Raspbian it should work just fine. If you are using another user, you can configures sudoers to no ask password for your user, or maybe better, edit /usr/bin/kodi and remove/comment the 2 lines which call "sudo". This 2 lines are to fix 2 bugs, but you may not get affected by them. In Kodi 17 I will try to change it to not depend and sudo. This was already talked earlier in this topic.
Oh, ok!

I read about these bugs before but I thought they were fixed already (or I commented those 2 lines out in an earlier version of the package).

Thank you!

Rascas
Posts: 460
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Kodi 15/16 Packages for Raspbian

Mon Aug 22, 2016 1:37 pm

cjan wrote:
Rascas wrote:
cjan wrote: no, all SD-TV channels can play under VLC sdl_vout.
That doesn't confirm the video codec. VLC doesn't even use omxplayer, or any kind of hardware acceleration on the Pi.

Anyway, if you are using a RPi 2 or 3, mmal is the recommended (default), since it has more features, using only slightly more resources.
ok, off topic
does mmal is open source? why VLC mmal suck & Kodi mmal rock ?
I am not the right guy to talk about this since I don't develop this, but MMAL stands for Multi-Media Abstraction Layer. In my opinion in Kodi 16 that option is a bit misleading because what it does, is using another player, dvdplayer (videoplayer in Kodi 17) which is a fork of omxplayer with more functionalities. It is developed mainly by popcornmix and some other guys from the Kodi community, so you will get more info if you ask in their forums.

Return to “Raspbian”