Page 1 of 1

alimentation

Posted: Tue Aug 14, 2012 9:40 am
by vohu
Bonjour,

Je suppose que ma réponse se trouve déjà dans un forum, mais après quelques recherches, je n'ai pas trouvé ici.

Voilà, comme tout le monde le sait, le RPi trouve ses limite concernant l'alimentation de l'USB...

Je me posais une question :

Si j'achète un HUB USB alimenté. Que j'utilise un des ports du HUB USB pour alimenter le raspberry, et que je boucle le port HOST du HUB sur le RPi à nouveau, est ce que cela pose problème ? (électriquement parlant)

Un petit shémas pour expliquer ce que je voudrais faire :

Image

Re: alimentation

Posted: Tue Aug 14, 2012 1:36 pm
by mebepi
Bonjour,

oui cela fonctionne mais pas avec tous les HUB USB!

Par exemple j'ai un D-Link DUB-H7 et cela ne fonctionne pas, par contre il parait que cela fonctionne avec le D-Link DUB-H4.
Et je pense avoir lu ici qu'un utilisateur avec D-Link DUB-H7 a expliqué que cela fonctionnait chez lui. Donc non la référence exacte du hub usb qui fonctionne est importante et encore faut-il trouver cette série en particulier...

http://elinux.org/RPi_VerifiedPeriphera ... d_USB_Hubs

Mebepi

Re: alimentation

Posted: Tue Aug 14, 2012 1:43 pm
by jeek
Non, ça ne pose pas de problème électrique, c'est une solution plus élégante et certainement plus économique car ça évite d'avoir plusieurs transfos.
Mais il faut une alimentation suffisamment puissante pour alimenter le Raspberry et tes autres périphériques USB (disques dur externes, webcam, clé wifi, clé bluetooth...). Evidement, ça dépend de ce que tu veux relier à ton hub.
De plus certains hub ne démarrent que s'ils reçoient un signal électrique de l'ordinateur, donc si on s'en sert pour alimenter l'ordinateur en question ça ne peut pas marcher.
Si tu as déjà un hub tu peux l'essayer, moi j'ai un vieux hub no name en USB1 qui fonctionne très bien

Re: alimentation

Posted: Tue Aug 14, 2012 2:17 pm
by vohu
arf, j'ai déjà commandé celui là maintenant :

http://www.amazon.fr/gp/product/B0030ED ... 01_s00_i00

On vera bien... au pire, ça sert toujours ces trucs là.

Re: alimentation

Posted: Tue Aug 14, 2012 2:27 pm
by mebepi
As-tu pris le temps de lire les commentaires sur le produit que tu as acheté?
Ils sont vraiment peu flatteur...

Re: alimentation

Posted: Tue Aug 14, 2012 8:01 pm
by Mgros
Salut j'avais un problème d'alim USB qui me déconnecté une camera...
Car je branché l'alim sur mon PC ou avec des alim secteur de 700mA...

J'ai fais 2 essai concluant pour mon problème...
1)J'ai tout simplement pris un cordon male/femme http://www.leboncable.com/491-thickbox/ ... emelle.jpg
que j'ai dénudé au centre sans couper les fils de donnés et j'ai mis une alim 5V 2A pour ma camera et ça fonctionne.
2)J'ai aussi testé d'alimenter simplement avec ce cordon le raspberry donc avec une alim 5V 2A et ça fonctionne aussi ...

Donc j'en conclu que c'est bien le RPI qui pompe ^^ @+

Re: alimentation

Posted: Fri Aug 17, 2012 3:38 pm
by DimiRPI
Je viens de tester avec un D-Link DUB-H4 hub (v. C1). Il marche très bien du moment que l'on utilise pas le port `high-power` pour alimenter le RPI.

Remarque: le port `high-power` est utilisable pour connecter des périphériques USB

Remarque2:
le câble mini-USB fourni avec le hub était défectueux et j'ai perdu 2h à comprendre pourquoi le hub n'était pas reconnu par le RPI avec de tester avec un autre câble....