User avatar
JeremPi
Posts: 24
Joined: Tue May 05, 2015 1:33 pm

RJ45 - USB / rpi - pc

Tue May 05, 2015 1:53 pm

Bonjour,

A l'aide d'un adaptateur RJ45(femelle) USB(male) je branche un cable reseau sur ma rpi B et reçois en USB sur mon PC.
Le soucis c'est que je n'arrive pas à ce que l'un et l'autre se reconnaissent par IP (chacun fixe).
Sur les deux supports je détecte la connexion réseau, mais les ping ne renvoie rien.

Une idée :?:

Merci à vous ;)

PS: par la suite je compte stream par cette connexion (avec la PiCam noir)

nikotinux
Posts: 674
Joined: Sat Feb 02, 2013 2:11 am

Re: RJ45 - USB / rpi - pc

Tue May 05, 2015 7:48 pm

cable croisé ?

JumpZero
Posts: 972
Joined: Thu Mar 28, 2013 7:35 pm
Location: 127.0.0.1

Re: RJ45 - USB / rpi - pc

Wed May 06, 2015 4:32 am

Bjr,

donnes le resultat de la commande ifconfig sur le raspberry pi
et ipconfig (je suppose que c'est sous Windows) sur le pc
--
Jmp0

User avatar
JeremPi
Posts: 24
Joined: Tue May 05, 2015 1:33 pm

Re: RJ45 - USB / rpi - pc

Wed May 06, 2015 6:54 am

Bonjour à vous,

Premièrement, c'est un câble non-croisé.
Deuxièmement, voici les configurations réseaux.

ipconfig de Windows:

Code: Select all

Carte Ethernet Connexion au réseau local 2 :

   Suffixe DNS propre à la connexion. . . :
   Adresse d'autoconfiguration IPv4 . . . : 169.254.174.201
   Masque de sous-réseau. . . . . . . . . : 255.255.0.0
   Passerelle par défaut. . . . . . . . . :
ifconfig de la rpi:

Code: Select all

eth0         Link encap:Ethernet   HWaddr  b8:27:******
                 inet addr : 169.254.0.1  Bcast 169.254.255.255  Mask 255.255.0.0
                 UP BROADCASTING RUNNING MILTICAST MTU:1500  Metric:1
                 RX packets:78 errors:0 dropped:0 overruns:0 frame:0
                 TX packets:0 errors:0 dropped:0 overruns:0 frame:0
                 collision:0 txqueuelen:1000
                 RX bytes:8172 (7.9KiB)  TX  bytes:0 (0.0B)

lo              Link encap:Local  Loopback
                 inet addr : 127.0.0.1  Mask 255.0.0.0
                 UP LOOPBACK RUNNING MTU:65536  Metric:1
                 RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                 TX packets:0 errors:0 dropped:0 overruns:0 frame:0
                 collision:0 txqueuelen:1000
                 RX bytes:0 (0.0KiB)  TX  bytes:0 (0.0B)
Mon problème venais du fait que ce n'était pas le même masque de sous réseau :roll:
Maintenant que je l'ai changer (edit du post) je me connecte en SSH avec putty depuis le PC sur la rpi.
L'inverse ne marche pas, mais c'est pas grave



Autant pour moi, merci d'avoir répondu. J'aurais surement d’autres questions sur d'autres sujets mais ceux-ci nécessiteront d'autres topics !

Return to “Français”