spatieman
Posts: 10
Joined: Tue Jan 13, 2015 10:06 am

how to select 2nd R820T tune

Thu Jan 15, 2015 7:07 pm

i got 2 rtl dvb-ty devices on my pi (powered usb hub)
1 i use cu6fully for adsb, but i want to use the 2nd one for local websdr use.
but it wont let me,

Code: Select all

rtl_tcp -a 127.0.0.1 -p 1234 1
Found 2 device(s).

Kernel driver is active, or device is claimed by second instance of librtlsdr.
In the first case, please either detach or blacklist the kernel module
(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6
Failed to open rtlsdr device #0.
lsusb say's

Code: Select all

lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 006: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 007: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Bus 001 Device 008: ID 04d9:1203 Holtek Semiconductor, Inc. Keyboard
well, device 004 is the 1st that is in use for ADSB
device 7 is the 2nd i want to use for websdr

how can i tell rtl_tcp to use the 2nd device ?
search with google gave me plenty midlefingers :/

spatieman
Posts: 10
Joined: Tue Jan 13, 2015 10:06 am

Re: how to select 2nd R820T tune

Thu Jan 15, 2015 7:50 pm

never mind , i should drink less..
it was adding the -d (x) flag ,x=device number.

Return to “General discussion”