surendar
Posts: 28
Joined: Mon Jan 13, 2014 3:39 am

Video Play in Vertical

Tue May 13, 2014 6:06 am

Hi!!!!!! Greetings to all.My screen resolution is 1366x768.I want to rotate screen by 90 degree.I done this using "display_rotate=1" in config file.If i rotate a display by 90 degree means How to play a video in full screen i.e it fits to display?

masterluke
Posts: 200
Joined: Tue Apr 17, 2012 4:10 pm

Re: Video Play in Vertical

Tue May 13, 2014 7:15 am

If you want a video to fill the whole screen with video using a portrait oriented screen then its going to be horribly distorted. Your best bet is keeping the correct aspect ratio. This would limit your video to 768x432 maximum effective resolution, but it would have the correct ratio.

tvjon
Posts: 735
Joined: Mon Jan 07, 2013 9:11 am

Re: Video Play in Vertical

Tue May 13, 2014 7:35 am

"How to play a video in full screen i.e it fits to display?"


$ omxplayer --orientation 90 your_video

surendar
Posts: 28
Joined: Mon Jan 13, 2014 3:39 am

Re: Video Play in Vertical

Tue May 13, 2014 9:21 am

tvjon wrote:"How to play a video in full screen i.e it fits to display?"


$ omxplayer --orientation 90 your_video
It shows /usr/bin/omxplayer.bin: unrecognized option '--orientation'

User avatar
RaTTuS
Posts: 10531
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Video Play in Vertical

Tue May 13, 2014 9:29 am

omxplayer -v
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

galsasson
Posts: 1
Joined: Thu Oct 19, 2017 12:59 pm

Re: Video Play in Vertical

Thu Oct 19, 2017 1:09 pm

It's an old thread, but I encountered the same problem and I'm just putting here the solution I found in case someone else gets here.

I have a 1080x1920 screen and I use 'display_rotate=1' in /boot/config.txt to put it in landscape mode. omxplayer doesn't like it and don't render the video on the entire screen.
Further, using --orientation=90 just makes it worse.

Use this:

Code: Select all

--win="xstart ystart xend yend"
For example:

Code: Select all

 --win="0 0 1920 1080" to render full-screen.
This will define the render window coordinates of omxplayer.

Return to “General discussion”