lunix
Posts: 4
Joined: Mon May 06, 2013 10:47 pm

Screen blanks intermittently

Mon May 06, 2013 11:15 pm

First- I'm a PC (Windows) guy (family breadwinner, not a fanboy), embedded systems hardware and firmware developer, software developer- running Linux server (non-expert) for about 15 years.

I have a friend who I setup with a Pi-b rev. 3 (with Berryboot, OpenElec, Wheezy). In each of those three GUI's the screen intermittently goes blank. He has a Westinghouse TV (VK42F240S) TV. It's supposed to be (according to the User Manual) 1080p, 60Hz (other profiles are supported). However, left to itself, the Pi blanks the screen approx. every second for about a second each time. (This happens when Berryboot, Wheezy, or OpenElec are running). The Video Status shows that we're running at 1080p, 60Hz in OpenElec. BUT- when I start a video via add-in, or file playback- it is FINE.

I have tried modding the config.txt file in BerryBoot. I have tried the video settings in OpenElec (everything available). But the problem persists.

When I change BerryBoot's config.txt, to, for example, ignore EDID (hdmi_ignore_edid=0xa5000080
), and try to set the display to say 1080p, 50Hz (my video experience says that this is a refresh rate problem)- with the caveat that I am often wrong before I am right with a recent problem- the screen goes into a "vertical letterbox" mode with borders on the right and left, but video top-to-bottom.

So the documented video modes (hdmi_group, hdmi_mode) seem to have unexpected effects. Setting to "Cheap Chinese monitor (ignore)" and some supposedly supported mode, results (usually)
in usually a narrow screen, and sometimes a completely blank screen.

What now?

breaker
Posts: 28
Joined: Mon May 06, 2013 6:42 am

Re: Screen blanks intermittently

Tue May 07, 2013 6:31 am

You try these?:

Code: Select all

config_hdmi_boost=4
hdmi_force_hotplug=1
http://elinux.org/R-Pi_Troubleshooting# ... put_at_all

I know it says "No HDMI output at all" but worth a try perhaps.

lunix
Posts: 4
Joined: Mon May 06, 2013 10:47 pm

Re: Screen blanks intermittently

Tue May 07, 2013 7:15 am

breaker wrote:You try these?:

Code: Select all

config_hdmi_boost=4
hdmi_force_hotplug=1
http://elinux.org/R-Pi_Troubleshooting# ... put_at_all

I know it says "No HDMI output at all" but worth a try perhaps.

Yes, I did- but thanks for your reply. I read the thread you linked. Yeah it's a different story. I neglected to mention one very significant thing in my original post- video either from a file, or streaming from any decent source plays just fine and the screen behaves well. Also, this board (and SD card) behaves fine with my HDMI monitor and also my HDMI TV.

lunix
Posts: 4
Joined: Mon May 06, 2013 10:47 pm

Re: Screen blanks intermittently

Tue May 07, 2013 7:19 am

One other thing- his TV has four HDMI ports. Each works fine with his DVD player, but each shows video intermittently when any of the Pi GUI's is displayed. But they all display streaming video or files (as mentioned above) just fine.

User avatar
cresfang
Posts: 37
Joined: Fri Apr 29, 2016 3:03 am
Location: Garden of Time
Contact: Website

Re: Screen blanks intermittently

Wed Sep 07, 2016 3:02 am

This is what I'm talking about in my thread.
Some UI elements make the HDMI goes crazy....

@all who got problem: could you open this site http://dev.deluge-torrent.org/wiki/Download without HDMI goes crazy?

And the blanking also happens while playing local video using Kodi & omxplayer (720p MP4 H264 video).

There's no rainbow square on the screen indicating problem, the power light also steady.
The power adapter used is 5V 3A.
Raspbian Jessie latest with latest rpi-update kernel.
Raspberry Pi 3

Return to “General discussion”