beylow
Posts: 7
Joined: Mon Feb 04, 2013 12:39 pm
Location: Finland

Problem with RC servo connect to pi

Sat Mar 16, 2013 7:40 am

Hi there,

I've got some problem with RC servo.
I'm using a servo which I bought from Sparkfun. https://www.sparkfun.com/products/9064
Since it requires 5V voltage and lots of currents, I have to use a external power for servo.
I've followed the instruction on http://learn.adafruit.com/adafruits-ras ... r/overview.
I used a 5V phone charger instead of battery.
When I connect the signal cord to raspberry pi, servo kept running until it reached the maximum angle, even before I issued the python code to control servo. Now, I cannot figure out why it is like this.
Does anyone have an idea?

Thanks a lot.

BTW. I've tried this under both the latest Wheezy and Occidentalis firmware, same result.

beylow
Posts: 7
Joined: Mon Feb 04, 2013 12:39 pm
Location: Finland

Re: Problem with RC servo connect to pi

Fri Mar 29, 2013 9:01 am

Up. Up.

User avatar
joan
Posts: 14590
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Problem with RC servo connect to pi

Fri Mar 29, 2013 9:31 am

Possibly noise from the floating control signal. Does it operate properly once your program starts?

beylow
Posts: 7
Joined: Mon Feb 04, 2013 12:39 pm
Location: Finland

Re: Problem with RC servo connect to pi

Fri Mar 29, 2013 9:21 pm

joan wrote:Possibly noise from the floating control signal. Does it operate properly once your program starts?
It doesn't.
I have even tried it with another pi, same problem.

User avatar
alexeames
Forum Moderator
Forum Moderator
Posts: 2869
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
Contact: Website

Re: Problem with RC servo connect to pi

Fri Mar 29, 2013 9:44 pm

Have you connected the GND on your power supply to Pi GND?

Which pin are you attaching it to?

Have you seen the photos and layout of how I did it?
Do they match with yours?
http://raspi.tv/2013/how-to-make-your-o ... aving-demo

Image
Alex Eames RasPi.TV, RasP.iO

beylow
Posts: 7
Joined: Mon Feb 04, 2013 12:39 pm
Location: Finland

Re: Problem with RC servo connect to pi

Sat Mar 30, 2013 10:44 am

alexeames wrote:Have you connected the GND on your power supply to Pi GND?

Which pin are you attaching it to?

Have you seen the photos and layout of how I did it?
Do they match with yours?
http://raspi.tv/2013/how-to-make-your-o ... aving-demo

Image
Hey alexeames.
It actually works with your configuration!

Thanks a lot!

I was trying to use the servo to open my door. But sadly, the servo torque isn't powerful enough. I have to consider buying another servo.

User avatar
alexeames
Forum Moderator
Forum Moderator
Posts: 2869
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
Contact: Website

Re: Problem with RC servo connect to pi

Sat Mar 30, 2013 11:41 am

Way to go. Excellent. Yes you'd need a pretty large and powerful servo to handle a door.
Alex Eames RasPi.TV, RasP.iO

Return to “General discussion”