crns
Posts: 5
Joined: Fri Feb 22, 2013 2:47 pm

pistore open app problem

Sun Feb 24, 2013 8:19 pm

Hi

I have problems opening an app form the pistore (storm in a teacup) while other apps open fine(iridium and libre office) Whenever i press launch a window will emerge briefly stating "App Running To start another app or edit your settings, please choose Storm in a teacup first." and the program does not launch.

I tried to delete and reinstall, but it does not help, I tried to find where the program actually is to look for permission settings, but that is a little confusing to see where it resides. I did notice that when it install it posted that it needed root password to install in the terminal but it did not prompt for it and continued installation.

I have run apt-get update prior to all this.

Has anyone any ideas?

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: pistore open app problem

Sun Feb 24, 2013 9:15 pm

Hi there,

I believe there are currently some issues with IceLib (or the server behind it), which is a game component offered by IndieCity and used by Storm in a Teacup (amongst other games). I'd imagine that your problem is likely related to this - I'm afraid there's nothing you'll be able to do to fix it.

I've asked a colleague for some more information; I'll post back once I know myself.

Apologies for the inconvenience,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

crns
Posts: 5
Joined: Fri Feb 22, 2013 2:47 pm

Re: pistore open app problem

Mon Feb 25, 2013 9:05 am

Hi

ok, thanks, I will wait and see then

br

User avatar
DrPiD
Posts: 30
Joined: Wed May 16, 2012 9:44 am
Location: Leamington Spa, UK
Contact: Website

Re: pistore open app problem

Mon Feb 25, 2013 4:02 pm

Sorry about this, a bug in our library :(

If you're happy running terminal commands then you can open up LXTerminal and run the following command

Code: Select all

sudo apt-get update && sudo apt-get install icelib
That'll update to the latest version of ICELib and correct the error on our side, we'll also release an update via the client in a couple of days for those that don't like terminal tinkering.

Apologies for the inconvenience.
Community Manager - IndieCity

crns
Posts: 5
Joined: Fri Feb 22, 2013 2:47 pm

Re: pistore open app problem

Mon Feb 25, 2013 5:25 pm

Hi again

Thanks, I tried to install the icelib and it does get me a tiny bit further. But now the "App running" screen comes on and stays on, nothing else happens after that, so the PiStore have to be closed to get rid of it. The game does not launch. and CPU goes to 0%

I tried another re-install just in case, then a launch still hangs at the same screen but with an added noice in the speakers. and CPU stays a 50%, and keyboard becomes dead, mouse still works. A hard reboot is nessesary.

Any new ideas?

br

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: pistore open app problem

Tue Feb 26, 2013 11:44 am

I'm sorry to hear the game's not working for you, crns.

If you navigate to /usr/local/bin/indiecity/InstalledApps/storm/Full and run ./storm in a terminal, does the game launch correctly for you then?

~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

crns
Posts: 5
Joined: Fri Feb 22, 2013 2:47 pm

Re: pistore open app problem

Tue Feb 26, 2013 4:13 pm

Hi

When trying to start it from the terminal I get

icelib: 1 users:
IndieGamer46310
icelib: default user is IndieGamer46310
icelib: created session object
icelib: session started
icelib: session and license ok
Found keyboard handler at H: Handlers=sysrq kbd event0

After that nothing else happens.

So maybee it's the keyboard thats the issue I use a Danish keyboard.

br

hansamann
Posts: 7
Joined: Fri Mar 22, 2013 7:40 pm

Re: pistore open app problem

Fri Mar 22, 2013 7:46 pm

I got my Raspberry Pi today and immediately bought Storm in a Teacup, but unfortunately it does not work. I upgraded the icelib (actually the Pi store did that I think, running apt on command line said it is up to date) and started on the commadn line. It hangs after that keyboard found message.

Any idea? What exact keyboard could I try. I have a Logitech K260 with German Layout.

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Tue Mar 26, 2013 6:31 am

crns wrote:Hi

When trying to start it from the terminal I get

icelib: 1 users:
IndieGamer46310
icelib: default user is IndieGamer46310
icelib: created session object
icelib: session started
icelib: session and license ok
Found keyboard handler at H: Handlers=sysrq kbd event0

After that nothing else happens.

So maybee it's the keyboard thats the issue I use a Danish keyboard.

br
I have the same problem as you. If I try to start the game from my terminal, I get this:

icelib: no default user

icelib: iceClientBridgeCreateDefaultGameSession() failed

icelib: session and/or license bad


My Raspbian is up to date and the game, the Pi Store and icelib library were reinstalled.

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: pistore open app problem

Tue Mar 26, 2013 3:29 pm

Hi - we're looking into the problems with Storm in a Teacup at the moment.

Could anyone who's having issues please run:

sudo apt-cache policy pistore
sudo apt-cache policy icelib

And post the output please?

Thanks very much,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Tue Mar 26, 2013 4:01 pm

Pankoi wrote:Hi - we're looking into the problems with Storm in a Teacup at the moment.

Could anyone who's having issues please run:

sudo apt-cache policy pistore
sudo apt-cache policy icelib

And post the output please?

Thanks very much,
~Richard Williams
Hi,

Please find below my output:

pistore:
Installed: 1.1.16693
Candidate: 1.1.16693
Version table:
*** 1.1.16693 0
500 http://archive.raspberrypi.org/debian/ wheezy/main armhf Packages
100 /var/lib/dpkg/status


icelib:
Installed: 1.0.15636
Candidate: 1.0.15636
Version table:
*** 1.0.15636 0
500 http://archive.raspberrypi.org/debian/ wheezy/main armhf Packages
100 /var/lib/dpkg/status

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: pistore open app problem

Tue Mar 26, 2013 4:09 pm

Thanks! :)

Could I ask your IndieCity username too, please? It'll appear in the top-right of the Pi Store when you're logged in.

Thanks again,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Tue Mar 26, 2013 4:24 pm

My IndieCity username is "Liber" ;)

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Mon Apr 08, 2013 3:17 pm

My latest finding: If I use Raspbian image "2012-12-16" (http://raspberrypi.ergatides.com/raspbi ... spbian.zip), I can run the game. If I update Raspbian, I cannot run the game.... There must be an error in current Raspbian, right? :oops:

Pankoi
Posts: 205
Joined: Tue Dec 18, 2012 6:59 pm

Re: pistore open app problem

Tue Apr 09, 2013 10:45 am

Hi Liber,

Well that's good news, but I'm afraid that with our testing here, one of my colleagues still can't get the game working properly on that image. Would you mind running 'sudo apt-cache policy icelib' for me and posting the output, please?

Thanks very much,
~Richard Williams
The Pi Store: the home of games, apps, tutorials and other content for Raspberry Pi - store.raspberrypi.com
Want to hear about new Pi Store content? Follow @PiStoreReleases on Twitter.

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Tue Apr 09, 2013 3:10 pm

It was quite difficult to persuade my daughter to stop playing the game and let me collect all information for you :D All information can be seen on the attached screenshot.
Attachments
screenshot.png
screenshot.png (47.47 KiB) Viewed 5174 times

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Sat May 04, 2013 6:41 am

If I use Raspbian image 2012-12-16 and extremely cheap 2Gb Tesco SD card, the game works. Is there any solution....?
Attachments
screenshot.jpg
screenshot.jpg (61.53 KiB) Viewed 5005 times

martintay
Posts: 1
Joined: Sun Sep 15, 2013 8:49 am

Re: pistore open app problem

Sun Sep 15, 2013 8:54 am

Hi,

I am also facing the same problems:
When starting the game through Pi Store (only music playing in the background)
Tried executing from command line (but failed).

Is there going to be support for the newer versions of Raspbian?
If not, will there be a refund for those who can't get it to work and are getting no support.
Maybe if there is not going to be support, this game should not be on sale?

Cheers,
Martin

captainsemtex
Posts: 4
Joined: Sun Jun 02, 2013 6:28 am
Location: Canada
Contact: Website

Re: pistore open app problem

Sun Oct 27, 2013 7:38 am

Is there any more news about getting "Storm In a Teacup" working? It has been essentially "dead" since February.

I'm running Raspbian from the latest NOOBS v1.3. Icelib is up-to-date.

When I try and run Storm from the command line I get...

icelib: 1 users:
captainsemtex
icelib: default user is captainsemtex
icelib: created session object
icelib: session started
icelib: session and license ok
Found keyboard handler at H: Handlers=sysrq kbd event0

initOpenGL() ok
System and Game init ok
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
etc

I am using HDMI sound.

Regards

User avatar
Liber
Posts: 51
Joined: Sat Dec 01, 2012 12:31 pm
Location: Czech Republic
Contact: ICQ

Re: pistore open app problem

Sun Oct 27, 2013 6:39 pm

Hi,

if I meet following conditions, the game works:

1, Use Raspbian image from 16th december 2012
2, MUST NOT resize image after instalation !!!
3, DO NOT UPDATE Raspbian. Only the Pi Store can be updated.

As you guess, I have extra SD card for the game :D

Regards

Rostislav LIBER

Return to “General discussion”