AshKing2703
Posts: 2
Joined: Sun Sep 08, 2019 3:07 pm

unable to update or download any dependencies on Raspberry pi 4 2gb

Sun Sep 08, 2019 3:21 pm

I am running the following os:

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian




this is the error that i am receiving from many days now when i do sudo apt-get update

Get:1 http://archive.raspberrypi.org/debian buster InRelease [25.2 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Reading package lists... Done
E: Release file for http://archive.raspberrypi.org/debian/d ... /InRelease is not valid yet (invalid for another 58d 5h 16min 49s). Updates for this repository will not be applied.
E: Release file for http://raspbian.raspberrypi.org/raspbia ... /InRelease is not valid yet (invalid for another 60d 7h 55min 55s). Updates for this repository will not be applied.

pip installs and other installers are also not functioning

DirkS
Posts: 9941
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: unable to update or download any dependencies on Raspberry pi 4 2gb

Sun Sep 08, 2019 5:48 pm

E: Release file for http://archive.raspberrypi.org/debian/d ... /InRelease is not valid yet (invalid for another 58d 5h 16min 49s). Updates for this repository will not be applied.
Check date/ time of your Pi...

AshKing2703
Posts: 2
Joined: Sun Sep 08, 2019 3:07 pm

Re: unable to update or download any dependencies on Raspberry pi 4 2gb

Sun Sep 08, 2019 8:01 pm

Check date/ time of your Pi...
Thanks man, it worked turns out my internet connection was poor

Return to “General discussion”