I dont what to use
Posts: 1
Joined: Mon Jul 08, 2019 4:09 am

Recommended Software error

Mon Jul 08, 2019 4:17 am

The recommended software has an error
"Error updating package data - E: Repository 'https://raspbain.raspberrypi.org/raspbain buster inRease' changed its 'Suite' value from 'testing' to 'stable' "
What does this mean and why can't I access the recommended software, I using raspbain on my pi.

User avatar
topguy
Posts: 5626
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: Recommended Software error

Mon Jul 08, 2019 10:49 am

I think we would like to see exactly what command you wrote and the error, its great if you can find a way to cut&paste so we avoid "raspbian" / "raspbain" errors.
I using raspbain raspbian on my pi.
Yes but which version ? did you upgrade to Buster from Stretch or just installed a fresh image ?

But it probably means that Debian just released Buster: https://www.debian.org/News/2019/20190706 Yeah!!
I think it might be good enough to replace "testing" with "stable" in the apt-source files, but it also might be safest to wait a little bit to see if there is some official guide how to deal with this.

klricks
Posts: 6503
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Recommended Software error

Mon Jul 08, 2019 12:40 pm

I dont what to use wrote:
Mon Jul 08, 2019 4:17 am
The recommended software has an error
"Error updating package data - E: Repository 'https://raspbain.raspberrypi.org/raspbain buster inRease' changed its 'Suite' value from 'testing' to 'stable' "
What does this mean and why can't I access the recommended software, I using raspbain on my pi.
Run sudo apt update from the command line then answer Y to the prompt.
When that completes then go back to Recommended Software and try again.

Code: Select all

pi@raspberrypi:/dev $ sudo apt update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease                   
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]      
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'testing' to 'stable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

User avatar
rpdom
Posts: 14759
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Recommended Software error

Mon Jul 08, 2019 1:11 pm

Or do

Code: Select all

apt-get update --allow-releaseinfo-change
which will clear the warning and allow the update to continue.

Return to “General discussion”