Page 1 of 2

Wifi 5GHz not working

Posted: Sun Dec 16, 2018 9:09 am
by pcdimoticanerd33
hello everyone i have problem i can not connect 5GHz wifi to raspberry pi knows someone how this is coming

Re: Wifi 5G

Posted: Sun Dec 16, 2018 10:06 am
by jamesh
Make sure you have set the correct country code using raspi configuration.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 10:26 am
by pcdimoticanerd33
that's okay on BE wants to work only on 2.4GHz and not on 5GHz or sometimes have to adjust something

Re: Wifi 5G

Posted: Sun Dec 16, 2018 11:46 am
by jamesh
It's almost always due to having a badly or unset country code....that is definitely set?

Re: Wifi 5G

Posted: Sun Dec 16, 2018 12:30 pm
by pcdimoticanerd33
This is my /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface = DIR = / var / run / wpa_supplicant GROUP = netdev
update_config = 1
country = BE

network = {
         ssid = "ASUS_5G_Guest2"
         psk = "password"
         pid_str = "Guest"
}

Re: Wifi 5G

Posted: Sun Dec 16, 2018 1:22 pm
by DarkPlatinum
Are you using raspbian lite? if not, you can usually see which wifi signals are 5G from the internet menu on the desktop.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 2:10 pm
by bensimmo
pcdimoticanerd33 wrote:
Sun Dec 16, 2018 12:30 pm
This is my /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface = DIR = / var / run / wpa_supplicant GROUP = netdev
update_config = 1
country = BE

network = {
         ssid = "ASUS_5G_Guest2"
         psk = "password"
         pid_str = "Guest"
}

try

Code: Select all

ctrl_interface=/var/run/wpa_supplicant  GROUP = netdev
update_config=1
country=BE

network={
	ssid="ASUS_5G_Guest2"
	psk="password"
	key_mgmt=WPA-PSK
}
if you do need to use pid_str, it should be id_str with no 'p'. It's also not needed for normal use.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 3:01 pm
by n67
There are (at least) two possible interpretations of what OP means by "Wifi 5G".

I assumed he meant the upcoming new standard (we have 3G, and 4G. 5G is just around the corner!)

Everyone else seems to have assumed he meant 5Ghz.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 3:24 pm
by rpdom
n67 wrote:
Sun Dec 16, 2018 3:01 pm
There are (at least) two possible interpretations of what OP means by "Wifi 5G".

I assumed he meant the upcoming new standard (we have 3G, and 4G. 5G is just around the corner!)

Everyone else seems to have assumed he meant 5Ghz.
It seems pretty obvious to me. The clue is "WiFi". The other "5G" is mobile internet, not WiFi.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 3:38 pm
by drgeoff
rpdom wrote:
Sun Dec 16, 2018 3:24 pm
n67 wrote:
Sun Dec 16, 2018 3:01 pm
There are (at least) two possible interpretations of what OP means by "Wifi 5G".

I assumed he meant the upcoming new standard (we have 3G, and 4G. 5G is just around the corner!)

Everyone else seems to have assumed he meant 5Ghz.
It seems pretty obvious to me. The clue is "WiFi". The other "5G" is mobile internet, not WiFi.
+1

Also mentions of country code BE and the OP writing "only on 2.4GHz and not on 5GHz" in one of his posts.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 3:59 pm
by n67
hello everyone i have problem i can not connect 5G wifi to raspberry pi knows someone how this is coming
I don't see any references to 2.4Ghz or 5Ghz in the above text. Maybe I need glasses...

Re: Wifi 5G

Posted: Sun Dec 16, 2018 4:22 pm
by bensimmo
n67 wrote:
Sun Dec 16, 2018 3:59 pm
hello everyone i have problem i can not connect 5G wifi to raspberry pi knows someone how this is coming
I don't see any references to 2.4Ghz or 5Ghz in the above text. Maybe I need glasses...
his second post gives a clue. viewtopic.php?f=63&t=229082&p=1404829#p1404746
But WiFi, as mentioned, is the big giveaway. 5G mobile is pretty rare and I've not seen many 5G pitches.

none of this is helping him though.

Re: Wifi 5G

Posted: Sun Dec 16, 2018 4:53 pm
by drgeoff
n67 wrote:
Sun Dec 16, 2018 3:59 pm
hello everyone i have problem i can not connect 5G wifi to raspberry pi knows someone how this is coming
I don't see any references to 2.4Ghz or 5Ghz in the above text. Maybe I need glasses...
@n67
See the third post in this thread. Which was almost 5 hours before your suggestion of mobile.

Re: Wifi 5GHz

Posted: Mon Dec 17, 2018 7:34 am
by pcdimoticanerd33
Sorry maybe a bit confusing it is 5GHz not 5g for mobile

my /etc/wpa_supplicant/wpa_supplicant.conf is now

Code: Select all

ctrl_interface = / var / run / wpa_supplicant GROUP = netdev
update_config = 1
country = BE

network = {
         ssid = "ASUS_5G_Gues1"
         psk = "password"
         key_mgmt = WPA2-PSK
}
[moderator added code tags]

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 7:54 am
by bensimmo
When you are posting, you'll see a row of tools above the box, one of them says Code, this lets you post you text as you type it (it's what I used above)
It should save you having to edit and add all the spaces etc.


I've also thought of a question.
Which Pi model is it?
Only the 3B+ and 3A+ models have the 5GHz band.

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 7:59 am
by pcdimoticanerd33
Mijn model is 3B+

how can you give static ip address to wlan0 and eth0

Yours sincerely

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 12:58 pm
by Will5455
but my rpi3 model b connected to my 5ghz band no questions asked? :?

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 2:22 pm
by pcdimoticanerd33
what have you done in interfaces and wpa_supplicant.conf

Re: Wifi 5GHz

Posted: Mon Dec 17, 2018 5:35 pm
by HawaiianPi
Will5455 wrote:
Mon Dec 17, 2018 12:58 pm
but my rpi3 model b connected to my 5ghz band no questions asked? :?
Not possible. The 3B does not support 5GHz.
pcdimoticanerd33 wrote:
Mon Dec 17, 2018 7:34 am
Sorry maybe a bit confusing it is 5GHz not 5g for mobile

my /etc/wpa_supplicant/wpa_supplicant.conf is now

ctrl_interface = / var / run / wpa_supplicant GROUP = netdev
update_config = 1
country = BE

network = {
         ssid = "ASUS_5G_Gues1"
         psk = "password"
         key_mgmt = WPA2-PSK
}
You have a lot of extra spaces in there. The wpa_supplicaqnt.conf file should look like this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
	key_mgmt=WPA-PSK
}

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 6:00 pm
by pcdimoticanerd33
it is the model 3 Model B +

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 7:21 pm
by DarkPlatinum
pcdimoticanerd33 wrote:
Mon Dec 17, 2018 6:00 pm
it is the model 3 Model B +
You should have stated this. I think most of us assumed that you used a 5GHz wifi dongle. Have you tried what I told you to do? Going on Raspbian Desktop and using the wifi settings to connect to 5GHz wifi?

We can't help you if you don't want to listen.

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 7:47 pm
by bensimmo
DarkPlatinum wrote:
Mon Dec 17, 2018 7:21 pm
pcdimoticanerd33 wrote:
Mon Dec 17, 2018 6:00 pm
it is the model 3 Model B +
You should have stated this. I think most of us assumed that you used a 5GHz wifi dongle. Have you tried what I told you to do? Going on Raspbian Desktop and using the wifi settings to connect to 5GHz wifi?

We can't help you if you don't want to listen.
He said it was a 3B+ when I asked, (none was mentioned in the opening post that I remember)
It was another chap that said his 3B connected at 5GHz band.

Though it's quite easy to ignore the + when posting, especially if you are new to this.
_______

Anyway,
--- does 2.4GHz work ?
--- Does anything else connect to your router/access point, what is it ?

Can you try a fresh new Raspbian Desktop image juat to see if something was messed up.

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 7:52 pm
by pcdimoticanerd33
yes 2.4GHz works

at 5GHz all my laptops are connected and that works
where I can find the log files maybe the error

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 8:09 pm
by bensimmo
Check you last attempts SSID, you spelt Guest1 wrong in the copy you pasted on here.

So double check spellings etc.


From the man pages on the web for wpasupplicant
The easiest way to debug problems, and to get debug log for bug reports, is to start wpa_supplicant on foreground with debugging enabled:

wpa_supplicant -c/etc/wpa_supplicant.conf -iwlan0 -d
So alter as needed.

Re: Wifi 5GHz not working

Posted: Mon Dec 17, 2018 9:07 pm
by HawaiianPi
pcdimoticanerd33 wrote:
Mon Dec 17, 2018 6:00 pm
it is the model 3 Model B +
That part of my reply was to Will5455 who claimed his 3B connected to 5GHz. You had already confirmed you had a 3B+ model.
  1. Can you see your 5GHz network when searching for networks in range?
  2. Do you have your SSID hidden?
  3. Do you have MAC address filtering or DHCP limits set in your router which could be preventing your Pi connecting?
You can have multiple networks in wpa_supplicant.conf as follows:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="Your 2.4GHz WiFi SSID"
        psk="Your 2.4GHz network passphrase"
        key_mgmt=WPA-PSK
}

network={
        ssid="Your 5GHz WiFi SSID"
        psk="Your 5GHz network passphrase"
        key_mgmt=WPA-PSK
}
Basically, two (or more) complete network sections. You can even specify priorities.