r9guy
Posts: 1
Joined: Mon Feb 18, 2019 1:40 pm

Re: Wifi 5GHz not working

Mon Feb 18, 2019 1:44 pm

this is really strange. probably the wify driver to support B+ s 5GHZ is not working well.
I have installed latest raspbian lite, installed all updates while connected 2.4ghz. then I switched off 2.4 and left only 5ghz.
it dosn't work

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12233
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Wifi 5GHz not working

Mon Feb 18, 2019 4:09 pm

r9guy wrote:
Mon Feb 18, 2019 1:44 pm
this is really strange. probably the wify driver to support B+ s 5GHZ is not working well.
I have installed latest raspbian lite, installed all updates while connected 2.4ghz. then I switched off 2.4 and left only 5ghz.
it dosn't work
Sorry but I assume you must have a 3B+, NOT a B+.
If you disable, 2.4GHz, then you can only connect with 5GHz, and there are newer rules and regulations when using 5GHz, one is that you MUST state where you live, as 5GHz modes are not everywhere the same.
You do that by adding text to the wpa_supplicant.conf file.
The text you need to add tells the system where you live.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="Your 5GHz WiFi SSID"
        psk="Your 5GHz network passphrase"
        key_mgmt=WPA-PSK
}
"country=US" must be replaced with the correct country code of your location, and the ssid, and psk and key_mgmt texts must be replaced with your correct ssid identificators, passprases, and encryption system that is used.

for details see: https://www.raspberrypi.org/documentati ... ess-cli.md

User avatar
joan
Posts: 14266
Joined: Thu Jul 05, 2012 5:09 pm
Location: UK

Re: Wifi 5GHz not working

Mon Feb 18, 2019 6:01 pm

My wifi router won't connect to some devices on 5GHz unless the router is set to use 40MHz band separation. Might be worth checking to see if there is any such configuration setting for your wifi.

Return to “General discussion”