Willzz748
Posts: 1
Joined: Fri Nov 02, 2018 4:15 pm

Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 4:18 pm

I have turned my pi on for the first time in months and on ok lite am getting somthing saying pi@raspberrypi: ~$. Anyone know what I need to enter to launch? or what I need to do?

User avatar
DarkPlatinum
Posts: 849
Joined: Thu Nov 02, 2017 2:30 pm
Location: Unknown
Contact: Website YouTube

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 4:27 pm

If you want a desktop and i presume you are using raspbian stretch with desktop, you type startx .
1 * Raspberry Pi Zero W, 1 * Raspberry Pi 2, 1 * Raspberry Pi 3 1 * Raspberry Pi 3B + :mrgreen:

Check Out My Raspberry Site (Run on a Raspberry Pi 3B :) ): https://html.dynu.net

W. H. Heydt
Posts: 10995
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 4:57 pm

Willzz748 wrote:
Fri Nov 02, 2018 4:18 pm
I have turned my pi on for the first time in months and on ok lite am getting somthing saying pi@raspberrypi: ~$. Anyone know what I need to enter to launch? or what I need to do?
Welcome to the forums.

That's a perfectly normal shell prompt. It shows that you are user pi on host raspberrypi, you're in your home directory, and that you're an ordinary (i.e. not root) user.

If you want the system to come up with the GUI desktop on a normal boot, then run "sudo raspi-config". Pick option 3 "Boot options", then pick B1 "Desktop / CLI". Within that, select either B3 or B4, depending one whether or not you want to have to log in each time.

Alternatively, as above, enter the command "startx" and if you want to have the desktop come up automatically, got to the pull down menu, select "Preference" and the "Raspberry Pi Configure". The options for how to boot are on the panel that comes up in the "System" tab. And--FYI--you can change your hostname there, too, which is a good thing to do, especially if you have (or expect to have) more than one Pi on the same LAN.

User avatar
B.Goode
Posts: 8856
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 5:03 pm

on ok lite am getting somthing saying pi@raspberrypi: ~$.

If that means you are running the 'Lite' variant of the Raspbian Operating System then what you see is what you should expect to get.

As others have pointed out, it is the shell (command line) prompt for the Operating System. It is the point from which you control your system.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12337
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 5:31 pm

And raspbian lite does not have a desktop, its normally command line driven only.

Or in other words, you have installed the wrong (version of the) software.

choose the left option on this page, https://www.raspberrypi.org/downloads/raspbian/ and burn it to your sd-card with etcher.

What I don't understand though that you said "I have turned my pi on for the first time in months ", meaning you have booted it before, and so you should have noticed it didn't boot to a desktop, or as we say in linux land, it "booted to the wrong run-level" .

drgeoff
Posts: 9886
Joined: Wed Jan 25, 2012 6:39 pm

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 6:34 pm

Maybe the "on ok lite" in that garbled sentence is meant to be saying that the "on light" (ie the red LED) is "on OK". Ie the OP did previously have the full desktop version of Raspbian working.

code_exec
Posts: 273
Joined: Sun Sep 30, 2018 12:25 pm

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 6:37 pm

Willzz748 wrote:
Fri Nov 02, 2018 4:18 pm
I have turned my pi on for the first time in months and on ok lite am getting somthing saying pi@raspberrypi: ~$. Anyone know what I need to enter to launch? or what I need to do?
You can install a desktop environment such as XFCE or LXDE and install LightDM for a display manager.

For XFCE, run:

Code: Select all

sudo apt-get install xfce4
For LXDE, run:

Code: Select all

sudo apt install lxde
Finally, you will need to install a display manager. Install LightDM with the following command:

Code: Select all

sudo apt install lightdm lightdm-gtk-greeter
Then reboot your Pi and you should boot into a login screen. Log in with your user credentials and you should see a desktop environment.

TIP: If you want to customise your Raspbian Lite installation, add "--no-install-recommends" to the end of the command you install your desktop environment with so that no "recommended" software is installed. For example, to install XFCE without any of the software that normally comes with XFCE, run:

Code: Select all

sudo apt install xfce4 --no-install-recommends
Hope this helps :D
Ubuntu 18.04 LTS desktop images for the Raspberry Pi 3.

https://github.com/CodeExecution/Ubuntu-ARM64-RPi

LTolledo
Posts: 2010
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Help, all I'm getting is a line with somthing saying pi@raspberrypi: ~$

Fri Nov 02, 2018 11:09 pm

if you have nothing really important in the current micrSD card, how about re-flashing it(using Etcher or any other method you prefer) with the latest Raspbian Stretch with Desktop?

having a mouse connected will be handy....
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “General discussion”