BenScorer
Posts: 3
Joined: Wed Nov 07, 2012 11:27 am

Disabling the Blank screen

Wed Nov 07, 2012 11:51 am

Hi There, I'm having a slight problem in disabling the blank screen, as the Pi is set up as a monitoring system, and I need the screen to stay on over a period of 6-8 hours.
os = Rasputin

I don't know anything about Linux, i'm more of a windows/mac so if I look/seem stupid...probably cause I am, in this area : :lol:

Maine_guy
Posts: 14
Joined: Thu Sep 13, 2012 12:44 am

Re: Disabling the Blank screen

Wed Nov 07, 2012 11:53 pm

You can stop screen blanking by entering the three commands. You may have to apt-get install x11-xserver-utils to get xset

xset s off # don't activate screensaver
xset -dpms # disable DPMS (Energy Star) features.
xset s noblank # don't blank the video device

in a terminal started in the X-Windows session

To have these settings invoked on boot, edit /etc/xdg/lxsession/LXDE/autostart and add these three lines.

@xset s off
@xset -dpms
@xset s noblank

Verify it's working with

xset -q

BenScorer
Posts: 3
Joined: Wed Nov 07, 2012 11:27 am

Re: Disabling the Blank screen

Thu Nov 08, 2012 9:19 am

so where do I enter the:
xset s off # don't activate screensaver
xset -dpms # disable DPMS (Energy Star) features.
xset s noblank # don't blank the video device

?
because ive browsed the internet and it mentions something about .xintrc file ?
and I don't know where or even how to get into this file to edit it :?

User avatar
RaTTuS
Posts: 10415
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Disabling the Blank screen

Thu Nov 08, 2012 9:31 am

http://www.raspberrypi.org/phpBB3/viewt ... 23#p210922
^ that if you are wanting the console display to stop blanking
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Return to “General discussion”