diresu
Posts: 2
Joined: Sun Sep 16, 2018 9:10 pm

Chinese input method? [solved]

Sun Sep 16, 2018 9:58 pm

Hi,

I would like to be able to write in Chinese on my Raspberry Pi.

Is there anybody who could explain me how to install a Chinese input method and make it work?

My own attempts failed all...

Thanks,

Dietrich

User avatar
allfox
Posts: 452
Joined: Sat Jun 22, 2013 1:36 pm
Location: Guang Dong, China

Re: Chinese input method?

Mon Sep 17, 2018 9:28 am

I use a headless setup, so not sure about the exact steps.

But essentially, you need a Chinese font, an input method framework(daemon), and an actual input method.

Raspbian is Debian mostly, so it might worth trying https://wiki.debian.org/gnome-chinese-input

EDIT: I just remember that Raspbian is not GNOME!
Well, I don't know how to make it work. Sorry.

diresu
Posts: 2
Joined: Sun Sep 16, 2018 9:10 pm

Re: Chinese input method?

Mon Oct 01, 2018 7:43 pm

Hi allfox!

> EDIT: I just remember that Raspbian is not GNOME!
> Well, I don't know how to make it work. Sorry.

Thank you anyway :)

I finally managed to make Chinese and Japanese Input work as follows - I hope this is helpful for others in need to write in Chinese or Japanese on the Raspberry Pi.

Cheers,
Dietrich

=== Chinese Input ===

1. Add Chinese locale (in my case 'zh_CN.UTF-8') via:

sudo dpkg-reconfigure locales

Select and install: zh_CN.UTF-8 UTF-8

2. Install Chinese fonts:

sudo apt-get install \
fonts-arphic-bkai00mp \
fonts-arphic-bsmi00lp \
fonts-arphic-gbsn00lp \
fonts-arphic-gkai00mp \
xfonts-intl-chinese \
xfonts-intl-chinese-big

3. Install fcitx and fcitx-libpinyin:

sudo apt-get install \
fcitx \
fcitx-libpinyin

4. Open the Input Method Configuration

Either from the command line:

sudo im-config

or via the main menu:

Raspberry Pi Menu > Preferences > Input Method

- First screen:
Current confituration for the input method...
click [OK]

- Second screen:
Do you explicetly select the user configuration?
click [YES]

- Third screen:
Select: (*) fcitx activate Flexible Input Method Framework (fcitx) @
click [OK]

5. Reboot

There should be a small keyboard icon on the right side of the panel.

- right click on the keyboard icon
and choose either 'Configure current input method' or 'Configure'
- click the '+' symbol on the lower left of the window popping up
- Uncheck 'Only Show Current Language' in the window popping up
- Enter the term 'pinyin' in the search field
- select the field 'Pinyin (LibPinyin)' and click [OK]
- close the window

Now it should be possible to select the input method
'Pinyin (LibPinyin)' from the keyboard icon in the panel:

- right click on the keyboard icon
- hover over 'input method'
- and select 'Pinyin (LibPinyin)'

The input method now can be toggled between English and Chinese using
the key combination 'ctrl-space'...

=== Japanese Input ===

1. Add Japanese locale (in my case 'ja_JP.UTF-8') via:

sudo dpkg-reconfigure locales

Select and install: ja_JP.UTF-8 UTF-8

2. Install Japanese fonts:

sudo apt-get install \
xfonts-intl-japanese \
xfonts-intl-japanese-big \
fonts-takao

3. Install fcitx and mozc:

sudo apt-get install \
fcitx \
fcitx-mozc

4. Open the Input Method Configuration

Either from the command line:

sudo im-config

or via the main menu:

Raspberry Pi Menu > Preferences > Input Method

- First screen:
Current confituration for the input method...
click [OK]

- Second screen:
Do you explicetly select the user configuration?
click [YES]

- Third screen:
Select: (*) fcitx activate Flexible Input Method Framework (fcitx) @
click [OK]

5. Reboot

Now it should be possible to select the input method
'Mozc' from the keyboard icon in the panel:

- right click on the keyboard icon
- hover over 'Input Method'
- and select 'Mozc'

The input method now can be toggled between English and Japanese using
the key combination 'ctrl-space'...

======

Return to “General discussion”