Page 1 of 1

Need help with WiFi Networking

Posted: Fri Jun 29, 2018 1:01 pm
by rsauerbrun
Hello Group,

I am running an image on my RPi 3 Model B that was configured to use the WiFi as a wireless access point. It works great and broadcasts an SSID to which I can connect and enter the required password.

The developer of this image provided documentation on how to remove the access point and configure a WiFi client using DHCP. I have attempted to do this, but now get a message that there is no WiFi network detected.

Here are his instructions:

Disable Access Point and Enable Wifi Client
The RPi cannot serve as an access point and a wifi client on another network at the same time. Here are the steps to change the wifi to be a client only:
to disable hostapd, remove it using
sudo apt-get remove hostapd
then modify your /etc/network/interfaces file to set wlan0 to dhcp and reenable the outgoing wifi by:
sudo nano /etc/network/interfaces
enable (remove the #) from these lines:
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf​​​​​​

and disable (add a leading #) these lines:
#iface wlan0 inet static
#address 192.168.6.1
#netmask 255.255.255.0

Then save and exit by pressing [Ctrl-O], then [Enter], then [Ctrl-X], and then reboot your RPi.
at this point, you'll need to have access to your RPi desktop via monitor, keyboard, mouse or connect to Ethernet and use a VNC client.
There should now be a working wifi icon in the top bar. use it to set your password, etc.
reboot again with ethernet cable disconnected (if it was connected).
you should now be able to ping and connect to "RPi-JMRI.local" from devices on your wifi network.

I have triple checked the changes he suggested, and my /etc/network/interfaces file is now correct, however, after a reboot, I have no wireless interface!

Your help will be very much appreciated ... thank you in advance,

Richard

Re: Need help with WiFi Networking

Posted: Fri Jun 29, 2018 6:57 pm
by Ronaldlees
It looks like your image was set up to use wpa_supplicant. So, you can run wpa_supplicant in manual mode with the "-DD" (or is that -dd?) switch to enable debugging, and maybe see what's wrong. I'd guess your wpa_supplicant.conf is incorrect.