Page 1 of 1

Forum search internal filtering

Posted: Mon Oct 08, 2012 4:31 pm
by jfornango
I was just trying to look up some info on the P5 connections for someone who had a question about it's capabilities. To my dismay, when I enter 'P5' into the Search and hit 'Enter', I get a message back saying that teh word 'P5' is being ignored because it "... too common."

I know the forum software tries to be smart and not look for words like 'the', 'and' & 'you', but filtering out a word that is the name of a system component really makes it hard to find material.

Could someone please update the search filters? (pretty please, with Raspberries and sugar on top? :D )

Re: Forum search internal filtering

Posted: Mon Oct 08, 2012 4:44 pm
by Techmeology
The same thing happens if you search for GPIO. It is annoying, alas I suspect it's done to avoid queries that might nom all the server's CPU cycles. As a work around, you could google something like:

Code: Select all

P5 site:http://www.raspberrypi.org/phpBB3

Re: Forum search internal filtering

Posted: Mon Oct 08, 2012 5:02 pm
by abishur
It is an unfortunate reality that there will forever exist something that cannot be searched do to forum search conditions. On the old forum, the limit was 4 characters (which made it hard to search for VGA, USB, CPU, GPU, etc). 2 letters is a bit on the low side, but 3 letters is an absolute necessity on an electronics site!

I'm afraid the best option is to Techmeology suggestion and do a site search with Google.

Frankly I consider this to be the best solution over all as Google has poured millions into their search engine and it produces very good results ;-)