lupa18
Posts: 2
Joined: Fri Sep 22, 2017 3:50 am

Re: Raspbian Stretch Headless Setup Procedure

Fri Sep 22, 2017 3:57 am

I can confirm that the only way to make USB Wifi dongle works is applying these changes: https://raspberrypi.stackexchange.com/a/72003/55567

debian_version: 9.1

mattmiller
Posts: 2102
Joined: Thu Feb 05, 2015 11:25 pm

Re: Raspbian Stretch Headless Setup Procedure

Fri Sep 22, 2017 2:05 pm

I think this whole thread needs to be nuked from orbit now

rdragon78
Posts: 2
Joined: Thu Sep 07, 2017 6:31 am

Re: Raspbian Stretch Headless Setup Procedure

Fri Sep 22, 2017 2:55 pm

mattmiller wrote:
Fri Sep 22, 2017 2:05 pm
I think this whole thread needs to be nuked from orbit now

Agreed! +1 for this suggestion. The real answer is post 937 by HawaiianPi. I've now confirmed it on several Pi Zeros and Pi Zero Ws.

tromper
Posts: 4
Joined: Sat Oct 07, 2017 12:24 pm

Re: Raspbian Stretch Headless Setup Procedure

Sat Oct 07, 2017 12:33 pm

Hi,

I have been following a tutorial on "how to set up wifi" on my raspi (raspbian stretch newest version). It is just here http://www.circuitbasics.com/raspberry- ... fi-dongle/

I just got to the point where i had to write the following code in the wpa_supplicant.conf file:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
ssid="YOUR WIFI NETWORK NAME"
psk="YOUR WIFI PASSWORD"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
id_str="YOUR WIFI NETWORK NAME"
}

After rebooting the pi i tried entering Putty or looking for the pi's IP with "advanced ip scanner" but none of the seem to detect the pi, even if it is connected via ETHERNET to my router. So now i can not acces my RaspBerry.

Do anyone know how to solve this? I would be grateful because it is a project for my university and i can not waste much time in these previous steps. THANKS

tromper
Posts: 4
Joined: Sat Oct 07, 2017 12:24 pm

Re: Raspbian Stretch Headless Setup Procedure

Sat Oct 07, 2017 12:35 pm

Hi,

I have been following a tutorial on "how to set up wifi" on my raspi (raspbian stretch newest version). It is just here http://www.circuitbasics.com/raspberry- ... fi-dongle/

I just got to the point where i had to write the following code in the wpa_supplicant.conf file:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
ssid="YOUR WIFI NETWORK NAME"
psk="YOUR WIFI PASSWORD"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
id_str="YOUR WIFI NETWORK NAME"
}

After rebooting the pi i tried entering Putty or looking for the pi's IP with "advanced ip scanner" but none of the seem to detect the pi, even if it is connected via ETHERNET to my router. So now i can not acces my RaspBerry.

Do anyone know how to solve this? I would be grateful because it is a project for my university and i can not waste much time in these previous steps. THANKS

User avatar
HawaiianPi
Posts: 4534
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Stretch Headless Setup Procedure

Sun Oct 08, 2017 11:56 am

tromper wrote:
Sat Oct 07, 2017 12:35 pm
Do anyone know how to solve this?
Yes, stop using old tutorials that are no longer relevant.

SSH is now disabled by default for security reasons, and you don't need (or even want) to edit network interfaces. That wpa_supplicant.conf also had a lot of unnecessary crap in it.

Here's how you do it.

1. Grab the latest Raspbian image from https://www.raspberrypi.org/downloads/raspbian/
2. Grab the Etcher software from https://etcher.io/
3. Install Etcher and use it to write the Raspbian image to your SD card.
...You don't need to extract the image or format the card prior to writing. Just choose the .zip archive, pick your SD card and write.
4. Remove and reinsert the SD card so that your Windows or Mac PC can see the small FAT32 partition on the SD card.
5. On that partition create a file with the name ssh or ssh.txt (this file can be empty, the contents don't matter).
6. If you are going to connect to a WiFi network, create another file called wpa_supplicant.conf which has the following inside.

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
	key_mgmt=WPA-PSK
}
...Edit country=, ssid= and psk= with your information and save the file.

7. Safely eject the card from your PC and use it to boot the Pi.

If you have done everything correctly, Raspbian will find the ssh file, enable SSH and delete the ssh file, and when it finds the wpa_supplicant.conf file it will move it to its correct location and connect to your network. The first boot can take awhile because Raspbian does some housekeeping and reboots so give it a minute or so and then you should be able to SSH into it.

Once you connect you will receive a warning about having SSH enabled with the default password. Heed that warning, change the password and reboot before doing anything else. You can change the password with the Raspbian configuration utility or with the passwd command.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

Re: Raspbian Stretch Headless Setup Procedure

Sat Oct 28, 2017 2:41 pm

HawaiianPi wrote:
Sun Oct 08, 2017 11:56 am

Here's how you do it.
...
Can you suggest how to get this working with Jessie Stretch Lite on a Pi Zero W? I've followed your instructions using 2017-09-07-raspbian-stretch-lite.img and WiFi is not coming up.

Contents of /etc/wpa_supplicant/wpa_supplicant.conf (SD card mounted in my PC)

Code: Select all

root@olive:/media/hbarta/9a7608bd-5bff-4dfc-ac1d-63a956744162/etc/wpa_supplicant# cat wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="IoT_Test"
	psk="not really this"
	key_mgmt=WPA-PSK
}
root@olive:/media/hbarta/9a7608bd-5bff-4dfc-ac1d-63a956744162/etc/wpa_supplicant# 
Following boot ifconfig reports

Code: Select all

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:ad:34:06  txqueuelen 1000  (Ethernet)
        RX packets 8  bytes 968 (968.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 11  bytes 1614 (1.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Last three lines reported by 'dmesg' are

Code: Select all

[   31.836812] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   31.836830] brcmfmac: power management disabled
[   33.279779] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Lines in /var/log/daemon.log that include 'wlan0' or 'dhcpd 'include:

Code: Select all

Sep  7 15:54:51 raspberrypi dhcpcd[332]: wlan0: starting wpa_supplicant
Sep  7 15:54:51 raspberrypi systemd-udevd[149]: Process '/usr/sbin/th-cmd --socket /var/run/thd.socket --passfd --udev' failed with exit code 1.
Sep  7 15:54:51 raspberrypi systemd-udevd[142]: Process '/usr/sbin/th-cmd --socket /var/run/thd.socket --passfd --udev' failed with exit code 1.
Sep  7 15:54:51 raspberrypi systemd-udevd[157]: Process '/usr/sbin/th-cmd --socket /var/run/thd.socket --passfd --udev' failed with exit code 1.
Sep  7 15:54:52 raspberrypi dhcpcd-run-hooks[365]: wlan0: starting wpa_supplicant

Code: Select all

Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: waiting for carrier
Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: carrier acquired
Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: adding address fe80::b549:c429:1d03:7783
Sep  7 15:54:54 raspberrypi dhcpcd[332]: DUID 00:01:00:01:21:44:28:4e:b8:27:eb:ad:34:06
Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: IAID eb:ad:34:06
Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: carrier lost
Sep  7 15:54:54 raspberrypi dhcpcd[332]: wlan0: deleting address fe80::b549:c429:1d03:7783

Code: Select all

Sep  7 15:55:24 raspberrypi dhcpcd[332]: timed out
Sep  7 15:55:24 raspberrypi dhcpcd[332]: forked to background, child pid 461
Sep  7 15:55:24 raspberrypi systemd[1]: Started dhcpcd on all interfaces.
Sep  7 15:55:24 raspberrypi systemd[1]: Reached target Network.
Sep  7 15:55:24 raspberrypi systemd[1]: Reached target Network is Online.
Suggestions for how to get this working or pointers to a guide to getting Stretch/Lite working on a Pi Zero would be highly appreciated. Same H/W (different SD card with Jessie/Lite)continues to work w/out any difficulty.

Thanks!

Edit.0: I plugged this card int a Pi 3B and the Wifi connection worked. Presently running ant update/upgrade to see if that makes a difference back in the Zero W.

Edit.1: After updating Stretch (using a Pi 3B) WiFi now works on a Pi Zero W. That suggests that the next Raspbian release will fix this. Is there some place I can file a bug report to make sure this is tested before the next release?

Edit.2: https://github.com/raspberrypi/linux/issues/2249

vickeyhort
Posts: 1
Joined: Mon Nov 13, 2017 5:48 pm

Re: Raspbian Stretch Headless Setup Procedure

Mon Nov 13, 2017 5:54 pm

There is no need of bulky wpa_supplicant.conf file. only following line is necessary along with WiFi SSID & Password.
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

For complete information and video tutorial visit Raspbian Stretch Headless Setup on Raspberry Pi Zero
Last edited by vickeyhort on Fri Apr 27, 2018 10:57 am, edited 1 time in total.

User avatar
HawaiianPi
Posts: 4534
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Stretch Headless Setup Procedure

Mon Nov 13, 2017 6:58 pm

vickeyhort wrote:
Mon Nov 13, 2017 5:54 pm
There is no need of bulky wpa_supplicant.conf file. only following line is necessary along with WiFi SSID & Password.
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
And this is exactly how we ran into trouble with Jessie and Stretch. The full wpa_supplicant.conf file should be recommended because we don't know when things might change again. We already have enough bad info left over from Jessie, let's not make the same mistake again. When you configure WiFi with the Raspbian GUI it puts that extra info in there for some reason. It may not be needed now, but telling people to leave it out is asking for trouble down the road.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5880
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Raspbian Stretch Headless Setup Procedure

Mon Nov 13, 2017 8:02 pm

HawaiianPi wrote:
Mon Nov 13, 2017 6:58 pm
vickeyhort wrote:
Mon Nov 13, 2017 5:54 pm
There is no need of bulky wpa_supplicant.conf file. only following line is necessary along with WiFi SSID & Password.
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
And this is exactly how we ran into trouble with Jessie and Stretch. The full wpa_supplicant.conf file should be recommended because we don't know when things might change again. We already have enough bad info left over from Jessie, let's not make the same mistake again. When you configure WiFi with the Raspbian GUI it puts that extra info in there for some reason. It may not be needed now, but telling people to leave it out is asking for trouble down the road.
Indeed. Removing update_config=1 may possible cause issues with some tools that communicate with wpa_supplicant.
HankB wrote: Sep 7 15:54:54 raspberrypi dhcpcd[332]: wlan0: carrier lost
That's not looking good. If you do iwlist wlan0 scan, do you see the AP and what is the signal strength? It may indicate your pi zero w is faulty (unlikely, but a possibility).

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5880
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Raspbian Stretch Headless Setup Procedure

Tue Nov 14, 2017 12:43 pm

Just checked the effect of removing update_config=1 and, as expected, it does break anything that tries to update wpa_supplicant via the control interface (the desktop plugin for it and raspi-config).

HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

Re: Raspbian Stretch Headless Setup Procedure

Wed Nov 15, 2017 12:45 am

ShiftPlusOne wrote:
Mon Nov 13, 2017 8:02 pm
HankB wrote: Sep 7 15:54:54 raspberrypi dhcpcd[332]: wlan0: carrier lost
That's not looking good. If you do iwlist wlan0 scan, do you see the AP and what is the signal strength? It may indicate your pi zero w is faulty (unlikely, but a possibility).
It turned out that the Zero W was not faulty (to some extent.) I confirmed this with:
- Two Pi Zero Ws I had behaved the same.
- Both Pi Zero Ws work w/out problem using a fresh install of Raspbian Jessie Lite.
- A Fresh install of Raspbian Jessie Stretch connected without difficulty on first boot on a Pi 3 B. After updating the S/W ('apt update; apt upgrade') the install brought a Zero W on line w/out further intervention.
- After updating the firmware on both Pi Zero Ws (using raspi-update) both were able to connect to WiFi on a fresh install of Stretch Lite on first boot.

It seems that there was some sort of incompatibility between Stretch Lite and the Pi Zero W that caused WiFi not to work. I did not try 'iwlist wlan0 scan' before updating the firmware and can no longer reproduce the problem since updating firmware.

thanks,
hank

cephasiii
Posts: 7
Joined: Sun Jan 08, 2017 1:02 pm

Re: Raspbian Stretch Headless Setup Procedure

Fri Dec 29, 2017 3:48 am

Yazidapple wrote:
Sun Aug 20, 2017 11:07 am
To set any Raspberry Pi in headless mode, you'll only need your Pi with pre-loaded Raspbian OS (latest is Stretch) and your Wi-Fi network.
Make sure you know your Wi-Fi SSID and Password in order to perform headless setup.

Once you've burned/etched the Raspbian image onto the microSD card, connect the card to your working PC and you'll see the card being mounted as "boot". Inside this "boot" directory, you need to make 2 new files. You can create the files using Atom code editor.

Step 1: Create an empty file. You can use Notepad on Windows or TextEdit to do so by creating a new file. Just name the file ssh. Save that empty file and dump it into boot partition (microSD).

Step 2: Create another file name wpa_supplicant.conf . This time you need to write a few lines of text for this file. For this file, you need to use the FULL VERSION of wpa_supplicant.conf. Meaning you must have the 3 lines of data namely country, ctrl_interface and update_config

Code: Select all


country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="your_real_wifi_ssid"
    scan_ssid=1
    psk="your_real_password"
    key_mgmt=WPA-PSK
}

Still works! Thanks for the tutorial.

daNNy_Gl0ver
Posts: 3
Joined: Fri Jan 05, 2018 8:59 am

Re: Raspbian Stretch Headless Setup Procedure

Fri Jan 05, 2018 9:07 pm

I think it is worth adding...do include the double quotes when entering the ssid and psk. Don't be like me and waste an entire day wondering if your pi is broken or not :oops:

blockchainluv
Posts: 1
Joined: Mon Jan 29, 2018 6:11 pm

Re: Raspbian Stretch Headless Setup Procedure

Mon Jan 29, 2018 6:24 pm

Hi - I followed the advice here and managed a headless set-up and now using vnc viewer (so, not so headless now). I added ssh and added the wpa_supplicant file..with the following:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network {
    ssid="MY SSID"
    scan_ssid=1
    psk="MYPASSWORD"
    key_mgmt=WPA-PSK
}
All good....except i want to use the wlan and this is not recognised wlan0:not associated - i attempted to fix this and ended up corrupting my install and having to repeat the whole process. Any idea how i can change to wifi (currently linked by ethernet cable), without having to redo everything....Thanks!

mattmiller
Posts: 2102
Joined: Thu Feb 05, 2015 11:25 pm

Re: Raspbian Stretch Headless Setup Procedure

Wed Jan 31, 2018 7:07 am

Couple of points

1. There is no need to change ssh.txt to ssh

2. You don't seem to have shown that Bonjour for Windows needs to be installed

User avatar
rpdom
Posts: 15022
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Raspbian Stretch Headless Setup Procedure

Wed Jan 31, 2018 8:01 am

mattmiller wrote:
Wed Jan 31, 2018 7:07 am
Couple of points

1. There is no need to change ssh.txt to ssh

2. You don't seem to have shown that Bonjour for Windows needs to be installed
3. There is no need to use the SD Card Formatter when using Etcher.

HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

Re: Raspbian Stretch Headless Setup Procedure

Sat Feb 10, 2018 2:15 am

blockchainluv wrote:
Mon Jan 29, 2018 6:24 pm
Hi - I followed the advice here and managed a headless set-up and now using vnc viewer (so, not so headless now). I added ssh and added the
...
All good....except i want to use the wlan and this is not recognised wlan0:not associated - i attempted to fix this and ended up corrupting my install and having to repeat the whole process. Any idea how i can change to wifi (currently linked by ethernet cable), without having to redo everything....Thanks!
You/re now in the realm of debugging wireless. Good that you have a wired connection as that will help. The alternative is to temporarily use a keyboard and monitor.

Incidentally I had a similar problem at my son's place a couple weeks ago. It turns out that the AP I was trying to use was set to 5GHz only and the built in WiFi does not work with that.

Places I would start would be looking at the results of 'iwlist scanning` which should list visible access points. I would also look at the output for 'dmesg' to see if there are any hints of a problem. I would also look at the various logs in /var/log to see if there is any indication of why you cannot connect.

If you haven't already done so, you should probably start another thread focused on WiFi debugging. For that matter you should also look for other threads on WiFi debugging for further hints on your issue. You are not likely to be the the first to deal with this.

with apologies for the delayed reply,
hank

n67
Posts: 938
Joined: Mon Oct 30, 2017 4:55 pm

Re: Raspbian Stretch Headless Setup Procedure

Sat Feb 10, 2018 2:48 am

3. There is no need to use the SD Card Formatter when using Etcher.
4. There is no need to use the SD Card Formatter when using NOOBS/PINN.

Yes, there is an obscure edge case where you do need to do something with the partitions, to get them back into the needed configuration, but that is easily handled in about a thousand other ways that do not involve installing a foreign 3rd party software package on your Windows box.
"L'enfer, c'est les autres"

G fytc hsqr rum umpbq rm qyw rm rfc kmbq md rfgq dmpsk:

Epmu Sn!

J lnacjrw njbruh-carppnanm vxm rb mnuncrwp vh yxbcb!

User avatar
HawaiianPi
Posts: 4534
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Stretch Headless Setup Procedure

Sat Feb 10, 2018 3:45 am

blockchainluv wrote:
Mon Jan 29, 2018 6:24 pm
Hi - I followed the advice here and managed a headless set-up and now using vnc viewer (so, not so headless now). I added ssh and added the wpa_supplicant file..with the following:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network {
    ssid="MY SSID"
    scan_ssid=1
    psk="MYPASSWORD"
    key_mgmt=WPA-PSK
}
All good....except i want to use the wlan and this is not recognised wlan0:not associated...
The wlan0:not associated message means the wireless is working, but has not connected to any router or access point, and that means something is wrong with your wpa_supplicant.conf file.

Why do you have scan_ssid=1 in there? Do you have your SSID hidden? If so, unhide it. That does not make your network more secure, in fact it actually makes it less secure and creates unnecessary connection headaches.

Make sure your wpa_supplicant.conf is edited with a pure text editor. Embedded control or formatting characters added by word processors will break it.

Since you have a VNC connection you could try the GUI wireless setup.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

whiteFang
Posts: 1
Joined: Wed Apr 04, 2018 7:26 am

Re: Raspbian Stretch Headless Setup Procedure

Wed Apr 04, 2018 7:29 am

Currently using raspbian stretch , and the wifi doesnt seem to be connecting . Sometimes it does , but that is after 5 - 6 minutes on boot .

HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

Re: Raspbian Stretch Headless Setup Procedure

Wed Apr 04, 2018 2:35 pm

That's kind of a tough situation. If it connects at all, it seems that you have the configuration correct. It may be harder to figure out the delay and that comes down to basic troubleshooting.

Do you have a console (monitor & keyboard) available? If so, look at the results of the command 'iwlist scanning' which will show a bunch of information for the access points (APs) that your Pi sees.

The next place I'd look is the logs in /var/log/. I see messages related to 'wlan0' in kern.log, messages and daemon.log.

You might also tell us more about your situation: Which Pi, which version of the OS.

Once you get everything on the network you should also upgrade all S/W packages, but I doubt this will have a significant impact.

Lastly, consider opening your own thread. Your issue is not related to headless setup as you seem to already have that working. Your issue is more related to debugging slow connection establishment.

User avatar
JohnBeardmore
Posts: 211
Joined: Thu Nov 15, 2012 11:03 pm
Location: Derbyshire UK.
Contact: Website

Re: Raspbian Stretch Headless Setup Procedure

Mon Apr 09, 2018 1:18 pm

Where do you put the wpa_supplicant.conf file when making a headless system ?

Thanks, J/.
Author of oBeMS open source Building energy Management System.
Automatic Meter Reading (AMR), Building Management System (BMS),
Building Energy Management System (BEMS), Infrastructure Control System (ICS).
See: http://t4sustainability.co.uk/oBeMS/

User avatar
B.Goode
Posts: 8271
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Raspbian Stretch Headless Setup Procedure

Mon Apr 09, 2018 1:57 pm

JohnBeardmore wrote:
Mon Apr 09, 2018 1:18 pm
Where do you put the wpa_supplicant.conf file when making a headless system ?

Thanks, J/.
A freshly created Raspbian Stretch microSD card will contain two partitions. If opened with a Windows PC only the first, smaller, FAT-formatted, Windows accessible partition will be visible. The partition concerned will have a label 'boot'. Once the system has booted from the microSD card this will become the /boot directory in the running Linux / Raspbian system.


That's where the wpa_supplicant.conf and ssh files go: directly into that Windows-visible folder, not into any sub-folder or anything the least bit tricky...


There is no new information here. It is simply re-hashed from Raspberry Pi Foundation documentation here: https://www.raspberrypi.org/documentati ... /README.md
3. Enable SSH on a headless Raspberry Pi (add file to SD card on another machine)
For headless setup, SSH can be enabled by placing a file named ssh, without any extension, onto the boot partition of the SD card from another computer. When the Pi boots, it looks for the ssh file. If it is found, SSH is enabled and the file is deleted. The content of the file does not matter; it could contain text, or nothing at all.

If you have loaded Raspbian onto a blank SD card, you will have two partitions. The first one, which is the smaller one, is the boot partition. Place the file into this one.

kitramos
Posts: 3
Joined: Sat May 26, 2012 5:27 pm

Re: Raspbian Stretch Headless Setup Procedure

Sun Apr 15, 2018 6:41 pm

I tried putting the file in the boot partition, tried it both with and with out the.txt. as I don't have access to the boot folder with out doing a lot of extra work. (as I'm on windows so it can't see inside the larger partition) and couldn't log in at all, I can get the login prompt to appear but every user/pass combination I try fails.
only way I could get it to let me in was to load up a linux VM attach the sd card to that, then mount the bigger partition and put the file in the boot folder. then I could login using the usal pi/raspberry login.
would make it so much easier if it really was just plopping in the file in the boot partition.

I also don't see why we can't have ssh enabled by default. I know the argument that having ssh enabled on linux type systems if your not using it is bad, yet unlike a desktop install it's not uncommon to want to setup and use these headless. also unless you port foward to the pi then only the people on the local network are going to even be able to get to the login screen and i'd bet for most people, there's no one else on the local network, least not that they don't already trust since it's their home network.

Return to “General discussion”