rkanton
Posts: 9
Joined: Tue Apr 30, 2013 4:05 pm

raspberrypi-sys-mods install failure

Tue Oct 18, 2016 6:03 pm

I just did a apt-get upgrade today (20161018) and it looks like there is a issue with the raspberrypi-sys-mods post install script. I think there is a missing "fi" before line 45 in the raspberrypi-sys-mods.postinst script.

Here's the console output:
Setting up raspberrypi-sys-mods (20161018+1) ...
/var/lib/dpkg/info/raspberrypi-sys-mods.postinst: 49: /var/lib/dpkg/info/raspberrypi-sys-mods.postinst: Syntax error: ";;" unexpected (expecting "fi")
dpkg: error processing package raspberrypi-sys-mods (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
raspberrypi-sys-mods
E: Sub-process /usr/bin/dpkg returned an error code (1)


- Bob Anton

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5764
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: raspberrypi-sys-mods install failure

Tue Oct 18, 2016 6:10 pm


ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5764
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: raspberrypi-sys-mods install failure

Tue Oct 18, 2016 6:22 pm

Should be fixed now.

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade

Return to “General discussion”